Pre-Dev-Update Thread! Yay! :D

Looks like we need to be patient for a little while longer.
Not currently able to put data.

8 Likes

What versions do you have?
I downloaded 0.39.0 and built it.
The final lines of the build process raised a red flag…

Compiling igd v0.12.0
   Compiling reqwest v0.11.6
   Compiling qp2p v0.27.2
   Compiling safe_network v0.39.0 (/home/willie/projects/maidsafe/safe_network-0.39.0/sn)
   Compiling sn_api v0.38.0 (/home/willie/projects/maidsafe/safe_network-0.39.0/sn_api)
   Compiling sn_cmd_test_utilities v1.1.0 (/home/willie/projects/maidsafe/safe_network-0.39.0/sn_cmd_test_utilities)
   Compiling sn_cli v0.38.0 (/home/willie/projects/maidsafe/safe_network-0.39.0/sn_cli)
    Finished release [optimized] target(s) in 5m 09s
willie@leonov:~/projects/maidsafe/safe_network-0.39.0$ cd target/release/
willie@leonov:~/projects/maidsafe/safe_network-0.39.0/target/release$ ll
total 138044
drwxrwxr-x   7 willie willie     4096 Nov 12 22:19 ./
drwxrwxr-x   3 willie willie     4096 Nov 12 22:19 ../
drwxrwxr-x 117 willie willie    12288 Nov 12 22:15 build/
-rw-rw-r--   1 willie willie        0 Nov 12 22:15 .cargo-lock
drwxrwxr-x   2 willie willie    81920 Nov 12 22:19 deps/
drwxrwxr-x   2 willie willie     4096 Nov 12 22:15 examples/
drwxrwxr-x 485 willie willie    36864 Nov 12 22:15 .fingerprint/
drwxrwxr-x   2 willie willie     4096 Nov 12 22:15 incremental/
-rw-rw-r--   1 willie willie    13150 Nov 12 22:19 libsafe_network.d
-rw-rw-r--   2 willie willie 50488640 Nov 12 22:18 libsafe_network.rlib
-rw-rw-r--   1 willie willie    15439 Nov 12 22:19 libsn_api.d
-rw-rw-r--   2 willie willie 11164248 Nov 12 22:18 libsn_api.rlib
-rw-rw-r--   1 willie willie    15538 Nov 12 22:19 libsn_cmd_test_utilities.d
-rw-rw-r--   2 willie willie  1387986 Nov 12 22:18 libsn_cmd_test_utilities.rlib
-rwxrwxr-x   2 willie willie  7923624 Nov 12 22:19 log_cmds_inspector*
-rw-rw-r--   1 willie willie    13232 Nov 12 22:19 log_cmds_inspector.d
-rwxrwxr-x   2 willie willie 31114984 Nov 12 22:19 safe*
-rw-rw-r--   1 willie willie    17309 Nov 12 22:19 safe.d
-rwxrwxr-x   2 willie willie 31054688 Nov 12 22:19 sn_node*
-rw-rw-r--   1 willie willie    13210 Nov 12 22:19 sn_node.d
-rwxrwxr-x   2 willie willie  7936712 Nov 12 22:19 testnet*
-rw-rw-r--   1 willie willie    13210 Nov 12 22:19 testnet.d
willie@leonov:~/projects/maidsafe/safe_network-0.39.0/target/release$ ./safe --version
sn_cli 0.38.0

and then

willie@leonov:~/projects/maidsafe/safe_network-0.39.0/target/release$ ./safe node bin-version
safe_network 0.36.4

Note these are the versions from the newly built 0.39.0 target/release dir. They just happen to match the versions I already have in ~/.safe/cli and ~/.safe/node.

I can put fine with these versions but get is a different story


willie@leonov:~/projects/maidsafe/safe_network-0.39.0/target/release$ RUST_BACKTRACE=1 safe files get "safe://hyryyryynoiqr7xgexgpztdqhzjc44nnn3aku9tfz39hzu7rikzhpcure674yeuy?v=h5j8qyguyckqg3x551wnkg1qe3t6hxrzzai7hchgeqrgdkt1oyuio" ~/projects/maidsafe/retreived/
Error: 
   0: NetDataError: Failed to GET Blob: NoResponse

Location:
   /rustc/c8dfcfe046a7680554bf4eb612bad840e7631c4b/library/core/src/result.rs:1897

  ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ BACKTRACE ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
                                ⋮ 2 frames hidden ⋮                               
   3: safe::subcommands::files::files_commander::{{closure}}::he1874d1bb8e98278
      at <unknown source file>:<unknown line>
   4: safe::cli::run_with::{{closure}}::hde1b77550f56abc8
      at <unknown source file>:<unknown line>
   5: <core::future::from_generator::GenFuture<T> as core::future::future::Future>::poll::hb4afedec38d55131
      at <unknown source file>:<unknown line>
   6: tokio::park::thread::CachedParkThread::block_on::h4b7b0e0fbf95d12a
      at <unknown source file>:<unknown line>
   7: tokio::runtime::thread_pool::ThreadPool::block_on::h545f8f897b863791
      at <unknown source file>:<unknown line>
   8: safe::main::h2555b0a43308e615
      at <unknown source file>:<unknown line>
   9: std::sys_common::backtrace::__rust_begin_short_backtrace::ha34c5858aff57cda
      at <unknown source file>:<unknown line>
  10: std::rt::lang_start::{{closure}}::hccc2a1f0cf9113a5
      at <unknown source file>:<unknown line>
  11: core::ops::function::impls::<impl core::ops::function::FnOnce<A> for &F>::call_once::h5edb75ac3af12064
      at /rustc/c8dfcfe046a7680554bf4eb612bad840e7631c4b/library/core/src/ops/function.rs:259
  12: std::panicking::try::do_call::h4398f4e6da05592f
      at /rustc/c8dfcfe046a7680554bf4eb612bad840e7631c4b/library/std/src/panicking.rs:401
  13: std::panicking::try::h3fe03463ab3f9a9d
      at /rustc/c8dfcfe046a7680554bf4eb612bad840e7631c4b/library/std/src/panicking.rs:365
  14: std::panic::catch_unwind::h3f31a496b3e5f0e5
      at /rustc/c8dfcfe046a7680554bf4eb612bad840e7631c4b/library/std/src/panic.rs:434
  15: std::rt::lang_start_internal::{{closure}}::h24e3f631c8bb6bd5
      at /rustc/c8dfcfe046a7680554bf4eb612bad840e7631c4b/library/std/src/rt.rs:45
  16: std::panicking::try::do_call::h9268f45ee0925288
      at /rustc/c8dfcfe046a7680554bf4eb612bad840e7631c4b/library/std/src/panicking.rs:401
  17: std::panicking::try::he93fcdbaacc3daf7
      at /rustc/c8dfcfe046a7680554bf4eb612bad840e7631c4b/library/std/src/panicking.rs:365
  18: std::panic::catch_unwind::hca9f2323bf3773b4
      at /rustc/c8dfcfe046a7680554bf4eb612bad840e7631c4b/library/std/src/panic.rs:434
  19: std::rt::lang_start_internal::hfee0032b3594c35b
      at /rustc/c8dfcfe046a7680554bf4eb612bad840e7631c4b/library/std/src/rt.rs:45
  20: main<unknown>
      at <unknown source file>:<unknown line>
3 Likes

sn_cli 0.38.0
safe_network 0.39.0

What OS are you on?
I have built on 20.4 and used the latest releases to no avail but… put for me is working on 18.4!! get not happening though.
Also memory on 20.4 is through the roof, about 10 fold that of bionic beaver.

3 Likes

Ubuntu 20.04 and memory usage seems fine.
Like I said, I thought I was building both sn_node and safe itself 0.39.0 but the versions reported were 0.36.4 and 0.38.0 respectively.
As an aside safe update refused to play


willie@leonov:~/projects/maidsafe/safe_network-0.39.0/target/release$ safe update
Checking target-arch... x86_64-unknown-linux-musl
Checking current version... v0.38.0
Checking latest released version... v0.38.0
Update status: `0.38.0`!

Thats my "working " safe version btw, not the newly built “0.39.0”

willie@leonov:~/projects/maidsafe/safe_network-0.39.0/target/release$ which safe
/home/willie/.safe/cli/safe

and the newly built safe binary gives me this…

willie@leonov:~/projects/maidsafe/safe_network-0.39.0/target/release$ ./safe update
Current version is 0.38.0
No releases are available on GitHub to perform an update

this is true…

1 Like

0.39.0 & 0.38.0 works for me on Ubuntu 18.4 put and get

This is not the case when I build @Southside

1 Like

did you download the binary or build from source? Not that it should make any difference…

Downloaded it. Was about to build because get was not working (just to try), but while building I tried to get again and voila.

edit: IDK what the hell has changed, but now it is working for me on both machines, probably need to step away from the screen for a while.

I feel like I am losing my mind but everything seems to be working just fine now.

My eyes are wobbly, it is late and I am going to bed, if things continue to work in the morning, a test sounds like a great idea!

8 Likes

Are we there yet?

Sitting here with a mug of coffee and a cream horn* and a mounting sense of anticipation.

Yums-yums are sooooo last year.

*This not a euphimism.

8 Likes

F5 is getting sick of my harsh touches!!

6 Likes

ye aw agog, urrye?

1 Like

Looks like there is healthy competition for first today

4 Likes

my meter is off the scale !!

8 Likes

Shall we let @neik have it been trying for weeks :joy:

5 Likes

I’m sorry, but I’m lurking today for the first :dragon:


Privacy. Security. Freedom

4 Likes

It’s only sweet if it honestly earned lol

4 Likes

Looks like you will be fighting dimitar for it anyway

4 Likes

Tuning… hearing something… lement AE for DKG messag…white noise…prisingly high impact on connection use, shaving off 500 or … white noise … tests passing…

@Southside does your meter catch any of this?

3 Likes

My meter is unmonitored for now. My desk is full of bits as the BigBox gets a new CPU + mobo and a whopping 32Gb RAM upgrade*

Once I get it all sorted and booted I will drag out the agogometer. :grin:

*Well I think it’s whopping, so there. Though the only time I ran out of RAM with 16Gb was when sn_node had memory leaks.

5 Likes

Just finished mine and turned it on fully kitted out for the first time about 5 minutes ago.
Also went 32 not knowing what I’ll ever really need it for :rofl:

4 Likes