API call return "Fields are missing"

I am trying to use the SAFE API in one of my dotNet Applications.
However, I am not able to authenticate properly.
I tried making an API call directly within my browser using the HttpRequester-Firefox plugin.

My json looks as follows:

{ "app": **[**{ "name": "Demo App", "version": "0.0.1", "vendor": "maidsafe", "id": "org.maidsafe.demo" }**]**, "publicKey": "f5uVaSXT/FFiWx7nSto7LFlySlLtDn5ocEm2vBDkLF4=", "nonce": "zsxbDqXlqsoTQ6X+ARECi9uR6qrxbO2+", "permissions": [" "] }

The repsonse is always: "Fields are missing"
I tried different things for permissions: “permissions”: [] / “permissions”: ""
The pulicKey is a byte[32] object and the nonce a byte[24] object converted to base64 using Convert.ToBase64String(byte[])

Here a screenshot of the plugin:
Any advice ?

Edit: Found my mistake already…
Corrected json without [] brackets for App-Content…
{ "app": { "name": "Demo App", "version": "0.0.1", "vendor": "maidsafe", "id": "org.maidsafe.demo" }, "publicKey": "f5uVaSXT/FFiWx7nSto7LFlySlLtDn5ocEm2vBDkLF4=", "nonce": "zsxbDqXlqsoTQ6X+ARECi9uR6qrxbO2+", "permissions": [] }

3 Likes