Accessing .safenet services

Installation of the DemoApp and Launcher were successful and appear to be working. I’ve managed to test upload and download a file. No problems. I attempt to create a service, use a template, and publish it. Everything seems to work fine.

When I attempt to access the service, by clicking the link in the DemoApp, it launches the browser but goes no where. Just the standard “Can’t Reach This Page” error message. I’m sure there’s something on my end I’ve screwed up, but not knowing enough about how the server/proxy works I can’t seem to figure it out.

WIn10/Edge, so that’s probably related. Everything appears to have firewall access.

Is it just me?

1 Like

Have you seen this link? https://maidsafe.readme.io/docs/proxy-setup

2 Likes

Thanks! That solved it. I didn’t notice anything about it during the install or setup, but I am mental, so maybe I missed it.

4 Likes

I’ve done the same thing plenty of times. It’s kind of easy to get over excited and miss things when testing such an awesome project. The possibilities for the SAFE Network are endless!

3 Likes

Tried a test page - worked fine
http://testpage.art.safenet/
Uploaded some mp3 files
but still no luck with getting them to play.
http://music.art.safenet/ just gives me the following error message
{“errorCode”:-1503,“description”:“FfiError::InvalidPath”}
If I add the filename of one of the mp3 files, like
http://music.art.safenet/hardsoul.mp3
I get a black screen that looks like it might be some kind of mp3 interface, but no sound.

EDIT
That;s interesting - What I posted was http://music.art.safenet/ followed by the mp3 file name and what showed up here was the icon to play the file. Doesn’t seem to work though.

Hello. Congrats on getting the SAFE Network up and running.

I’ve got the SAFE launcher and Demo App running, as well as the appropriate *.pac assigned to run as my Mac’s system proxy. However, my template site (http://blog.javoza.safenet/) does not load. I’ve also tried the poster’s site above, and I get the same message as mine.
“This site can’t be reached testpage.art.safenet’s server DNS address could not be found.”

Any ideas?

Can you see http://www.hello.safenet ? I expect it’s the .pac not applied.

Check you did all the steps for the pac… https://maidsafe.readme.io/docs/proxy-setup#mac-os-x-proxy-setup

Thanks for your reply David. I’ve just tried it out on another Mac computer
(on the same WiFi network) and it’s working. Perhaps restarting will help.
I’ll give it a shot and keep you updated.

1 Like

Restart did not work. Exactly the same settings at the desktop computer
that’s connecting fine. Weird!

User error: Replace User :stuck_out_tongue:

Hi, I just finished configuring the SAFE application on my MacOS X! I went ahead and uploaded some simple files from an existing website. Something simple as HTML, images, and CSS.

  1. Yes, I did configured the Proxy (WiFi) URL on Preferences>Network>Proxies>“Automatic Proxy Configuration” with the url “http://visualiser.maidsafe.net/safe_proxy.pac
  2. Yes, I did configured the Advanced>Network>Settings>“Use system proxy settings” on FireFox.
  3. I Uploaded the files on the public folder using the Safe Demo App.
  4. Then, I went to Manage Websites and published the folder and got an URL.
  5. Clicked on the URL and I got an error “Not found” on FireFox.

Any suggestions?

Thanks!

Can you see any sites ?

@dirvine : Can you see any sites ?

You mean, the site that I just uploaded?
No! I clicked on the URL and it was transferred to the Firefox Browser but to a “not found page”

Server not found

Firefox can’t find the server at x02.interstar.safenet.

Check the address for typing errors such as ww.example.com instead of www.example.com
If you are unable to load any pages, check your computer's network connection.
If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

I am able to open your site. dbl check your proxy settings.

1 Like

Hello @Savage,

Maybe there is something else I have to do. My actual proxy configuration connects to the LAN network and from there it should route to the internet. Most of my websites do! That is how BIND routes all the internal IP addresses to the WAN IP address.

  • Are you connected directly to the internet through your Network card or you also go through an internal LAN network?

Thanks!


Update1: Please, read the “Update2” This configuration here is wrong! follow the second configuration/ Ok! I got it! It was Firefox configuration I had to change. The instructions need to change and tell people to change from “Use system proxy settings” to “Automatic proxy configuration URL:” and put the proxy MaidSafe url .pac there as it shows in the image bellow;

Update2:
I am editing this post because if you read the next post @anon81773980 warn me that my previous configuration poses a security risk, so here is the new configuration;


Thanks @anon81773980 for your help!

This is funny, I will have to re-design the whole site because neither Apache or DNS are part of the SAFE Network. If I understood correctly, the SAFE Network run its own DNS and Server infra-structure.

2 Likes

That poses security risk. @bluebird posted this awhile back, if I recall correctly.

You’re better off skipping the automatic proxy configuration URL. Go with Manual proxy configuration…

Every slot - 127.0.0.1 port 8101
Check Remote DNS

You’re set to go.

1 Like

Hey @anon81773980,

I’ll sure do! Much appreciated! Thanks!

\E

@anon81773980,

The only problem I found is that I have to turn on and off each time I have to access other websites on the internet.

The .safenet extension is not going to fly. It must be safe://www.whatever.com if this is ever going to be popular among a wider audiance. Simple as that.

Create a file in your computer with this data (or save the pac file in your hard drive):

function FindProxyForURL(url, host) {
if (shExpMatch(host, “*.safenet”))
return “PROXY localhost:8101”;
return “DIRECT”;
}

and set the “automatic proxy configuration URL” to that file:

file:///“your file” (ex. file:///c:/safe_proxy.pac)

1 Like