Your first SAFE website – start to finish in just 20 minutes


#28

Definitely the most surreal site on the SAFE Network so far


#29

Nice post, i am a web designer and I am very excited about the future of pages in the safe network


#30

Hello everyone. I’ve known about SAFE for quite a while now. When I first bought some BTC I heard of the Maidsafe coin, and bought some without knowing much about the project, because I was just bowled over by the concept of a decentralized internet - it’s the future, and a necessary one.

I installed the authenticator and the browser programs in 2016, but didn’t open an account and let time pass by. Last year I saw that everything had changed and there is now this process to open an account and to start learning and using the SAFE network.

Fast forward and it’s now Nov 2018 and I figure it’s time to get up to speed. I’ve joined the forum(!) and I hope to earn the required level to open an account soon. But, all I’d like to know for the moment is a few websites that I can start to browse from within the safe browser? Basically, I have the browser installed but don’t know how to start using it…! Despite my knowledge of buying MAID, I do sadly need some guidance to start browsing the Alpha 2 network.

I uninstalled the old 2016 stuff last year, and I’ve now updated the SAFE browser I had installed with the “Peruse” browser. But until I get an account, what can I actually do? Where can I go? Also, was Peruse the right thing to install? Or SAFE Browser 0.10.2? The post here, as well as the general information at https://safenetwork.tech/how-it-works/ are both great, so I feel a bit slow basically.

My appreciation goes out to the Maidsafe team and all other contributors and supporters of what I believe will be the next step in the evolution of the internet. I believe in Maidsafe because it’s time for the net to become a real shared resource, and for privacy and civil liberties to be maintained.

Thanks for all and any replies! :slight_smile:


10 key facts about SAFE Network
#31

Hello,

I hope the OP of this topic will help you.


#32

Thank you. I guess I’m just confused because the home page of the project says that we can just start looking at sites right away after downloading the browser, and that doesn’t appear to be the case.

I’ve read some of this thread and input some of the SAFE web addresses into the Peruse browser and a message is returned “Setup Incomplete. Connection not available yet.” So, things aren’t as simple as I thought. I want to get to Level 1 to open an account to get involved, but it’s not my intention right away to start building a website or using other apps. I just wanted to have a look around the network and see what others have created so far on this test network. I’m more interested in secure communication and email rather than making a website at this stage…

Thanks again for your response.


#33

If you only want to look at (static) sites then it is enough to do the first part of
’3 mins: Get the Peruse browser’ in the OP (you don’t have to log in with an Account Secret and Password).
Here you find a list of sites to see: List of Websites/Safesites & WebIDs (Community Resources).

If you also want to test dynamic sites, like safe://pat.ter/#/home, then you have to do all the steps before '7 mins: Get the Web Hosting Manager’.
Starting from the 7 min step, site creation is explained.


#34

Hi, I joined the forum a few days ago and I have a few questions about this post

Can anyone use the same ID and same website name I have created ?
In this example will I get an error when I attempt to create a cat.jpl1 webpage?


#35

Yes jpl1 is registered with the network as a primary domain so no-one else can reuse it and you won’t be able to register it as an ID. The cat part does not have to be unique though, so cat.neuralogic would be fine.


#36

Wow that was fast, thanks for the respones but… it’s NATURAL :smile: ot neural


#37

So it is! Same applies :slightly_smiling_face:


#38

If I create a new public ID and a new version of SAFE Net comes out, the public ID will be deleted?


#39

Yes, these re all tests right now.


#40

Hi draw. Thanks for the clarification. I did just want to look around at some static sites but every one I tried from the list you recommended didn’t work. I just keep receiving the message “setup incomplete.”


#41

Which Operating Systems are you running? Windows 10, macOS, …?
Edit: the error means that the app is not yet connected to network.
Maybe firewall issues: tcp port 5483 outgoing blocked or something like that.
I’ve similar issues when trying at work.


#42

This was a great post about cats :stuck_out_tongue_winking_eye: :mouse:


#43

Hi,

I’m new to Windows so this is probably just a rookie error (be gentle). But I can’t seem to get the Web Hosting Manager working to bring me to the next step. I’ve re-downloaded the file a couple times but the same thing keeps appearing.

So I guess the real question is, how do I initialize the app?


#44

Just to check: have you created an account and are you logged in when you start the Web Hosting Manager?


#45

Could be the need to set IP address?


#46

Hi @SatoshiNakayolo,

You need to have (Edit: I can see you have trust level 1 (basic user) but others might find this useful):

  • Forum account with trust level 1 (how?). This lets you get a network invite token from the

  • Invite server (click on the network logo) <— this is where you set/update your IP address.

  • A Network login (if you don’t have one already just create one - really quick)
    In your SAFE Browser go here(if it doesn’t start there already):

  • Then when you open the web hosting manager the authenticator (shown above in the browser) will ask. you to authorise the app (web hosting manager) - authorise it.

  • That should be you.

Hope you enjoy playing around with the tool.

Here’s a list of SAFE websites that you can have a look at as well using the SAFE Browser.

Regards,
David.


#47

Hi David,

I’ve done everything listed, it’s just the last bit when it asks me to authorize the web hosting manager app that I receive an error.

I can see @happybeing pointed out it may be that i needed to set an IP address (which I did not do). I’ll try and figure out how to go back and do that now.

Thanks,
Jasper