Yep, another newbie can't do it... ;-)

Hi folks,

I’m new here. I’ve read quite a lot about getting level 1 status, going to the invitation page and getting a token, then logging in. When I achieved level 1 status I went to the invitation page, was offered a token, but since at that time I needed to upgrade my OS (Debian Linux stable ie stretch) from 32 to 64 bits first, I stopped there to do that.

I’ve now upgraded my OS, downloaded the Safenet browser and launched it. It immediately barfs with a js error:
"
Uncaught Exception:
1
at module.exports (/home/dalroth5/safe-browser-v0.9.0-linux-x64/resources/app/node_modules/@maidsafe/safe-node-app/src/native/_error.js:19:10)
at Object.ffi.init (/home/dalroth5/safe-browser-v0.9.0-linux-x64/resources/app/node_modules/@maidsafe/safe-node-app/src/native/lib.js:58:11)
at SAFEApp (/home/dalroth5/safe-browser-v0.9.0-linux-x64/resources/app/node_modules/@maidsafe/safe-node-app/src/app.js:36:9)
at Object.initializeApp (/home/dalroth5/safe-browser-v0.9.0-linux-x64/resources/app/node_modules/@maidsafe/safe-node-app/src/index.js:61:25)
at netStateCallbackHelper (/home/dalroth5/safe-browser-v0.9.0-linux-x64/resources/app/node_modules/beaker-plugin-safe-app/dist/api.js:230:11)
at Object.module.exports.module.exports._with_async_cb_initialise [as initialise] (/home/dalroth5/safe-browser-v0.9.0-linux-x64/resources/app/node_modules/beaker-plugin-safe-app/dist/api.js:389:10)
at Promise (/home/dalroth5/safe-browser-v0.9.0-linux-x64/resources/app/background-process.build.js:1631:32)
at Promise ()
at authoriseApp (/home/dalroth5/safe-browser-v0.9.0-linux-x64/resources/app/background-process.build.js:1629:10)
at dispatch.payload.Promise (/home/dalroth5/safe-browser-v0.9.0-linux-x64/resources/app/background-process.build.js:1534:9)
"
but once I’ve okayed that it goes ahead and launches a page called beaker:start which says:
"
The SAFE Network and Browser are still in test phases and may only work if you are using the latest version.

Here are few example applications to start with.
You can join the discussion on the Community forum
If you’d like to contribute to the code or have found any issues, you can find us on GitHub
Manage Applications Using Authenticator
"

I’ve tried clicking on the Authenticator link which launches a tab which just permanently shows a progress spinner and never gets anywhere. Maybe that’s where you get to put in a token, I don’t know.

I’ve also returned to the invitation web page because my IP address is nothing like it was some days ago…but it still shows that old IP address, greyed out in both places, and a greyed-out “Update Registered IP” button, so I can’t change it to get a new token.

I think my problems are at least twofold:

  1. I can’t update my registered IP address for a new token,
    and
  2. I can’t find anywhere to enter a token anyway.

:slight_smile:

I spent 25 years as a software developer so I have no doubt at all that it’s my fault–isn’t it always!–but might somebody take pity on me and tell me what I’ve broken. Thanks!

Joy

5 Likes

Hi @joyous

Here’s what should happen. I’ll go through it step by step as that may be helpful to others too. I’m also on Debian.

Download latest SAFE Browser (NOT the mock routing version) from https://github.com/maidsafe/safe_browser/releases (so safe-browser-v0.9.0-linux-x64.zip)
Unzip and launch the browser from within the resulting folder. The browser should open with a login page.
Click the create account link
You’ll now be asked for your invite code. Go to invite.maidsafe.net using your normal web browser, you’ll need to also be logged into the forum. Click through the options then on “update registered IP” and copy the token. Paste the token into the box in the SAFE Browser and continue
Enter an account secret and repeat (note it down, it can’t be recovered)
Enter a password and repeat (note it down)
Click continue and you should be logged in. The first page will be safe-auth://home/#/

It sounds like you may have some sort of connectivity problems, but can you confirm you followed those steps?

13 Likes

Hi,
Thanks for writing so quickly and helpfully. I’m writing this on my phone having shut down the Linux machine. I did everything as you said until I got a different result. I’m turning in now but tomorrow I’ll go through it again and then write again with screenshots (assuming I can post those… :wink:

3 Likes

Hi,

I think I have solved the problem. Because I was/am interested in perhaps developing for the network, I had also started some initial tasks to set up an environment for it elsewhere in my userland. To that end I had exported the “NODE_ENV” environment variable set to “dev” via my bashrc…but I didn’t know enough to know that it would mess things up elsewhere. :smiley: Once I’d nulled that out I got the login/account creation page you wrote about.

Many thanks once again for helping me out so kindly. I’ll try to do more investigation myself next time.

I have two follow-up questions to throw open to the floor.

  • Rather than just blathering on here about it, it occurs to me that perhaps a better activity might be if a change is made to ensure no repetitions eg by testing for the variable in the code and querying the user?

  • If so, is it better to change the browser source code or to write launch scripts for the different platforms which can check beforehand?

Today the current version is v.0.9.0-linux-*, I’m using the x64 variant but the change would be for all and upstream too, I presume.

Joy

3 Likes

Glad you got it working! Node seems to be the cause of many problems… The best place for your questions would be the safedev forum

You’re quite right, I shall ask those questions there.

Joy