XHV wallet trouble (Solved)

I bought some XHV a while back and just left the coins on Bittrex. Today I tried sending them to a desktop wallet for Linux I downloaded from Products – Haven Protocol XHV – Private Money, but the coins won’t show up. At some stage I clicked on what I think was a “pending” link, either in the wallet or on Bittrex, and got to this page:
Haven Blockchain Explorer
Now the wallet isn’t recognizing any transactions anymore, pending or otherwise, and I can’t see a clickable link on Bittrex. They claim the transaction has been completed.
Does anybody have any idea of what might have happened? It’s not a crazy amount of money, but it still hurts a bit.

Ping @Southside. I just saw you at least used to own some XHV until recently. Did you ever send it off of the exchange and/or use a Haven wallet?

1 Like

No - it was bought for speculation only - and I failed miserably at that.
Im just recouping a little of my losses here.

1 Like

Apparently XHV is currently doing some sort of fork. I forgot all about it and suddenly felt an urge to move my coins off of Bittrex and into a dedicated wallet. I guess I was pretty careless with my whole XHV experiment. But I would still like to understand what happened. The coins seem to have just disappeared into thin air, and since they are not supposed to be traceable by design, I guess finding them is particularly difficult. I’m not saying they did, but Bittrex stealing the coins also crossed my mind.

Does this transaction data page mean anything at all to you?


1 Like

Today the Linux desktop wallet finally found my XHV on a different computer, when I restored from seed. Problem solved!