What is the file size limit for Safe Hosting Manager?

It is 20 Megabyte.
From here:

MAX_FILE_SIZE: 20 * 1024 * 1024


Having trouble getting 0.14.1 and 0.14.0 or any SAFE browser working on my Ubuntu Linux.

It doesn’t even recognize the file as executable:

Any idea how I can get it working? Linux

Windows Errors

I’m also trying on Windows. I get a bit farther, because the SAFE Browser actually works and I’m logged into the network successfully.

But when I try to open the web_hosting_manager 0.5.1 on this Windows then it keeps giving an error loop below and never works.

I really want to upload things to SAFE and get working but these errors are making it not possible right now. Trying everything I can think of:


1 Like

any ideas? This is really roadblocking right now.

Because there’s no way to upload things through mobile right?

No Mobile web_hosting_manager or anything to that effect?

I should really update my Web-based uploader website app:

1 Like

With the Linux one it looks like you’re using the dev (Mock) version of the browser. Also you may need to add execute permissions to safe_browser. I’ve seen that serialisation error before in Windows but I can’t remember the occasion. Let me know if you need an invite code in case you want to try with a new account.


In linux the browser must be run through the terminal (the double click don’t work).
Open a terminal in the browser folder and execute with ./safe-browser.


Great thanks guys that seems like an easy fix. I actually now seem to remember doing that before on Linux a while back. Thanks very much everyone :+1:


ugh I got things mostly up on Linux, but now web-hosting-manager isn’t starting.

My console is giving this:

web-hosting-manager-v0.5.1-linux-x64/web-hosting-manager: error while loading shared libraries: libgconf-2.so.4: cannot open shared object file: No such file or directory

checking the Github dependencies. But not something I remember setting up last time on this OS

Now it can’t even find the libgconf-2.so.4 package. I guess it’s because this is a live Ubuntu instance.

Is anyone successfully running the Browser & Hosting Manager on any windows machine?

That would probably be easiest, if those programs are stable these days

Well I figured it out for now,

I had to revert all the way back to Peruse 0.7.0 and Hosting 0.5.0 to get things working on Windows, but could never get the Hosting running on Linux.

Just want to know if other people have trouble getting these newer versions running anywhere.

SB, SB Dev (both 0.14.1 and 0.14.0) and WHM all work on my Ubuntu 18.10.

To use WHM with SB Dev you need NODE_ENV=test


As far as I remember that bug is Ubuntu specific - I can launch the browser from the file manager OK on my Linux Mint machine. The workaround to launch from the terminal will work on Ubuntu.

1 Like


I’m able to run WHM 0.5.1 on my Mint 19 machine so not sure what the issue you’re facing is - I wonder if like the double click launch thing it is Ubuntu related? I’ll try on an Ubuntu VM and see if I can replicate the problem you’re facing.

1 Like

I’ve tried on my Ubuntu 18.04 VM and can get the WHM working out the box - I just downloaded the 0.5.1 release from GitHub and fired it up.

I checked the machine and I do have the libgconf package installed:

The only other point of note that I can think if is that on this particular VM I have all the build prerequisites for the SAFE Browser installed:

Although, given I just downloaded the WHM zip, extracted it and ran I’m not sure that would have any impact, just thought I would mention. I suspect the libgconfdependency is the more likely culprit.


OK… So, I fired up a brand new Ubuntu 19.04 VM (from osboxes.org is anyone is interested - great for quickly grabbing VM images). I’m meeting a similar issue but I get a slightly different error message:

$ ./web-hosting-manager
./web-hosting-manager: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory

However, for your missing dependency I think I may have found a fix / workaround - can you try this:

Please let us know how you get on!



Weirdly when I was trying to resolve my missing dependency I started getting the reference to libgconf.

I enabled all the available repositories via the Ubuntu software update tool and searched for version 2.4, found it listed but not installed, installed it and was able to launch the WHM:

Hopefully you will be able to resolve it the same way.


Yes thanks for that,

But again, I’m on an Ubuntu live persistence-less instance and it’s not even finding libgconf in the packages or letting me update.

So I think there are just some serious fundamental issues I’m facing with my “OS.”

But thanks for going through that and showing me


Does that mean you are not able to enable the universe repo (I believe the libgconf package is now hosted there rather than the main Ubuntu repo).


Yeah, it is: https://packages.ubuntu.com/bionic/libgconf-2-4. There’s also a direct download there.


Yeah I don’t think you can update live instances as it’s just running off the DVD. Why are you running it that way, out of interest?


Just quickly tried that way, after windows didn’t work. Wanted to try other options and it was easy to set up quickly.

But after getting older versions working on Windows, I don’t really need to do that anymore.

Really hope I didn’t waste anyone’s time but thanks everyone for looking into it