Web Hosting Manager Not Working (Win10)

When I start the Web Hosting Manager, it simply opens up to a white screen with a couple options in the corner.

I’ve installed the newest version and have tried reinstalling it. I assume the manager needs authentication with the browser but nothing shows up in that either. Thoughts?

Which version of SAFE Browser are you using?


v0.6.0, it should be set to update automatically.

No, automatic updates are not implemented. You need to update to new versions manually at the moment.

The newer versions of Web Hosting Manager (v0.4.3 and above) require a more recent version of SAFE Browser (v0.8.0 or above).

The latest version of SAFE Browser is v0.8.1. You can download it here :slightly_smiling_face:

1 Like

Ah. Alright, I’ll download that. The browser download on https://maidsafe.net/ seems to be v0.6.0 then as that’s where I downloaded it.

IMO @maidsafe should provide links to the Github repositories of the apps alongside those for the packaged executables on the website so that readers understand that updated versions are available.

1 Like

After downloading SAFE Browser v0.8.1, were you able to successfully execute Web Hosting Manager?

v0.4.0 still doesn’t work but I also doubt that that’s the newest version of the manager available.

can safe browser run in 32bit?or what is minimum required?

Hi Wayne,

Yes, I recently ran successful tests on 32-bit Windows 7 and 32-bit Ubuntu 16.04, both connecting to Alpha 2 and mock routing, as well as running SAFE Mail tutorial and Web Hosting Manager.

@Kkill Let’s get this solved for you.
Here’s a link to our latest releases: Release Email Example v0.4.3 and Web Hosting Example v0.4.4 · maidsafe-archive/safe_examples · GitHub
May I see a screenshot of what the options look like when you execute WHM?
Are you able to run WHM from Powershell or command prompt? If so, I’m curious to know if you receive any useful output there that points to the problem.


i using XP but now cant start my cpu…planning to buy a new one…

can i know how much your mbps upload in your country?i mean when you test safe browser

My network is currently uploading at 12 Mbps

1 Like

I can run the WHM from cmd but no errors are shown after the manager starts.
I’m also able to go to File>Open Log File in the WHM but nothing appears when I hit that either.

Hi @Kkill, just in case, can you please confirm your path to the SAFE browser executable doesn’t contain any white spaces in it? if so please make sure it doesn’t and launch the SAFE browser again; there is a known issue with that to be fixed in next release of the browser. Do the same for the WHM executable’s path afterwards.

1 Like

I don’t notice any empty spaces, just dashes and lines.

Also, I don’t think this affects whether the web hosting manager works or not, but the years for when the browser and manager were last modified are set to be 2025 and 2081.

Let me know if you have time and are comfortable with getting on a Google Hangout.
I may be able to better assess the situation there.
DM me.

This topic was automatically closed after 60 days. New replies are no longer allowed.