Waiting for establishing connection with SAF

Please edit this template with relevant info when creating a bug report.

Launcher version: [0.4.0]
Demo app version: [0.2.1]
Browser version: [Firefox 44.0 ]
Operating System: [Ubuntu 14.04.4 ]

Describe the bug with as much detail as possible:
I get a: waiting for establishing connection with SAF… Whenever I try to login

What are the steps to reproduce the bug

  1. Enter log in through launcher
  2. Click “login”

Were you able to work around this bug? How?
No, not even shutting down and restarting helps

Is there anything else that might help us fix this bug?
Don’t know :sob:


Jippy I’m back on the SAFE Network after what seems like a millennium. Sure feels good to be back home again… :stuck_out_tongue:

I still can’t explain what/who/why that happend, but I’m really happy/happy/happy that I’m on it again

[update] I’m back to Unhappy and “waiting for…”:sob:

Thanks I have shared this one with the front-end guys, so they are aware. :slight_smile:

1 Like

Hi guys. I keep getting the same error. I downloaded the latest version (0.4.4) and i was able to login. I tried again a few weeks later and the error came back. I’m using OSX 10.10.5. Any ideas? Thanks

You can download the latest launcher and demo apps here:


1 Like

Aha! Sorry i thought i had the latest. Thanks @Melvin ! :slight_smile:

1 Like

I have same error using SAFE Launcher v0.4.3
Any news?

You too, are running an old version. Refer to Melvin’s post above.

Great that did it. Thanks