User run network based on test 12b binaries


#382

Yeah my usage over the past week, peaking at six instances and various snapshots and volumes has cost $1.17 so far :slight_smile:

Data transfer accounted for $0.97…


#383

Yes mine is owned by root but the permissions allows any user to write to it. There should be no loop holes


#384

This is a aws VM I just created now and the only thing I have done with it is in the screen shot below.

If you notice the /tmp directory has the permissions “drwxrwxrwt”

This allows ANY user on the unbuntu machine to read/write/delete to/from that directory.

At the moment I have NO idea why your instance of ubuntu has /tmp locked down. Because that would “break” a lot of applications that one may install on ubuntu


#385

You are quite right - I looked again /tmp is in fact 777 but owned by root.
Pretty sure that when I did ./safe_vault first time it failed and I guessed (probably wrongly) that it was cos it could not write to /tmp.
So being lazy I just tried sudo ./safe_vault and it worked
So I continued in my ignorance…
But now Im going to continue to bed – night night :slight_smile:


#386

What are you all using to keep safe_vault running in the background after logging out of terminal? Tmux? Screen? What’s the simplest and reliable?

Also, how do you know if your vault has lost connection with the network? I’d like to set up an alarm so that I or an automated script can respond.


#387

see this response. .


#388

Its already trying to fork itself!


#389

I can’t get screen to persist the process between SSH sessions. I’m thinking of creating a docker process to daemonize safe_vault, so that I can attach and detach at any time. We’ll see…having fun sipping on hot tea tonight while I mess with this :smiley:


#390

Using screen this should be possible. Try the following:

1Login using ssh
2 Type screen
3 Ctrl + a and then hit “c” to create new screen window
4 Run vault
5 Ctrl + a followed by “0” or "n"
6 You should now be in your initial screen window (vault still running) Now type: screen -d (to detach screen session)
7 Now you are back where you logged in. Type exit to leave ssh session.
8 Re-login
9 Type screen -r (to reattach to running screen session)
10 Ctrl + a followed by “1” or “n” This should bring you back to your screen window running the vault.

Hope this helps.


#391

Thank you. I see now that I was running screen in one SSH session within GCP browser console and then I was also attempting to find that screen when I logged into a different SSH session through my local terminal. I can see screen persisting from wherever I started it.


#392

Spot the new feature…


#393

I’m in! node 87e3ef reporting for duty!
The problem was mainly that vultr uses english keyboards and I was unable to login because I can’t change the password and I’m missing certain keys on the keyboard. Or something like that. I installed mint xfce and while the gui is slow, at least it works.

/edit
It’s pretty impressive, after a vault has been accepted, it fills up with over 200MB worth of chunks within a minute or so.


#394

Nice!

INFO 17:08:34.205607229 [routing::states::node node.rs:277] ----------------------------------------------------------------
INFO 17:08:34.205781351 [routing::states::node node.rs:278] | Node(8a5cb9…(1)) PeerId(ecca0561…) - Routing Table size: 26 |
INFO 17:08:34.205932878 [routing::states::node node.rs:279] ----------------------------------------------------------------
INFO 17:08:34.224638574 [safe_vault::personas::data_manager data_manager.rs:1026] This vault has received 8118 Client Get requests. Chunks stored: Immutable: 446, Structured: 89, Appendable: 0. Total stored: 500760731 bytes.

rup


#395

i’ve found easiest way to run is to use byobu to keep session running and allow me to make new terminals very easily to keep an eye on backend, os etc… can log in and out as required…

rup


#396

Well they take paypal aswell, and once you have linked your paypal acc (don’t have to pay with it, afai understand), you can pay with Bitcoin!


#397

I’ve added one vault for now, hopefully we’re gonna get a new testnet today!

{
“hard_coded_contacts”: [
“35.167.139.205:5483”,
“108.61.165.170:5483”,
“52.65.136.52:5483”,
“206.116.50.52:5483”,
“99.199.170.208:5483”,
“31.151.192.2:5483”,
“86.184.57.178:5483”,
“13.80.119.160:5483”,
“85.93.19.51:5483”,
“35.157.162.33:5483”,
“185.16.37.149:5483”,
“35.156.220.253:5483”,
“104.207.131.126:5483”
],
“bootstrap_whitelisted_ips”: [],
“tcp_acceptor_port”: 5483,
“service_discovery_port”: null,
“bootstrap_cache_name”: null,
“network_name”: “community_network_feb_2017”
}


#398

lol :slight_smile:

That’s encouraging that you got Vultr working… I wonder I got stuck with the need for ports to be open. I didn’t know there was a GUI option.


#399

Thanks to Willie’s instructions above I’m running a vault as a VM running on my server box.

my ip is dynamic (currently 217.44.199.44) but i’ve got a dynamic dns resolver dooglet.ddns.net

fake edit: i should be able to leave this thing running but my ip might change. will the vault config accept a hostname instead of an IP?


#400

As I understand it, not all IP’s need to be in the config… the config is a seed that allows new vault to connect and then progress as needed through the network. Better to have then static IPs put to the config that others might use.


#401

Grabbed the latest Vault code, compiled it, joined the community network on AWS with it :+1:.