User run network based on test 12b binaries


#221

@Viv That is hardly spam…
This is what we are here for. Looking now.


#222

I’m tempted to put a node up but unclear what profile might be best atm…
Is a $5/month [1 CPU 768MB Memory 1000GB Bandwidth] on Vultr going to be enough for now?
It’s only 15 GB SSD but I can tweak the config for that.


#223

I’d suck it and see - depends if it can handle occaisional CPU load spikes - the AWS instances seem to fail on spikes


#224

Are we ready for blast off? If so here’s my ip: 86.184.57.178


#225

Struggling with port perhaps I just see it fall over without comment… any ideas?

root@SAFE:~/SAFE/vault/safe_vault-v0.13.0-linux-x64# ./safe_vault INFO 19:46:33.765922928 [safe_vault safe_vault.rs:95] 

Running safe_vault v0.13.0
==========================
root@SAFE:~/SAFE/vault/safe_vault-v0.13.0-linux-x64# 

I don’t know much of port opening from command line, so threw this at it:


iptables -I INPUT -p tcp --dport 5483 --syn -j ACCEPT
iptables -I INPUT -p udp --dport 5483 -j ACCEPT
iptables -I INPUT -p tcp --dport 5484 --syn -j ACCEPT
iptables -I INPUT -p udp --dport 5484 -j ACCEPT

iptables-save > /etc/network/iptables.rules

and it didn’t complain but I don’t know if it worked netstat -lntu doesn’t suggest 5383
:confused:


#226

I’ll try to find the reference but you need something similar outbound also

BTW I just connected - we seem to have a 2 node network running for now


#227

Thanks… I found something that does work for the ports but no change to the resulting flop…

sudo ufw allow 5383/tcp sudo ufw allow 5383/udp sudo ufw allow 5384/tcp sudo ufw allow 5384/udp sudo ufw enable sudo ufw status


#228

OK an update from our efforts so far tonight

I started a seed node around 17:10 UTC using an AWS instance. That failed when a 3rd node tried to join - (excess CPU load suspected)
We then tried again with a non-AWS seed node.
Results were mixed but again it seems the AWS instances are just not up to the job when the network is very small.
We expect other userss along after about 2300GMT - so hopefully we will be able to try again.

If you want to join in we will get a new list of hardcoded IPs published
also make sure the that you have
`“network_name”: “community_network_feb_2017”

in your `safe_vault.crust.config (END)


#229

Ah ha!

I think I’m up as a seed node… at least it doesn’t fall down with -f

So, try perhaps adding
45.76.81.236:5483


#230

INFO 20:14:17.325766568 [routing::states::bootstrapping bootstrapping.rs:201] Bootstrapping(f90f81…) Failed to bootstrap. Terminating.

GNU nano 2.5.3 File: safe_vault.crust.config

{
“hard_coded_contacts”: [
“45.76.81.236:5483”
],
“bootstrap_whitelisted_ips”: [],
“tcp_acceptor_port”: 5483,
“service_discovery_port”: null,
“bootstrap_cache_name”: null,
“network_name”: “community_network_feb_2017”
}


#231

I’ll leave that running now and take a break… here’s hoping it’s useful. :thumbsup:


#232

Still failing to bootstrap. Should I try ./safe_vault -f too or would that screw things up?


#233

only the very first node should use the -f

but i’m failing too


#234

I have it started on an AWS instance (again) and have a second instance connected

Try
35.157.162.33:5483
and
35.156.220.253:5483

in your crust.config files


#235

OK - thought that was probably the case


#236
ubuntu@ip-172-31-29-103:/maidsafe/safe_vault-v0.13.0-linux-x64$ ./safe_vault
INFO 20:47:17.779404931 [safe_vault safe_vault.rs:95]

Running safe_vault v0.13.0
==========================
INFO 20:47:24.085773967 [routing::states::node node.rs:1240] Node(afec91..()) Requesting a relocated name from the network. This can take a while.
INFO 20:47:24.132605636 [routing::states::node node.rs:1890] Node(f84898..()) Received relocated name. Establishing connections to 1 peers.
INFO 20:47:24.135660186 [routing::states::node node.rs:1031] Node(f84898..()) Starting approval process to test this node's resources. This will take at least 300 seconds.
INFO 20:47:24.143838335 [routing::states::node node.rs:1001] Node(f84898..()) Resource proof challenges completed. This node has been approved to join the network!
INFO 20:47:24.144014010 [routing::states::node node.rs:277]  ---------------------------------------------------------------
INFO 20:47:24.144111335 [routing::states::node node.rs:278] | Node(f84898..()) PeerId(c003d659..) - Routing Table size:   1 |
INFO 20:47:24.144263738 [routing::states::node node.rs:279]  ---------------------------------------------------------------

#237

Can you post your config file?


#238

{
“hard_coded_contacts”: [

"35.157.162.33:5483",
"86.184.57.178:5483",
"45.76.81.236:5483"

],
“bootstrap_whitelisted_ips”: [],
“tcp_acceptor_port”: 5483,
“service_discovery_port”: null,
“bootstrap_cache_name”: null,
“network_name”: “community_network_feb_2017”
}
safe_vault.crust.config (END)


#239

INFO 20:54:13.602191458 [routing::states::node node.rs:1031] Node(6bb3e8…()) Starting approval process to test this node’s resources. This will take at least 300 seconds.

ps: :frowning:
Failed to get approval from the network. All 1 resource proof responses fully sent. Terminating node.


#240
INFO 21:02:06.494456206 [routing::states::node node.rs:277]  --------------------------------------------------------------- 
INFO 21:02:06.494574970 [routing::states::node node.rs:278] | Node(f84898..()) PeerId(c003d659..) - Routing Table size:   2 |
INFO 21:02:06.494659837 [routing::states::node node.rs:279]  --------------------------------------------------------------- 
INFO 21:02:13.351532663 [routing::states::node node.rs:1952] Node(f84898..()) Expecting candidate da719a.. via Client { client_name: 73e250.., proxy_node_name: 9ccd48.., peer_id: PeerId(6c35d517..) }.
INFO 21:02:13.355042243 [routing::states::node node.rs:1988] Node(f84898..()) Our section with Prefix() accepted da719a.. as a candidate.
INFO 21:02:13.399876741 [routing::states::node node.rs:1363] Node(f84898..()) Sending resource proof challenge to candidate da719a..