Trezor: support for OMNI and MAID

To expand on that, not only does the trezor show you the amount and address, the trezor is the device that signs the transaction. The website could show address 1234…7890 and amount 100btc, but as long as the trezor shows what you intended it to, the correct amount will be sent to the correct address.

As you said, the website is just a nicer interface with which to interact with the trezor. Much the same way the UI guys are making nicer ways to interact with the network while the guys comfortable with “the black box you type commands in” (cli) can already play.


Would we really still need a Trezor once the safenetwork and safecoin have become a reality?

Because currently we would access the SAFENetwork from devices that can be compromised, it would be very helpful to have a way of securing our keys and identities on a hardware device.


I did a cursory review of the code and it looks ok. It’s a pretty simple react app that leverages the trezor-connect library to connect to the device and sign a transaction. Note, I have not done an in-depth code review yet but rather spent 20 minutes scanning through the code base to understand what it does, how it works, and making sure there was no glaringly obvious issues.

I tested it to send MAID that was stored on a segwit address on a Trezor and it seems to work as advertised.


I’m guessing the webpage can be downloaded from GitHub and ran locally, right? Is that what you did?

1 Like



Yes. Just clone from GitHub - tektite-software/omni-trezor: OMNI Wallet for Trezor, npm install and then npm start and it will serve the app on localhost.

1 Like

Does anyone have positive experience with omnitrezor wallet ?

Does it work only with legacy (1…) Bitcoin address or also segwit address (3…)

i tried sending 20 MAID from legacy to legacy and it gave me an error.

Can you even send MAID to a segwit address?

MrFelton says it worked

1 Like

I have made 4 transactions with Trezor T through

with Segwit addresses, all of them have been in reception as well as emission,
3 in reception and 1 in emission, but its operation is chaotic, in the own Trezoor
I have 2 wallets, in one of them I normally enter easily in the other wallet.
normally remains searching without finally appearing, other times if it appears or is its
appearance is random, even if it has more than 0.000008 satoshi requesting

It works if, but the results are sometimes chaotic, in a transaction send 1000 maid
and sent 4096 I guess I don’t know if it’s a problem of the indivisibility of the currency.
the other transactions have been with the correct value

Ultimately all transactions have worked but the results and
visibility isn’t accurate.

If they manage to correct random errors I will be happier with my Trezor.

Any comments or corrections of these errors I will receive with satisfaction.


I’m not sure what you mean here. Maybe something was lost in a (Google?) translation. What is searching for what, and what randomly appears where?

I have sent MAID to my Trezor, and I can see the MAID through Omnitrezor. But I haven’t tried sending MAID from the Trezor yet.

1 Like

Sorry about the translation

What I mean is I can’t always see the maid through omnitrezor.

In a wallet I almost always see them
in the other almost never, this is random

Then there’s the amount of maid I transfer, that the value changes,
other transfers well.

I hope this will help make it clearer what you meant.

This is worrying. Can anybody else confirm?

I’m afraid I still don’t understand this sentence.

I sometimes use Google translate too. Are you maybe writing in Spanish or Catalan? Try making the original sentences as short and correct Spanish as possible, including punctuation. That will make things easier.

What I’m trying to say

It’s just that I did a 1000 main transaction

And I got 4096 main

This is more worrisome.

the other two transfers were correct

I hope this helps.

traductor DeepL de Barcelona catalán

It would really be easier if you used standard punctuation and capitalization. I’m guessing by “main” you mean MAID. Maybe you could post the transaction id here. This is important stuff.

Sounds like a number base issue:

1000 base sixteen (hexadecimal) is 4096 base ten (decimal).

If you typed 1000h or 0x1000, that would be 4096 decimal. So maybe a programming bug?


That’s what I think.

When using legacy wallet/address I couldnt see the maids.

1 Like

I’m always using Segwit addresses.

I can’t see legacy addresses because in my trezor they don’t exist.

all are Segwit start with 3

Another thing would be to try legacy, perhaps its performance would be better

I don’t know.