Tips on using the Software released 6/8/2017- Done on Windows 7

First off, this software is a stand alone test environment using mock routing. This means it only has access to what you upload and there will be no content to see.

I created this because I thought some people might need help or have suggestions using the software you can download below:
Click here to download the Safe Browser 0.2.1
Click here to download the Web Hosting Manager.

First thing you’ll need to do after downloading the software and unzipping the contents of the files is start the SAFE Browser and register an account. To register an account you’ll need to select the “Rocket” circled in red as shown below:

Then after the Authenticator page has loaded select "Create Account" ![|509x500](upload://gf2SDMMCW2u8eHirUiLIV0mXiE4.png)
You will then be guided through the process to setup an account. When are asked for a invitation code any 4 digits will work.
After you've successfully registered an account you will need open/start the "Web Hosting Manager" software. When you first the "Web Hosting Manager" software you will asked in the SAFE Browser to allow it access. If you don't give the "Web Hosting Manager" it won't work. ![|505x420](upload://vN0K0WkNJAH61vu7aJ5soGplnrA.png)
Then you will need to "Create Public Id": ![|690x284](upload://rconCFpPiUFu77QvV5ibn0iGe5q.png)
Then you will need to "CREATE SERVICE" after: ![|690x239](upload://g2MZ4X60P49kp4n321dL43EgFSd.png)
Then you'll enter then the name of the service and then select "Create Service"(the Create Service button only becomes visible after you've entered something in the "Enter Service Name". ![|690x307](upload://15P9txVXsaPFWlovW2ZU449oTgg.png)
Then after you create the service you will need to upload your files. To do that you'll need to select the text after the name of the service as shown below circled in red: ![|690x268](upload://sBkmJUiTMn2VUKEUaPCevExKmyJ.png)
Then you'll upload the file or directory by selecting from the drop down menu that appears when you place your mouse cursor over the area pointed to by the red arrow. ![|690x220](upload://CyDW7kDgrzXRwWigpJ5miUCCLa.png)

If you don’t upload anything you will only see the following screen or something close to it(the address shown would depend on what you entered):

I’ll add more to this when I can and please offer suggestions. :slight_smile:



Great. I would suggest to add how to update files, after I upload a file I get an error message if I try to upload again after updating it.


I was getting something like that before - it worked once then failed. Haven’t had a chance to test the latest one yet, but plan to over the weekend. Are you on Windows?


Yeah, I’m on windows.

1 Like

I’m stuck at this point. I can register an account, use the web hosting manager to create a service, then upload an index.html file but can’t get it to load in the SAFE Browser. Using Windows 7.

Hi @upstate, what URL are you using to load the page on the browser?

E.g. if your public Id is my-public-id, your service is my-service and the html page you uploaded is called my-page.html, you can then access it with safe://

I had an issue like that and it worked when I restarted the browser after the upload.

If I start the browser first, then the manager and do the upload, the page won’t show until I restart the browser.

I believe that’s what it was, but I deleted everything to start over. I’ll double check in a couple of minutes. Thank you.

1 Like

Tried again and still the same:

Don’t know if this matters, but I was able to log back in with the account I’d create the first time I was using this.

When I try to clearing the “Clear Access Data” in the “SAFE Hosting Manager” I get an error also.


Finally got to try it again from home and it worked!!!

Nothing spectacular, but just happy it worked!


But when I restart everything it fails again. I was able to get the SAFE Browser reset by deleting the appdata folder associated with it, but deleting the Web Hosting Manger app data folder doesn’t work. Even after I deleted the whole folder the Web Hosting Manager was running from, unzipped a the file again and it was still showing previous information from when I got it to work the first time including it didn’t ask to be authorized in the SAFE Browser. It’s pulling cached data from some where and I can’t figure out where it is to delete it. I tried using the “Clear Data Access” option in the Manager but get the following error:

I know another release is coming down the pipeline and this isn’t big issue, but I’ll still try to figure how to reset the Manager.

Never surrender! :stuck_out_tongue:


Open Explorer and type


delete the safe folders and you can begin a fresh star.

I did and thats the strange part.

Did you delete the SafeBrowser folder too?

Yes, I deleted it. 20charachers

The mysteries of windows…

If I were you, I would delete all the directories, the %appdata% folders and both program, restart the computer and download the two programs again.

I’m sorry, but think the only remedy is to reformat the hard disk and install an operating system. :laughing:


One of these days I’ll bite the built and do it.

1 Like

Took me a while to pick up the courage - a couple of years ago I think. Not problem free, but I am so happy to be free of windows now. Anyway, I was only teasing, people should be free to sleep on beds of nails if that’s what they want :wink:

1 Like

This topic was automatically closed after 60 days. New replies are no longer allowed.