The safe browser doesnt open for me on windows 10

To more easily test the most up to date version, first download and install virtual box. Then install your favorite Linux distro in a virtual machine (debian, Ubuntu, mint etc.). You will then be able to run the latest Linux binaries or install from source.

https://safenetforum.org/t/how-to-help-testing-a-step-by-step-visual-guide-wiki-in-progress

1 Like

Yeah, I’m going to pass on that. When will it be available to everyone as a standard browser?

1 Like

It’s not a “standard” browser like Chrome, Firefox, Safari.
It will only give access to sites on the SAFE network.

For many people it works OK right now for browsing to sites like
safe://network
safe://hello
safe://safe-blues

but you are NOT going to log in to FB or buy stuff off Ebay on it. Not for a long time, anyway.

When you open it on a Mac, try typing safe://network in the address bar.

Have you installed the CLI?

I am going to have to agree with this. I am having the same issue. It is probably one of the weirdest installs I have done.

I get the github download link from Download SAFE’s latest versions

On the github page there is no README with no mention of prerequisites so one must assume it is ready to go.

Download and run install

captureSafeBrowserInstallWarning

Allow access through firewall

captureSafeBrowserFirewallAccess

Then an admin popup asking if I want to allow this program to make changes on my device. I click Yes.

That’s it. It weirdly just jumps to the desktop screen. No questions of where I want to install the file nor asking permission about desktop shortcuts, add to start menu etc. No install succeeded, would you like to run the program etc.

I notice a desktop shortcut has been placed on the desktop. Double click that and nothing happens. Right-click to check file location. It is located in user/AppData/local/programs/safe-browser

captureWINSafeBrowserFileLocation

I am on Windows 10 Home version 1903 OS build 18362.778. Intel® Core™ i3-4170 CPU @ 3.70GHz Installed RAM 4.00GB 64-Bit OS, x64-based processor

By “nothing happened”… there is no browser that opens, no screenshot possible as nothing opens. All I have is a desktop shortcut, start menu icon and a file location. When double-clicking on the desktop shortcut icon a loading circle shows up for a second or two but that’s it, no reaction. When I try to load from the Start Menu it does seem to think slightly longer but again no reaction.

I tried running the program as admin but no difference. I checked Event Viewer Administrative Events logs and this is the only warning that shows up when I try to run the browser, not sure if it relates. (sorry about the long line, I don’t know how to make paragraphs in preformatted text)

The propres à l’application permission settings do not grant Local Activation permission for the COM Server application with CLSID {2593F8B9-4EAF-457C-B68A-50F6B8EA6B54} and APPID {15C20B67-12E7-4BB6-92BB-7AFF07997402} to the user DESKTOP-QVC0DIV\USER SID (S-1-5-21-3273692350-2784694469-4056788777-1001) from address LocalHost (avec LRPC) running in the application container Non disponible SID (Non disponible). This security permission can be modified using the Component Services administrative tool. 

I had a look at the Component Services tool but I have no idea how to work that nor what to look for.

Browser properties:

CaptureWINsafeBrowserProp

I am going to do this but if it is a prerequisite it should be stated on a README on the github download page. Again, the download is available to users on this forum via Download SAFE’s latest versions and the way it is presented it seems it should just work out of the box just like the mobile browser.

4 Likes

Thanks @Haigha for the detailed outline of the issues you’re seeing. Very helpful and exactly the sort of feedback we need to be able to get to the bottom of this. :+1: This gives me something to go on. I’ll hopefully get some time to look at this later today/tomorrow.


Just to clarify something: The readme for the project you’d find at the project root on github. Not on the release page. Here you’d normally see the the release notes, which we automatically populate with significant changes (when compared to the last release in this release channel – which means alpha/beta or stable). There were non for this version compared to the previous alpha as the changes were related to the CI not the app itself. (For the stable release eg, this would generate some info as it should include all changes since last stable).

Currently we’re using the dedicated forum posts for explaining any installs/deps etc, which should ideally link to the release (or directly to the files). I’d imagine we get this more streamlined as we go. Though we could look at mixing this up / repeating info etc if it’s going to be useful… Not really sure what’s best there.


It’s not a requirement for the browser (at least for browsing). This / any other dependencies will be managed more through SNAPP most likely (and the browser will likely eventually prompt for that). Meantime though, you’re right and we should have any deps stated in the readme :+1: (and


It shouldn’t, when it comes to the stable release. And I’d love it not to be like this. But we’re looking at alpha software here I’m afraid. There are no guarantees.

We can certainly make that clearer (though it is mentioned on the baby-fleming guides as far as i recall), I’ll look at stating that at the top of the release notes :+1: .

Anyone willing to dive in to the alpha versions and provide feedback is massively appreciated! You help make the beta/stable release channels more reliable for folk! :bowing_man:

It’s also worth mentioning that PRs are always very welcome. :smiley:


If anyone is not comfortable dealing with unstable software, they are encouraged to wait for the stable releases or use the beta channel which should have such reported issues fixed (though you may still find issues).

8 Likes

+10 (can I speak for nine others :joy:) …

I am finding this stuff real fun. Perhaps finding my little niche here, actually more fun than everything working smoothly :wink: . Good job everyone and I look forward to being difficult :wink: If I push it too far or become a pain please let me know, I have a lot to learn in many arenas and appreciate critisicms/feedback.

7 Likes

This is puzzling as it doesn’t happen for me in Win 10.

@Haigha does the browser icon appear on the taskbar or in the hidden icons tray?

@joshuef would it help if @Haigha and others started the browser from the command line and reported the output?

But you still need vaults and autheticator installed, correct? I tried installing the browser ( v0.17.0-alpha.11) on Linux without the vaults and it did not connect to the network.

It only connected after I had installed the CLI and used that to install the auth and vaults and then to select the network.

3 Likes

No it does not.

This is not clear to me. I just followed the topic download latest versions link and clicked on windows safe browser. Following this path, as I assume most non-techies would do, it is the shortest path, there are no guidelines/requirements specified using this route.

I will install vaults and authenticator tonight to see if it resolves the problem…

2 Likes

It won’t solve the problem of not being able to see the browser.

Oh, OK.

Can you specify which version of Windows 10 you are, seeing as it works. Not for me but for @joshuef.

1 Like

Windows 10 Pro, version 1903, OS build 18362.778. I expect it will be some setting somewhere though, maybe https://www.techspot.com/guides/226-bring-lost-window-back-desktop/ ?

2 Likes

I would just like to remind those who are genuinely struggling to get things up and running - these are developer releases, for those who are technically minded. Don’t expect to just click a few buttons and have a polished product ready to use.

However, your constructive feedback is valuable. Barbs about expecting it to be easier, after all this time, blah, blah, blah, is not constructive and will just annoy folks.

Good luck in getting things working!

6 Likes

I dont think it is a “lost window” as the icon doesnt show in the taskbar, i will play around with my display settings though.

Yeh, that would be helpful indeed. A run form cmd line with the --debug param should give more output (and a couple of new debug console windows for where it does work)

1 Like

Vaults is only needed for running your own local testnet. authd would be needed though yeh :+1:

The CLI itself should not be required but as you note, it’s probably the simplest way to get authd atm and configure the shared vault access.

A lot of this will be handled by SNAPP (cli install / authd etc) eventually. But if you just dl the browser you’d still be left hanging, so we’ll probably have to reuse the same scripts in browser if nothing is found (as I think prompting to get SNAPP might just be a PITA if you only want to browser)

4 Likes

FAQ: Browsing is for free… why do I need authd? Can browser not default to connect unauthorized.

1 Like

Sorry, to be clear it does already default to an unauthorised connection. And so should work w/o authd installed (at least is working here. I’m not 100% sure if connecting to get updated bootstrap info is needed these days).

When webapps or browser need to store things, they’ll need permissions + therefore authd as well. So we’ll need to document that aspect, and distinguish between ‘browse’ (readonly) and ‘store’…

(cc @JimCollinson maybe something to mull over: I think clearnet ‘browse’ you expect websites to work. Here we have a ‘read only’ kind of distinction. I’m not sure how/where that’d affect other messaging, but this is one instance.)

6 Likes

Yeah, the expectation is/was that to browse the network, the user need only install the browser, and they are good to go.

Should they want to, say, save a bookmark, or make any PUTs such as commenting on a blog, they’d begin a flow to install SNAPP and log in / create an account.

8 Likes