The safe browser doesnt open for me on windows 10

Ive tried the gui some years ago around the time the logo was being voted on and it loaded ok but there wasnt any network at the time to play with it. I thought to give it another go now that theres a working network but i installed it and opened and nothing happens.

I thought maybe i needed the CLI installed to have it open and ran through the git terminal window to install it, then from there proceeded to install the auth server and everything else i could find to install that was written on the CLI github page. Disabled my firewall and tried again, still nothing.

What i am observing is the GUI opens 3 processes. If i try to open the GUI again it will continue opening 3 more procecesses. I know this is alpha and all but i was really hoping the software would do something after all these years, please advise on what i might be doing wrong. (edit: i also tried opening as admin, on an admin acct)>

Current exe at
https://github.com/maidsafe/safe_browser/releases/download/v0.17.0-alpha.11/safe-browser-v0.17.0-alpha.11-win-x64.exe

1 Like

I thought you also needed the Authenticator?


2 Likes

Trolls dont RTFM, they prefer to ask time-wasting questions in here, find a chink (like two people giving slightly different advice) and then cause further bother. Classic FUD intro stuff.

after all these years… sigh. Cry me a river

1 Like
1 Like

Club trolls with reality and turn that negative! :upside_down_face:

4 Likes

That’s something at least. Can you provide more details on your system and the exact steps you’ve taken (CLI / authd versions installed, browser version downloaded, snapp version downloaded, commands run etc)?

have you followed the guide: Baby Fleming Public Shared Section ?

And perhaps some screenshots of what you’re seeing and trying to do once these GUI processes hare running.

We have CI and end to end tests, as well as many people able to run the browser on windows. So I’d be surprised if we can’t get it going for you!

7 Likes

That’s something at least. Can you provide more details on your system and the exact steps you’ve taken (CLI / authd versions installed, browser version downloaded, snapp version downloaded, commands run etc)?

Im on windows 10, i dont know what else to say about my computer that might affect this software, its a laptop, i7 intel processor w/intel onboard gfx card. As i explained i installed the safebrowser linked on safenetwork.tech and proceeded to run it, but it did not do anything except open 3 processes. The download page had no info on how to run it. The only page i could find with any information about setup was the CLI download page https://github.com/maidsafe/safe-api/tree/master/safe-cli#download

So i proceded to download gitbash and ran the install script ```
$ curl -so- https://safe-api.s3.amazonaws.com/install.sh | bash

It installed. I followed the next step regarding using this with the mock network (baby fleming i imagine this is referring to)

$ cd safe-cli

Which returned the error “no such file or directory”. Then i ran “$ cargo build --features mock-network”

which gives the error “command not found”.

However if i just type “safe” into the gitbash window it will open the safe interactive shell. So if i try those commands again the first cd command returns “command is unknown or not supported yet”. If i run the cargo build command it returns the same error. I have also tried adding the $ before the commands and it returns the same error. The guide is not clear where else i am supposed to input this, or if it is out of date.

Moving onto the vault install section of the guide, i input “safe vault install” and also “vault install” both returned the error “command safe vault install is unknown or not supported yet”.

It doesnt appear as if i can go any further if the vault wont install as the next instructions assume it did.

edit: to followup to upstates post i downloaded the safe auth for windows and ran it and it does open a processes safe-authd.exe. Opening the safe browser alpha exe once again opens 3 processes but nothing else happens. This was attempted again with the CLI running (open gitbash and typed in “safe”). The commands listed on https://github.com/maidsafe/safe-api/blob/master/README.md are incorrrect, “safe-authd start” gives an error, the command “safe auth start” works, but its the same as running the exe.

Running “safe auth” attempst to auth the CLI but gives an error “failed - you need to log in to a safe network account first”. Trying “safe auth login --self-auth” causes the CLI to hang.

The instructions are unclear on what else can be done.

Windows support lags Linux. Try installing Linux on a virtual machine via Virtualbox. You can then use the latest tools and/or compile from source.

1 Like

Try this.

Browser

Download the latest browser from here. https://github.com/maidsafe/safe_browser/releases

Direct link to Windows version: https://github.com/maidsafe/safe_browser/releases/download/v0.17.0-alpha.11/safe-browser-v0.17.0-alpha.11-win-x64.exe

Double click on the .exe file to install it

Once installed it should open. If not you’ll find it here.

C:\Users<your-name>\AppData\Local\Programs\safe-browser\

CLI

Download the latest CLI here:

Direct link to Windows version: https://github.com/maidsafe/safe-api/releases/download/0.12.0/safe-cli-0.12.0-x86_64-pc-windows-msvc.zip

The zip contains one file called safe. Extract it somewhere.

Using cmd or gitbash navigate to the folder where you extracted safe and run safe -V it should say safe-cli 0.12.0.

Now run safe auth install and then safe vaults install to install the authenticator and vaults, then follow these instructions https://github.com/maidsafe/safe-api/blob/master/safe-cli/README.md

7 Likes

safe vault install @JPL. But otherwise all looking like good steps to try there. :+1:

@safeandsound it looks like you’re not trying the guide I linked to?

In any case, @JPL has provided a concise set of steps to try. Also bear in mind to clean up any previous attempts before diving into a new one.

Good luck @safeandsound ! and let us know how you get on and any issues you encounter from @JPL’s steps please.

4 Likes

This isn’t untrue :stuck_out_tongue: BUT I’ve the latest browser working on a VM for me and our e2e tests are passing so it should go. Will be good to see what the issue is here, though. May be that the documentation is missing a step.

3 Likes

Unfortunately I still can’t bootstrap in Windows. Pretty sure this is a firewall issue as I can’t login from a Linux VM hosted in VirtualBox on the Windows machine either.

2 Likes

There was no criticism towards a dev in my comment. Twas indirectly saying that people need to be patient and wait for devs to deal with windows peculiarities/nonsense if they don’t want to install/use a (better) free OS. :sunglasses:

4 Likes

haha, dont worry, i didn’t read it so :slight_smile:

2 Likes

Thanks for the instructions. I uninstalled safebrowser, then deleted remaining safe folders in /USER/.safe and /USER/appdata/local and roaming folders.

I installed the safe browser you linked as administrator, nothing happened but the 3 processes are running and its installed.

I opened gitbash and navigated to the safe-cli.exe that you linked to and ran safe -V, it reported “safe-cli v0.11.0”. The zip i downloaded says its v0.12.0.

I ran “safe auth install” and it downloaded and installed, resulting in this error

“ERROR: safe safe-cli error: [ERROR] authderror - Failed when invoking safe-authd executable from C:\users\user.safe\authd\safe-authd.exe error: found argument ‘install’ which wasn’t expected, or isn’t valid in this context”

How should i proceed?

I did try the guide you linked to, it reccomends to follow the CLI guide in my situation “never have installed” which is closest to “never have got any of this to work”, which was the result of following the CLI guide.

My guess is you still have multiple versions installed.

Go to Add or Remove Programs and remove safe-authd if it’s there.

Then try safe update and see if it updates to v0.12.0. Then in case safe-auth is still running stop it with safe auth stop or if that doesn’t work through the task manager (Ctrl-Alt-Del), delete the folder C:\users\user.safe\authd\ and try safe auth install again.

2 Likes

The only safe product in my programs list is safe browser. I ran “safe update” and it updated to v0.12.0. I ran “safe auth stop” and it said it wasnt running. I ran “safe auth install” and it insalled v0.0.8. Following the CLI guide the next step is to run “safe vault install”, it installed. Then i ran “safe vault run-baby-fleming”, it opened 8 vaults and said done!.

The instructions go into connecting to different networks, im not sure if that applies at this point. Skipping down to the auth section i ran “safe auth start”, and it started an auth daemon. “Safe auth status” showed i have daemon v.0.0.8, im not logged into a safe account. I ran “safe auth create-acc --test-coins” and it hangs. Edit: I think it was waiting for a login and passphrase, it didnt say anything just went straigh to the next line. I tried various combinations of random login and pass, or just one word login, it just gives “ERROR safe cli-error: Failed reading ‘passphrase’ string from input: The handle is invalid (os error 6).” I dont know what it expects here, it wont allow me to create an account.

Unsure of what to do i tried to open safe browser and again nothing happened. Are all these CLI parts required to be running including having a safe account for the safebrowser to become viewable?

OK getting there!

Are you using gitbash? If so this is a known bug - try using command instead. I’m a bit mystified as to why the browser doesn’t open. What happens if you go to C:\Users\<your-name>\AppData\Local\Programs\safe-browser\ and double click on SAFE Browser Alpha?

2 Likes