Testnet tool

Off the top of my head “aws not found” but will confirm.

Ah, that means you don’t have the aws CLI installed. The script is actually supposed to fail if you don’t have that installed, so I’m not sure that part is working correctly.

You can install it using pip, either in a virtualenv or not. A virtualenv is a way you can install it without root access and it provides isolation for all the Python dependencies, so you don’t end up with conflicting libraries if you install system wide.

1 Like

That’s not actively used atm. So YMMV. (could be worth removing it tbh).

1 Like

Ahh ok. It tries, I can see some data put to the network before it fails with the netdata error and with a retry I also see data already exists.

Thanks @joshuef

Im trying to get it all to talk to each other locally before approaching you to discuss how best to host this. Im having reasonable success with Docker so looking at DO Kubernetes instances looks like a logical next step.
Bit distracted past few days, got an unexpected funeral to go to tomorrow so I’ll check in again in time for the Thursday update


Cool, no problem. Just wanted to check you weren’t constrained by any local resources or anything, because we could probably get you setup with the Maidsafe DO if that was the case.


4 Gb Ram and 2 vCPUs locally is no problem, in the cloud its expensive. Lets talk Thursday :slight_smile:


@chriso is the vpc_uuid assigned by the tool at creation of a droplet or can I retrieve it from a droplet that was not created by the tool?

If it helps, what I am trying to do is import a node into terraform.state that was not created by the tool.

For stuff that wasn’t created by Terraform, you can use data sources rather than resources.

What’s your scenario here?


1 Like


My scenario has been somewhat turned on its head.

From the other thread I mentioned that in the past I could start genesis and then add new nodes one by one until there were enough to be a functional network.
I am trying to do that now but it is not working anymore, has something changed that would cause that.

The now, no longer in play scenario was that I wanted to then gain control of any nodes that I created from within the tool.

I’m not completely sure about this off the top of my head, but I think if you wanted new Droplets to come online, you can increase the size of the Droplet count, then run Terraform again, and it’ll bring new Droplets online.

For Droplets that were created outside the tool that you would want to participate in an existing network, I’m not entirely sure if we should handle that within sn_testnet_tool. It would be possible to use Terraform’s data sources for that, but it might be easier to just let those nodes join the network using safe.


1 Like

No progress on Elk been sick all day, sorry


Makes me feel… less alone :grinning_face_with_smiling_eyes: I’m spinning my wheels here but it’s messing around with unnecessary stuff so ok.

For sure, just poking at it to see what happens.

I wonder if the connection pool changes could be why what worked for me in the past is not working for me now.

1 Like

Sorry, so what exactly is it that’s happening? You can’t get new nodes to join?

You answered my tool related questions :slight_smile: it’s all good, don’t be.

My wheels spinning is not testnet_tool related.

In the past I could
start a node with --first --public-addr
grab the --genesis-key
then add new nodes with --genesis-key --local-addr
that is not working now.

Yup. It’ll just spin up more nodes and connect them to the preexisting terraform infrastructure.

@josh this is without the testnet tool, just to be clear?

1 Like

Yes, without the tool.

Edit: @joshuef @chriso problem was me… all is well, false alarm.
Wheels stopped spinning and progress was made!


Can I be reasonably certain that logs will be stored at /home/$USER/.safe/node/root-dir/*/log.* for now?

EDIT /home/$USER/.safe/node/*/*/log.* may make more sense for testing with baby-fleming

1 Like

Yeah, and I think we can change it if we need something different.

1 Like

down.sh ~/.ssh/id_rsa for me isnt working says failed to authorise. any tips?

I circumvented the problem ny running up.sh again and it deleted the previous node.

also it said it needs rsync the first time I run up.sh so maybe put requirements for the testnet tool in the readme?

I also get

 rm: cannot remove './default-node_connection_info.config': No such file or directory