Stable Droplet Test Network

No, i registered the public ID and it worked just fine. I also apparently managed to upload an index.html but it is definitely corrupted and I also wasnt able to manage a service

The new launcher seems a little faster maybe :smile:

back on safenet: http://frostbyte.safenet/

3 Likes

Not really, the network is faster, being all vaults on droplets (i.e., with fat pipes).

1 Like

So, here’s a simple question…

If you upload a folder into /public/ are the files not accessible without a service setup in that folder’s name? I have one folder that’s a /public/www and works as usual - that’s http://www.yvette.safenet and another uploaded /public/data and I can’t seem to get the image to display in a browser. So, would have expected to be able to jump to http://data3a.yvette.safenet/1.jpg ={“errorCode”:-1004,“description”:“DnsError::ServiceNotFound”} or http://yvette.safenet/data3a/1.jpg = {“errorCode”:-1502,“description”:“FfiError::PathNotFound”}

For the record to check stability I’ve also put http://www.hello.safenet up again too.

Could some kind person post the link to the proxy url again please?


or watertight is Public Notice - How to hack SAFE Browser Plugin users and http://powersign.io/safe-browser-security-hole/

3 Likes

Thank you.
This the sort of thing you have to ask for when you are waaay too cool to RTFM :slight_smile:

1 Like

Alright, I spotted the issue. After I created my public ID I managed a service and uplaoded a folder which apparently was too big, so the upload failed. After that I wasn´t able to create new services because the other files already reached the upload limit. However, I couldn´t delete those files so I was stuck with the public ID (http://join.the.safenet/).

I created a new public ID and could upload as always. Again I tried to reach the limit. Deleting doesn´t help once the limit is reached.

Now I created another ID and just put ~4.5 MB for test reasons. You can find me at http://this.is.safenet

1 Like

No, I found that you can only create accessible folders under the base directory of each service, like this: http://test.bluebird.safenet/Data/maid.jpg

Which has a path in the demo app of: “/public/test/Data/”

Also, you can only create them by uploading, but that’s the demo app’s limitation

I think this currently would be the biggest reason for quick responses. Currently you’d need QUORUM responses for consensus of a given request which when the network is spread and luck has the target group/route for that data as a bunch of very slow nodes is gonna affect throughput. This is something we’re working on addressing ofc so the network can itself asses and require particular functionality from nodes accordingly based on the nodes physical capabilities.

At the same time, this certainly isn’t the only difference here. Routing in this network is v0.21.0 while the previous test used v0.19.1. One of the neat features brought in is

Send acknowledgement messages (acks) and resend via a different route only if no ack is received. Previously, several routes were used simultaneously, wasting a lot of bandwidth.

This saves a lot of unwanted traffic by not broadcasting each routing message in PARALLELISM number of routes. So the overall workload on each node should be down a bit too.

12 Likes

Just to note so it’s more visible: https://github.com/wrnice/rsafe is very useful for seeing the API in action.

I’ve not got to look closely at the directory listing that sees in reply to its request but I wondered I couldn’t see everything I knew existed - that was my expecting to see a list from /private but I likely got confused with the options being used. It seemed on first pass there might be different contexts with isPathShared etc.

2 Likes

Well, I was responding to the statement that the launcher was faster, but point taken that the vault software is more efficient in this version.

1 Like

A simple list of sites http://dir.yvette.safenet/ and http://a.random.safenet/

3 Likes

The second one is not available.

Try again. While satisfying my near OCD there I wondered about the need for delete then upload to refresh a data point and the impact that will have for usage in future. I don’t know what option there will be to make that a smoother experience for the users of data that’s being refreshed.

and another http://web.chunky101.safenet

Front

1 Like

Keep getting cannot create file/directory. Tried creating more than one account and/or ID as well.

Is that UDP progress still available and open source? So when The world is all watching and wants to create it, they will have a solid foundation to start from?

Thanks for this, providing the droplets obviously comes at a cost to the company. Much appreciated.

6 Likes

No problems at all here, logging into an account I created five hours ago and checking the data.

Try a fresh start with a default local network, no redirections, with download of launcher 0.4.5 in an empty folder, start without any vaults since this network uses later binaries and @dirvine requested no community binaries.

I am, however, now running a community1 vault (on community1 of course) as well as a launcher for client_test_2 (this network): they operate quite separately each on its own network.