Stable Droplet Test Network

I have to say I really appreciate your prioritizing the development over the PR/marketing aspect of this (too many cryptos sometimes seem the opposite). That said, I’m looking forward to seeing what the “PR activities” entail. There’s still way too much confusion and misinterpretation (and FUD) in the crypto space with regards to MAID, so it’ll be good to clear the air and give people a better sense of what to expect. Feel free to contact me if you need some additional boots on the ground in San Francisco (I work in media, though on the literary side). Cheers, best of luck, and thanks for the ride!


Thank you very much for this @dirvine and the MAIDSAFE team!


I get Upload failures, anyone experiencing the same?

I did earlier, but it was due to exceeding the file size limit (5mb) I think.

1 Like

In my case I have 3.X MB. I also tried with smaller sized uploads. I can´t upload anything.

There was nothing stopping anyone (app devs or community members) from putting up a stable test network, as I have shown at no extra monetary cost. The reasons for their failing to do so are neither technical nor economic ones.

With just one droplet, it is perfectly stable once the operator of that droplet learns to avoid missteps. With two or more hard-coded contacts in the config, even that wouldn’t be an issue.

I never deliberately crashed it; the goal has always been to make it stable, and it has been for several days now.

1 Like

hmmm…are you using the newest launcher and demo app releases included above? That’s the only other thing that I can think of …

I expect the point is more about Test3 expecting to be volatile.

Stable is about the experience of the user and their data not about the host of the seeding… which you’ve done really well.


That looks like failure to create directory not to upload. I’ve seen similar in the /private where the directory already exists. Adding to it appears to lack a merge feature atm, so you need to perhaps upload the file not a directory.

Also I suspect the intent for this droplet test network is for app devs, rather more than users uploading files… I wonder there might be limited capacity on this network, though unlikely we can max it out but still, data upload might be better suited to a community network that becomes the order of magnitude of the users using it. Guessing…

That definition of stable is yet to be determined and I’ve put up several accounts to find out. If the data survives then it will surely be due to the fact that the vaults running on this network are a newer version, rather than the launcher and demo.

By the way, @Artiscience et al, if you use the old launcher it just won’t connect at all (I tried that, in the interests of research), so it isn’t that.

1 Like

No, i registered the public ID and it worked just fine. I also apparently managed to upload an index.html but it is definitely corrupted and I also wasnt able to manage a service

The new launcher seems a little faster maybe :smile:

back on safenet: http://frostbyte.safenet/


Not really, the network is faster, being all vaults on droplets (i.e., with fat pipes).

1 Like

So, here’s a simple question…

If you upload a folder into /public/ are the files not accessible without a service setup in that folder’s name? I have one folder that’s a /public/www and works as usual - that’s http://www.yvette.safenet and another uploaded /public/data and I can’t seem to get the image to display in a browser. So, would have expected to be able to jump to http://data3a.yvette.safenet/1.jpg ={“errorCode”:-1004,“description”:“DnsError::ServiceNotFound”} or http://yvette.safenet/data3a/1.jpg = {“errorCode”:-1502,“description”:“FfiError::PathNotFound”}

For the record to check stability I’ve also put http://www.hello.safenet up again too.

Could some kind person post the link to the proxy url again please?

or watertight is Public Notice - How to hack SAFE Browser Plugin users and


Thank you.
This the sort of thing you have to ask for when you are waaay too cool to RTFM :slight_smile:

1 Like

Alright, I spotted the issue. After I created my public ID I managed a service and uplaoded a folder which apparently was too big, so the upload failed. After that I wasn´t able to create new services because the other files already reached the upload limit. However, I couldn´t delete those files so I was stuck with the public ID (http://join.the.safenet/).

I created a new public ID and could upload as always. Again I tried to reach the limit. Deleting doesn´t help once the limit is reached.

Now I created another ID and just put ~4.5 MB for test reasons. You can find me at

1 Like

No, I found that you can only create accessible folders under the base directory of each service, like this: http://test.bluebird.safenet/Data/maid.jpg

Which has a path in the demo app of: “/public/test/Data/”

Also, you can only create them by uploading, but that’s the demo app’s limitation

I think this currently would be the biggest reason for quick responses. Currently you’d need QUORUM responses for consensus of a given request which when the network is spread and luck has the target group/route for that data as a bunch of very slow nodes is gonna affect throughput. This is something we’re working on addressing ofc so the network can itself asses and require particular functionality from nodes accordingly based on the nodes physical capabilities.

At the same time, this certainly isn’t the only difference here. Routing in this network is v0.21.0 while the previous test used v0.19.1. One of the neat features brought in is

Send acknowledgement messages (acks) and resend via a different route only if no ack is received. Previously, several routes were used simultaneously, wasting a lot of bandwidth.

This saves a lot of unwanted traffic by not broadcasting each routing message in PARALLELISM number of routes. So the overall workload on each node should be down a bit too.