SAFE Network - TEST 7

I cant open my vault, when i try to open it, it closes automaticaly, any ideas?

For now this is client software only test so no other vaults will work. We are narrowing tets here to confirm client side is all fine whilst completing refactoring of routing and network parts. This does contain routing and crust code, but we do not need to worry about resource provisioning etc. here just the network all works whilst we get the rest done.



One question, is there a way to move private data to public without re-uploading? I don’t see it as an option in the demo app, but I’m wondering if it’s technically possible.

Yes, there’s is a move or copy files operation in the NFS API, but I don’t think it is implemented yet (and so not part of the demo app either).

1 Like

This is a droplet network. Maidsafe running the Vaults. They’ll release new Vault for us after this is up and works well.


Yes it is technically possible. Also at the moment much of what you see is sequential, albeit async code download and upload. That can probably be made much quicker via parallelization.


I guess not the Disjoint Groups RFC yet? That’s quite a step isn’t it?

Not yet, it’s being worked on though.


@happybeing & @dirvine
Thanks for your replies![quote=“dirvine, post:94, topic:10460”]
That can probably be made much quicker via parallelization.
Great news on that front also! This project is coming together quite nicely.

EDIT: hooray for async code


The Better-B-Test, same webpage, ‘title’ adjusted


Did a little duplication test by uploading the same file in two different public directories. On the second upload it appeared as a standard upload of data. My initial thought on this was that the network would report back with “file already there” and the file would appear to be uploaded instantly. This doesn’t seem to be the case. Thinking about it security wise this behavior makes sense, but does seem to be a waste of bandwidth.


A spread of 10MB-20MB speed and download completion tests:



This is definitely proof that the slower connections on the network i.e. My node and others like mine, are what are screwing seemingly everything up. I’m ready for message priorities, disjoint groups, and data chains baby!


Bruce Lee wisdom video :slight_smile:



Watching one of the “The Expert” sketch right now! I love this! Show seems funny also. :wink:

And uploaded the template webpage for now - http://www.upstate.safenet

1 Like

It’s actually implemented in safe_core and also available via Launcher API - Move dir and Launcher API - Move file. Just demo app not showcasing that feature via its UI. Other apps should be able to use that even now.


81 posts were split to a new topic: Discussion about the password requirements in SAFE Launcher

Thanks @Viv - are you aware these don’t feature in the Launcher API docs? As a Dev I’m reluctant to touch something that isn’t documented.

I’m holding back from playing with the new API for the same reason.


Unfortunately yep, and I know exactly what you mean Mark think @frabrunelle was looking into getting those updated with @Krishna_Kumar once these launcher updates were out. They’ve just been caught up with the actual app updates, but now that they’re nearly sorted, we should be getting the docs up to date soon for this.


This is my first time trying the SAFE Network and I’ve got to say everything’s worked flawlessly so far (I’ve only tried the latest binaries). To be honest it was a lot faster than I’d expected.

The only thing I’ve noticed when uploading files is that there are “hiccups”, I suppose that’s because of the chunking process.

I was able to upload at 1MB/s (which I think is probably maxing out my current WiFi connection). From that graph am I right to assume that the current block size is 1MB?


Welcome to the forum! New member but you already got some likes somewhere ;-).

Yes, max size (of a PUT) is 1 mb. I’ve seen the same hickups btw. Don’t know what’s causing it.