SAFE Network - Test 16


#143

Hi @juus

  1. As far as I know it’s the latter. There is no organised list - although it would be nice if there was such a thing.
  2. Not a problem - the network is designed to support nodes being switched on and off. So long as a bare minimum number of machines remain connected it’s not an issue at all. When you reboot your computer all the chunks will be deleted (they are replicated elsewhere on the network), but when you start up your vault again the network will load you up with some more chunks.
  3. Nothing needs to be backed up as everything is done through your authentication credentials. It’s worth keeping the log files somewhere safe though, just in case they are needed, although they are persistent and won’t be deleted if you reboot.
  4. I’ll leave that to the devs to answer.

#144

Thanks @JPL, I’ll just keep monitoring this list then.


#145

Great feedback @juus - glad it went so smoothly.

One thing you can do is visit & try out the different websites and web apps that people have published. If you fancy adding functionality to your website, @whiteoutmashups has done some work to help get people started. It’s also good to share your experiences and generate interest.

Once we have a stable developer test network again there will be things that app developers create that will need trying out and testing, but at the moment I think some Devs are doing work locally. For example, I haven’t uploaded my work to Test 16 because it is likely to short lived and I’m quite busy for now.


#146

Hold on a sec, what do I need it for? I’m running a vault but I didn’t need the code for it. Im confused :confused:


#147

Explanation below:

20 charsssss


#148

Ah right lol. Have been thinking too much about other stuff lately. Two weeks out and a lot has changed.


#149

Now it works.

Screen shot with my 2 vaults (one at home and the other at DO):

To locate your vaults you have to enter their node ids on 6 digits each, separated with one space character and then you validate.


SAFE-FS Desktop App
#150

confused, none of my apps can authorize now with launcher 11

SecretChat and DemoApp just make launcher give the spin loading screen for 3mins then it stops and shows “no authorized apps.” none of my code has changed, is TEST16 giving anyone else strange problems like this?


#151

Uploaded your DemoApp to safe://demo-app.jpl2/ and it works for me


#152

Aw naw…

I left the constellations2 page open overnight. Could this have been the culprit?


#153

No chance. When you are visiting a site with SAFE Browser the launcher is only issuing GET commands. You can browse without even being logged to an account, meaning that the network is unable to charge any put balance.


#154

Yeah - thats what I thought. I just dont recall sending a LOT of data TO the network.
The screenshot seemed to show fairly regular PUTS that puzzled me . THen I found the constellations page on beaker beneath a pile of other windows - (I have a very untidy desktop) - so I blamed it…


#155

Is this an XOR space thing? Couldn’t find a post explaining it.


#156

It was a bug in the javascript code I delivered Sunday that I corrected yesterday. People can now locate their vaults in safe://constellations2 by entering their vault ids. This is useful to check permanently their availability without connecting to them.


#157

I can’t load safe://wingsuit.draw, which I created immediately after startup of Test 16. This still worked yesterday or monday.
I guess that all/most of the 8 copies of each chunk were initially stored on the 100 Vault instances of Maidsafe. Have (some) of these 100 initial Vault instances stopped or restarted since then? Or is this unrelated to the load problem?
The more recent safe://constellations2 does work (partly).
Login (created right after start of Test 16) in Launcher works, but app authorisations fail.


#158

Sorry, I meant…what is it I’m looking at in the graphic? groups of nodes maybe


#159

Hi,

My website/service has disappeared: safe://tpirate.4tee2

It was a simple bit of text and one photo.

I’ve been on test 16 since Monday, nothing has been shut down (except see below) all the programs demo, beaker, launcher have been running since then, not closed, the site was created on Monday and worked immediately. Over the next couple of days I refreshed it periodically with no problems.

This morning I refreshed it and got the errror in beaker:
{“errorCode”:-18,“description”:“CoreError::GetFailure::GetError::NoSuchData”}

I closed beaker and re-opened and re-tried: same error.

The only thing I did in the last days is md/late morning of 11th I ctrl-c’d my Vault because I wanted to test disconnect/reconnect. I restarted my vault without any major problems.

The site folder was still listed in the demo app public area.

On going to demo app manage website I got:

Get Services
Failed to get service list
reason
GetError:NoSuchData

Then it displayed: No Service Registered

On retrying to create my service I got a similar message
with “Publish Service failed”, and the same reason.

I then deleted the site folder in demo app public and then re-uploaded
the folder to demo app public. Tried to add the service again, still same error.

Tried adding it as a new service name “ttpirate”. Same error.

Does this mean my ID is bad then? How? Why? I’ve been able to upload this morning using demo app, but my services do seem to be fried.

I also just closed and reopened demo app. My public ID still seems to be recognized but I’m still getting no registered services. On trying to add the new “ttpirate” still got same error.


#160

Hoping for more clarification on this data loss today, test 15 did better than test 16 it seems besides being filled up. I saw David had said something about tunneling spam (attack maybe?) and test 16 had some changes to tunneling as well so, I suppose we may know more today.


#161

It is a representation of safe network: stars are nodes and constellations are sections.

I explained the way I compute coordinates here:


#162

Thanks for that, it’s a nice contribution you’ve done with the app.