SAFE Network - Test 16


#63

Ahh, so much to learn… :slight_smile:

Edit: Made a rule for the firewall to accept safevault.exe but this had no effect.


#64

hiya,

tried to start v14:

Running safe_vault v0.14.0
==========================
I 17-04-07 13:04:20.600036 Node(763f5e..()) Requesting a relocated name from the network. This can take a while.
I 17-04-07 13:04:21.063739 Node(006b65..()) Received relocated name. Establishing connections to 17 peers.
I 17-04-07 13:04:21.272468 Node(006b65..()) Starting approval process to test this node's resources. This will take at least 300 seconds.
I 17-04-07 13:04:51.063385 Node(006b65..()) 0/17 resource proof response(s) complete, 57% of data sent. 380/410 seconds remaining.
I 17-04-07 13:05:21.063567 Node(006b65..()) 14/17 resource proof response(s) complete, 89% of data sent. 350/410 seconds remaining.
I 17-04-07 13:05:51.063752 Node(006b65..()) 14/17 resource proof response(s) complete, 94% of data sent. 320/410 seconds remaining.
I 17-04-07 13:06:21.063877 Node(006b65..()) 16/17 resource proof response(s) complete, 96% of data sent. 290/410 seconds remaining.
I 17-04-07 13:06:51.064116 Node(006b65..()) 16/17 resource proof response(s) complete, 97% of data sent. 260/410 seconds remaining.
I 17-04-07 13:07:21.064360 Node(006b65..()) 16/17 resource proof response(s) complete, 98% of data sent. 230/410 seconds remaining.
I 17-04-07 13:07:51.064541 Node(006b65..()) 16/17 resource proof response(s) complete, 99% of data sent. 200/410 seconds remaining.
I 17-04-07 13:08:21.064761 Node(006b65..()) 16/17 resource proof response(s) complete, 99% of data sent. 170/410 seconds remaining.
I 17-04-07 13:08:51.064961 Node(006b65..()) All 17 resource proof responses fully sent. 140/410 seconds remaining.
I 17-04-07 13:09:21.065262 Node(006b65..()) All 17 resource proof responses fully sent. 110/410 seconds remaining.
I 17-04-07 13:09:51.065377 Node(006b65..()) All 17 resource proof responses fully sent. 80/410 seconds remaining.
I 17-04-07 13:10:21.065482 Node(006b65..()) All 17 resource proof responses fully sent. 50/410 seconds remaining.
I 17-04-07 13:10:51.065639 Node(006b65..()) All 17 resource proof responses fully sent. 20/410 seconds remaining.
I 17-04-07 13:11:11.063369 Node(006b65..()) All 17 resource proof responses fully sent, but timed out waiting for approval from the network. This could be due to the target section experiencing churn. Terminating node.

will retry…

rup


#65

2nd time straight in not probs…

rup


#66

First attempt at this. Does this mean I’m running a vault? If so what node am I?


#67

Yep! You are node b4ecf9 in section 101


#68

Awesome! Thanks :slight_smile:

One thing I’m confused about is that I didn’t assign any hard drive space. How do I do that? And how much does it assign by default?


#69

Welcome to vaulthood :slight_smile:

It assigns 5GB. You can change it in the config file safe_vault.vault.config - change "max_capacity": 5368709120 to another value. You’d presumably need to restart the vault though.

If you’re in Windows the chunks get stored at C:\Users\ [your_name]\AppData\Local\Temp\safe_vault_chunk_store


#70

Great thanks. Can I change the drive to say E:
?


#71

I think I remember someone asking this before, and that the answer is yes. I don’t know how though. Might want to do a quick search


#72

Change chunk_store_root in safe_vault.vault.config

“chunk_store_root”: “E:\your directory”


#73

Okay I can’t even run the safe_vault.exe now. I tried changing the port it looks for for port forwarding and now windows won’t even launch the file. It keeps saying I don’t have permission to access this file or directory. And my antivirus keeps getting all upset about it and thinks it might be a virus. What gives?


#74

Some feedback and questions.

How the heck do I know if my vault is running? Will there be a UI soon?

Why in general is everything separate? It’s kind of a pain in the ass. I have to download the launcher, test app, browser app, vault app… ughhhh!


#75

Regarding the Vault. Almost any server type of program does not have a UI. You set it up with config files, and then you run it. You look at it’s log file to try to debug issues. This is the case for things like Apache web servers, Postfix mail servers, Plex Media servers, Minecraft game servers, Freeswitch VOIP servers, etc., etc, etc., This is the standard for any type of program that is expected to just run in the background, day after day, week after week, month after month, year after year. There’s no UI, because the user is not expected to need to or want to interface with it. The Vault is not a server per se, but it follows that paradigm, as it will run quietly in the background forever.

There are a bunch of status messages that appear as it runs, so that’s how you know it’s running. In Linux, you set up a screen session, and run it in that, so anytime you want to, you can switch to that screen, and see those status messages. You can also tell Linux to start it on boot and run in the background, just like you would do with a web server, phone server, etc. In that case, you won’t be able to ever see the status messages, but you still have your log file to look at, to see how things are going. For Windows, there is no equivalent to Screen, AFAIK, so you need to remember to not close that window when it’s running. There are ways to run programs as Windows Services, which will be what you would do when we go live, to avoid having a window that you can accidentally close and stop your vault.

As for the other programs, the separation into multiple programs is a hint of things to come. The Launcher provides the gateway into the network. It handles authentication and encryption to allow network access. All other programs use the Launcher to access the network. Someday, there will be hundreds of programs. You will only download and run the ones you want, of course. They will all be forced to use the Launcher for authentication, so that some random program is not given your SAFENet credentials.


#76

Still many server programs do have interfaces/rpc to allow inquiries as to its state and change its functioning.

It will be nice for the node/vault to have such interface so a UI APP could be written to display its internal status like GETs delivered, coins earned, chunks stored and so on.

Not having looked into the vault/node software I am not even sure if that interface has been built in. Sorry to tag you @dirvine but can you enlighten me/us


#77

No problem @neo we are working on a UI for vaults that will appear and may be installed with the browser. Early days, but it’s in process now and something the guys are looking at. Not priority for now, but will happen as we progress.


#78

Really cool testnet david, keep up the good work cant wait to use the safenetwork.
Used everything for the first time and its already easy to use.

Also the safebrowser is awesome, feels really normal to use.


#79

Hi David, thanks for the explanation. I got as far as your last command:
screen
[Enter x2]
./safe_vault

but get this error:
[root@safeserver safe_vault-v0.14.0-linux-x64]# ./safe_vault
./safe_vault: /lib64/libc.so.6: version `GLIBC_2.18’ not found (required by ./safe_vault)
[root@safeserver safe_vault-v0.14.0-linux-x64]#

Any help would be much appreciated.


#80

Maybe have a look at this: http://askubuntu.com/questions/736208/upgrading-glibc


#81

Did you opt for Ubuntu 16.10?

I’ve not seen that and would have expect the base images to be identical.

You could try just updates all packages with this below but if you’ve got an older OS, it might need dist-upgrade and quicker/easier to just stop and start again.

sudo apt-get update
sudo apt-get -y upgrade

#82

Is it just me or is the network running a lot faster today?