SAFE Network - Test 16


#43

I remember there was a way to visit the websites by google chrome is this still possible, anyone know were to find how again.

(was a long long time ago crypto-time)


#44

Pretty sure those days are gone


#45

Yea thought so, my company network wont let me download anything here

Need a mobile compatible client :stuck_out_tongue:


#46

When I tested 30 min ago it seems that especially the app authorisation in the Launcher takes time.


#47

The Vault seems OK (Routing table 62 and estimated network size 126) but impossible to log in (Request timed out). I try with different computer and same error.

Yesterday all was OK. I uploaded the usual files to test speed (about 180KB/Seg.) and the safe pages I check was OK too.

Maybe some problem with the invitation?


#48

EDIT: left it a couple of hours, tried again and it worked. Testnet 16 is a fussy one it seems


#49

#More nodes can only help…
I just brought 7 online… with 3 of those tweaked for 20GB… surprised we’re only using 50% of 5GB still.

#abc

Goto
http://www.vultr.com/?ref=6817462

Deploy New Server/Instance
Vultr Cloud Compute
[Any location]
[Ubuntu 16.10]
20GB SSD $2.50/month (sold-out but still cheap at $5 and trivial then hourly rate)
[scroll down and enter a server hostname]
[deploy now]
=================
manage
get IP address and a copy of the password

#from your computer then login via ssh
ssh root@999.888.777.666
+(yes if needed)+thepassword#

#Logged in via ssh
root@SAFE:~# 

#and do this:
mkdir ./SAFE
cd ./SAFE
wget https://github.com/maidsafe/safe_vault/releases/download/0.14.0/safe_vault-v0.14.0-linux-x64.zip
sudo apt-get -y install unzip
unzip ./safe_vault-v0.14.0-linux-x64.zip
cd ./safe_vault-v0.14.0-linux-x64

screen
[Enter x2]
./safe_vault

[wait a while.. for resource proof.."This will take at least 300 seconds." <410s.. ta da!]
[detach from screen and leave it running with “Ctrl-a” “d”]

exit
=================
"exit" will drop your ssh connection and the vault will be there when you ssh again, running in screen.
Use "screen -r" to return to the screen with whatever is the latest output from the vault.

Any questions, just ask but it’s simple and worth doing for the experience of running a cloud server. :thumbsup:


A vault in my home
#50

I’ll just note that a delay at the start of vault does become a retry and success:

Running safe_vault v0.14.0
==========================
I 17-04-07 08:59:59.611749 Node(9df58e..()) Requesting a relocated name from the network. This can take a while.
I 17-04-07 09:05:59.612216 Node(9df58e..()) Failed to get relocated name from the network, so restarting.
W 17-04-07 09:05:59.613052 Restarting Vault
I 17-04-07 09:06:02.711734 Node(c13c94..()) Requesting a relocated name from the network. This can take a while.
I 17-04-07 09:06:03.102895 Node(8d33c3..()) Received relocated name. Establishing connections to 20 peers.
I 17-04-07 09:06:03.153232 Node(8d33c3..()) Starting approval process to test this node's resources. This will take at least 300 seconds.

which is good :slight_smile:


#51

Good experience from here then, except as above it seems galaxy times out.

safe://hello
safe://big.hello - 19.4MB


#52

Yesterday, at 22:49:58 UTC the program updating safe://galaxy crashed because a NFS request timed out.

I have just discovered this right now, and I am not able to relaunch the program anymore (get user root directory listing request always times out).

I don’t know how to solve this, so I just asked for another invite and recreated the site with another name (safe://constellations). Maybe this is a better name because i find that sections look like constellations.


#53

Many thanks to the team for the effort to get this done!
Started a vault and all looks nice.

Uploaded a few files and noticed that data upload counter does not seem to show correct value:


#54

Counts are PUTS (chunks written to the network) rather than MB. They are related but not the same thing, which is why the numbers don’t match.


#55

A post was split to a new topic: Request for Test 16 Logs in the following cases


#56

Yes, but it says Total Data Upload 11.2 KB. Although I have uploaded multiple mp3 files that are 10 MB each.


#57

The 11,2 KB data upload only refers to that specific session. Did you upload the mp3’s in this same session, or did you restart the launcher in between?


#58

Did all of that in one session.


#59

I’ve noticed the routing table size is changing every 10 seconds or so - same problem I guess?


#60

Yes, seems like it to me.


#61

Thank you @drehb. I’m a noob when it comes to things like this.
In the terminal I get the message:

E 17-04-07 10:38:15.580293 Failed to Bootstrap: (FailedExternalReachability) Bootstrappee node could not establish connection to us.
I 17-04-07 10:38:15.581296 Bootstrapping(41f597…) Failed to bootstrap. Terminating.

So, I guess that it can´t get through the router.

In the router there are only three settings for UPnP:
UPnP Enabled: ON
NAT-PMP Enabled:ON
Secure Mode Enabled: OFF

Anything else I need to consider?

Otherwise I will see if I can learn how to port forward


#62

Is the port open in the firewall??? Could be your virusscanner’s firewall as well. I have to open port 5483 on my router as well, even with UPnP activated.