SAFE Network - Test 15

Great to see test 15 up and running

Would it be possible to include in the list of limitations the minimum (upload) link speed people require to run a vault. I gather it is still 6 Mbits/sec which it was in 12c. Just be good to see it listed with the port forwarding/UPnP requirement

Any chance of reducing this?

Be great to try vaults from home, but I only have 2 Mbits/sec upload speed. And its like 2 years before I can expect to upgrade this.


Anyone else getting this error on startup of the vault? I just dies without doing anything for me :frowning:

I 17-03-24 00:15:36.500793 [safe_vault]

Running safe_vault v0.13.2

T 17-03-24 00:15:42.083112 [routing::states::bootstrapping] Bootstrapping(0626af…) Listener started on port 5483.
E 17-03-24 00:15:43.442190 [crust::main::bootstrap] Failed to Bootstrap: (FailedExternalReachability) Bootstrappee node could not establish connection to us.
I 17-03-24 00:15:43.442190 [routing::states::bootstrapping] Bootstrapping(0626af…) Failed to bootstrap. Terminating.
D 17-03-24 00:15:43.442190 [routing::state_machine] State::Bootstrapping(0626af…) Terminating state machine

1 Like

Will test tonight, my first time testing vaults as I have missed out previously.


I’m up and running! Went pretty smoothly.




We commented on that here @Blindsite2k: GPL licensed software leaving github. In short, I don’t see anything significant in the changes to motivate a change, explanation in the post. Thanks.


When this has happened in the past the cause has generally been either having a VPN running or port forwarding not set up properly on the router for port 5483.

1 Like

It looks very much like what happened to me in 12c :

MaidSafe Dev Update - March 2, 2017 - Test 12c

A new config option was added to the crust config file , which should adress the case of some weird router behaviour :

Hopefully setting “force_acceptor_port_in_ext_ep” to TRUE should fix this.

I did not have a chance to try it yet as I am away from home until this afternoon.

@ustulation , force_acceptor_port_in_ext_ep works perfectly my side . If I set it to false, test 15 behaves just like 12c and is not reachable from outside. Setting it to TRUE makes it visible. GOOD JOB ! :congratulations:


Hi All, I’m going to take an off topic risk here but does anyone have a Vault working with a BT homehub 4? I’m stuck on this option, it seems a bit severe… but without port forwarding I cant build a vault… I don’t think disabled is a wise move, anyone have an opinion?


Default looks ok - In [Port Forwarding] is there not [Supported Applications] where you have [User-defined games & Applications] option?.. then I would expect [Add new game or application] => [Protocol]=Any [Port Range]= 5483 - 5483 [Translate To]=5483 - 5483 … and the same for 5484… can’t recall why I’ve got both those but it works.


Visual representation of nodes and sections at safe://galaxy

There are currently 139 nodes:

I am afraid test 15 is the last network where I can do this because I rely heavily on free POSTs and there is a project of making people pay for POSTs in the future.

Currently I don’t use any API but only html and json files. I make my site dynamic by replacing json files periodically. As long at each file remains under 3KB and each directory under 100KB, I only pay once to create them. If I had to pay to update them, then my account balance would be exhausted in few hours.


A newbie here… until now only a “lurker” watching in awe the great things this project is attempting, the amazing accomplishments to date, and the admirable positive energy of this forum! I am looking forward to the day that I can contribute something even if only as an occasional tester and later as a farmer (one of millions, I hope!).

In the meantime, can anyone help me understand why I can’t connected as a vault in Test 15? I always get something very similar to this:

Is it just a bandwidth problem (according to, I typically get 52 Mbps down, 5.7 Mbps up) or is there something else going on here?

Thanks in advance.


In your case this is a problem of CPU performance: the resource proof wasn’t completed on time (only 86% of it).


Maybe the problem is something else, but the upload requirement for vaults is 6 Mbps for now, so 5.7 Mbps might just fall short for the approval resource proof.


Shouldn’t a newish iMac with 3.2 GHz Intel Core i5 be able to do the job?


OK, I’ll resign myself to waiting for a while longer! It’s my understanding that the rate limit may be reduced eventually (soon?).


It’ll do it easily.

For your situation the vault only got through 86% of the resource proof which means you uploaded 86% of the proof data in the required time of 300 seconds.

If anyone else using your internet connection was uploading or streaming at the time then maybe if you get them to pause you might have a chance.


I am not aware of any other significant loading on the uplink during my vault connection attempts, so I guess I’ll just have to accept that I’m a little below the current required threshold.

Thanks for the assistance!


Okay I’ve forwarded my ports AND I’ve enabled UPnG and the vault still doesn’t connects and auto shuts down. What am I doing wrong?

What error/log message do you get.

What is the IP address of the machine with the vault?.
What was the IP address you forwarded the port to?
What Port# did you forward?