SAFE Network Dev Update - March 5, 2020

First update I didn’t read on a Thursday and my weekend is booked solid! I’ve been waiting for this and now have to wait until at least Monday… Not happy Bob… Not happy.

My personal disappointment aside, this is fantastic news, and as always, keep up the fantastic work Maidsafe crew. You guys are like the little engine that could. Keep chugging along and we’ll hit the other side!

10 Likes

Thank you for the heavy work team MaidSafe! What was once a dream is turning into reality tomorrow! :dragon:

I add the translation into Bulgarian in the first post :dragon:

13 Likes

I’m getting closer, but since you run the SAFE CLI on a mac, I would appreciate it if you could just list a quick, how to, guide of installing and running the CLI on a mac, when you have time. Thanks so much!

1 Like

This is an ideal opportunity for a community member to help out - anyone on Mac able to provide this?

3 Likes

Not yet but Mrs Southside is getting a Mac tablet of some sort from work next week. I intend to explore…

6 Likes

The single source of truth needs a refresh:
Download SAFE’s latest versions
just noticing that, as it is usefully among the default topics visible to users not logged into the forum.

5 Likes

So, having tried yesterday to avoid reading instructions, I jumped into the CLI, which prompted happy memories of MUD clients from the early 1990s!!

Welcome to Adventure! Do you want instructions?

:smiley:

Today, I walked through the abc above and happy with its being nice and simple…
breadcrumbs from my walking this labyrinth then left below, all fairly minor issues.

Auth not installed:
could do with being more graceful

$ ./safe auth stop
Creating '/home/safe/.safe/authd/logs' folder
Stopping SAFE Authenticator daemon (safe-authd)...
[2020-03-07T18:56:27Z ERROR safe_authd] safe-authd error: [Error] GeneralError - Failed to open safe-authd daemon PID file ('/home/safe/.safe/authd/logs/safe-authd.pid') to stop daemon: No such file or directory (os error 2)
[2020-03-07T18:56:27Z ERROR safe] safe-cli error: [Error] AuthdError - Failed when invoking safe-authd executable from '/home/safe/.safe/authd/safe-authd':

Timeout error from AWS:
this occurred but then worked shortly after.

$ ./safe vault install
[2020-03-07T19:00:27Z ERROR safe] safe-cli error: Failed to find a release available to install: ReqwestError: error sending request for url (https://safe-vault.s3.amazonaws.com/?list-type=2&max-keys=100&prefix=safe_vault): operation timed out

Tidy of /tmp files from safe install
needed for where multiple attempts across different users

  • /tmp/safe_vault-0.21.0-x86_64-unknown-linux-musl.zip

  • /tmp/safe-authd-0.0.5-x86_64-unknown-linux-gnu.zip

    $ ./safe vault install
    Latest release found: safe_vault v0.21.0
    [2020-03-07T19:01:12Z ERROR safe] safe-cli error: Error creating temp file (’/tmp/safe_vault-0.21.0-x86_64-unknown-linux-musl.zip’) for downloading the release: Permission denied (os error 13)

Odd case of auth not perhaps starting…
though not obviously different from the later instance that was ok:

$ ./safe auth start
Starting SAFE Authenticator daemon (safe-authd)...
$ ./safe auth create-acc --test-coins
Passphrase: 
Password: 
Creating a SafeKey with test-coins...
Sending account creation request to authd...
[2020-03-07T19:08:17Z ERROR safe] safe-cli error: [Error] AuthdClientError - Failed to establish connection with authd: [Error] ClientError - Failed to establish connection with remote QUIC endpoint: the cryptographic handshake failed: invalid certificate: UnknownIssuer

directly afterwards ok with

safe@water:~/SAFE$ ./safe auth start
Starting SAFE Authenticator daemon (safe-authd)...
safe@water:~/SAFE$ ./safe auth create-acc --test-coins
Passphrase: 
Password: 
Creating a SafeKey with test-coins...
Sending account creation request to authd...
Account was created successfully!
...

FilesContainer created at: "safe://
Is it a bit odd that the url is stating the xorurl?.. perhaps this is useful for beta testing. I wonder encouraging a PublicName asap or defaulting to the username (y/n), might be better.

With a xorurl, will it cause a confusion, that a user deletes the file in their FilesContainer and yet the file persists on the network because someone else has that and the count was not 1 to remove it entirely?

Could do with pass wildcard characters
displayed on input to ./safe auth

Which account am I logged into?

$ ./safe auth status
Sending request to authd to obtain a status report...
+------------------------------------------+-------+
| SAFE Authenticator status                |       |
+------------------------------------------+-------+
| Authenticator daemon version             | 0.0.5 |
+------------------------------------------+-------+
| Logged in to a SAFE account?             | Yes   |
+------------------------------------------+-------+
| Number of pending authorisation requests | 0     |
+------------------------------------------+-------+
| Number of notifications subscribers      | 0     |
+------------------------------------------+-------+

:thinking:
It would be great, if the abc descriptions in future were made as ./safe rather than safe as there’s a lot of copy paste.

and upload of 4.5MB file was seeing the RAM vanish rather quickly; so, safe vault killall has me stop for this evening.

Good game :slight_smile:

4 Likes

Good shout. Done

3 Likes

good news, lets go safecoin.

1 Like

Yes that’s very ambitious fro now.
I have been keeping another terminal open with safe vault killall entered . I have had to hit enter on it a few times.

1 Like

Awesome, sharing over Reddit

r/privacy

r/security

r/crypto

r/cryptocurrency

17 Likes

I live un Malaysia :blush:

1 Like

All upvoted :smile:

7 Likes

We really need to hit Reddit harder. Reddit is a great source of free traffic and its community is generally very up with tech advancements and issues around privacy and security.

9 Likes

How is your Malay? Do you speak Tamil as well? Your English is excellent :slight_smile:

We probably should update the https://safenetwork.tech/roadmap/
Or wait?

4 Likes

Yes we should cos I just invited a shit-load of redditers to go look at it :slight_smile:

3 Likes

up voted and commented on them all. Now some of you go on there and start arguing with me so we get some action…
PS I’m TorranToi

3 Likes

Yes. Malay and English. I have helped a community own an estimated 3million MS coins in Malaysia who right now possibly do not like me. :rofl:

5 Likes

THey will in a few months. Your popularity will rocket. Especially if you could help translate some stuff into Malay hint hint :slight_smile:

1 Like