SAFE Network Dev Update - March 5, 2020

Anybody on Reddit, Please upvote my comment as TorranToi on

Also Sotros25 comment plus others supporting the project.

6 Likes

Looks like it’s removed but tried to do my part.

5 Likes

Yes, Bit of a bummer that… Thanks for trying :slight_smile:

25 Likes

Excellent, had to clear my Medium cookies first.

Sorry no claps but Im not signing up.
I wonder could this be referenced in Reddit as another possible way round their super zealous moderators on some sub-reddits? like r/privacy?

1 Like

Why has the post been removed from reddit? Was it because you were to excited about Baby Flemming? hahaha… they thought it was a pyramid scheme spam? hahaha…

I think they are a super conservative group.

4 Likes

Hi @Michael_Hills, the guides in the OP above and in the CLI readme have been written to be universal for Linux, Windows and macOS users, though I agree with the comment from @davidpbrown that these should be updated to $ ./safe as I assume the vast majority of people have not added safe to their $PATH - I’ll update that in both places shortly. (see Edit 2 below)

Just about everything should be standard across platforms, I think the only exception is that there are notes for Windows users informing them of slight differences, for example they should launch their console with administrator permissions.

I’ve followed the guides on a mac and they seemed to all be fine, but then I have had prior exposure, a mac which already has the software on it, etc, so I’m not completely unbiased. Is there particular parts that don’t make sense to you as a mac user? If so let me know and I’ll update them.

** EDIT ** That’s the OP updated as mentioned, and I’ve raised a PR for CLI readme updates here - anyone who wants to review that PR feel free to go through it, it’s not too big and includes some typo fixes (I’ll also ask internally).

** EDIT 2 ** I’ve been discussing alternatives to my above linked PR with @frabrunelle and @bochaco and Francis suggested using an install script to install the latest CLI and add it to your path for you, then you would only need to type safe ... from any directory, rather than having to navigate to the binary location and run with ./safe .... We agree that this is the correct way forward and are updating the linked PR to reflect this process instead :slight_smile:

9 Likes

Bare with me as I’ve never used the CLI for safe in this way before. I have, indeed, used the safe software before. I also took part in the curst testing. It all work like a charm. Recently I wiped my mac. So I downloaded and unpacked the CLI EXEC to my applications. My problem now it that no commands seem to be recognized in the SAFE CLI interactive shell. Does it have something to do with the interactive mode?

Last login: Mon Mar 9 09:16:22 on ttys002

/Applications/safe ; exit;

michaelhills@Michaels-iMac ~ % /Applications/safe ; exit;

Welcome to SAFE CLI interactive shell!

Type ‘help’ for a list of supported commands

Pass ‘–help’ flag to any top level command for a complete list of supported subcommands and arguments

Type ‘quit’ to exit this shell. Enjoy it!

$ ./safe auth install

Command ‘$ ./safe auth install’ is unknown or not supported yet in interactive mode

Type ‘help’ for a list of currently supported top level commands

Pass ‘–help’ flag to any top level command for a complete list of supported subcommands and arguments

1 Like

@Michael_Hills in the interactive shell you simply put the commands without the safe binary name (no $ either), so for your example just type auth install

3 Likes

Great I’ll give that a try, thanks!

edit: yep that was it. Now it worked. I knew it was something simple like that. Thanks again

2 Likes

I was looking at your experience above and trying to work out what was going on, then the penny dropped - as a non-CLI user, you are unused to seeing the command prompt $.
THose of us with some CLI experience simply filter that out…

BTW on Macs, does the prompt change from $ to # when you are logged on as root?

1 Like

Bash defaults to $ and zsh in Catalina defaults to # I believe

1 Like

Baby Fleming Update

Thanks to everyone for their Baby Fleming testing feedback.
The main area of feedback so far is performance when uploading data, and rightly so - we suspected that this may occur and the testing by the community has shown that to be the case. This performance issue is primarily due to us sending the client requests through Parsec, our consensus algorithm, for strong consistency.

Next steps

We have plenty of feedback & logs about data upload performance now and are working in the background on several different potential solutions for that. In the meantime, we believe it would be more beneficial to remove Parsec from vaults right now, keeping it in routing, so as to allow people to see past the current performance lag and test other parts of the testnet, create sites and apps, etc. We have a safe_vault pull request going through internal testing here. We will of course let you know as soon as we release a new version with this change.

23 Likes

Thanks to all of you who tested. Great job bringing up our baby.

16 Likes

Hi! Is it possible to limit number of vaults run by safe vault run-baby-fleming?

Maybe it’s ok to kill some vault processes with system utilities?

You can damage them by stopping process or deleting the folder perhaps… somewhere here there was a script for spawning more that perhaps could control a spawn of less than the normal.

1 Like

Thanks! I’ve figured out how to start vaults on my own and now I can start as many as I want. ps -aux has shown me commandline I need to run every node, genesis and subsequent ones.

1 Like

I don’t know much added value there tbh… more exciting atm is Baby Fleming Public Shared Section and the new browser in that thread.