Safe Network Dev Update - December 17, 2020

Amazing work getting this close to the whole team and everyone whos ever been in the team!


Great work guys! When we (at work) have to work together to get to a delivery it’s always a great energetic bunch of people striving for the same goal and I can’t imagine it being otherwise at Maidsafe! Enjoy!


3 beautiful words.

I couldn’t decide which image to post.

Apollo Computer: 145,000 lines of code.
SAFENetwork: I can’t see a way to count the total lines of code in the repos, and also dependencies, but I’m willing to bet it took more lines of code to get to the test net, than it took to get to the moon - and more complex.


My router isn’t supported, but I still had fun building and playing with a local network again. I’m looking forward to connecting to the shared network and/or hosting a node when possible though!

EDIT: btw, I had an issue running the binary on Ubuntu 20.04.1 LTS:

$ safe
safe: /lib/x86_64-linux-gnu/ version `GLIBC_2.32’ not found (required by safe)

Compiling from source worked great though!


We can support port forwarded (manually though), a wee bit of setup but entirely possible and the config allow that.


What you have built is monumental.

Your efforts grant you and your people a place in the history books in perpetual ways.

You are Lions of the Light!


So does this mean there is inter section accountability?

Probably included in a next test-net iteration?

Curious how mature the api is but given the tough work happening tying up the network that it’s somewhat of a fresh start.

Great work @maidsafe! This will be great to see tested amongst the community in the coming days. Foundation is being laid!



Cam somebody guide us on setting up the test net now? Ask me for mu whatsapp number on pv!


Anybody else seeing this on Ubuntu 20.04?

willie@gagarin:~/.safe/cli$ ./safe
./safe: /lib/x86_64-linux-gnu/ version `GLIBC_2.32’ not found (required by ./safe)

I have deleted all other safe binaries I had on this box.

EDIT: I see @Traktion had this issue - I will build from source then.


That’s a bug it should all be MUSL releases and statically compiled. Build from source will work here though. Good to catch this one, we can make sure the release is musl (no glibc deps)


I think we can forgive this one :slight_smile:

Thank you and the team for all your hard work to get us this far



if anyone is feeling particulary generous with their time and fancies doing a screencast that would be warmly welcomed! :grin:


Let me get it working first and I’ll be delighted to share but RealLife™ keeps getting in the way - just been pinged at 3:45 in the morning to sort out some WordPress formatting that is working sometimes but mostly not working and the code looks absolutely identical
If only I was bald, I wouldnt worry so much about tearing out my hair.

Sleep is for wimps…


@Traktion and @Southside that should be the error resolved that you were seeing on Linux when installing the CLI via the install script and attempting to run.
It’s not musl yet (there’s a dependency blocker stopping that at the moment AFAIK), but it should work for you guys.

Run the install script again with

curl -so- | bash

and let us know if any issues.


when tried ‘safe auth install’ with cargo build created safe executable file, I got this error ‘Cannot drop a runtime in a context where blocking is not allowed. This happens when a runtime is dropped from within an asynchronous context.’ but resolved it with ‘cargo build --release’


I got this error when trying to run ‘node run-baby-fleming’
size: 8 nodes
Launching genesis node (#1)…
Failed to obtain the contact info of the genesis node: No such file or directory (os error 2)

My OS is Ubuntu 20.04.1 LTS
any idea to resolve this? thanks in advance.


@hamarana and @majumba what guidance is it you guys need? We recommend following the instruction in the OP above, it should be really straight forward to see some activity on your own computer at home. A brief cut down list of steps you can follow on a terminal if the OP is too verbose:

  1. curl -so- | bash
  2. safe auth install
  3. safe node install
  4. safe node run-baby-fleming

At that point you should have 8 nodes up & running on your machine - easy!

Want to see the logs of the nodes to see what they’re doing?:
tail -50f ~/.safe/node/baby-fleming-nodes/sn-node-genesis/sn_node.log
Note that you can swap genesis part in the above command for any of the other node logs, e.g. 2, 3, 4, 5, 6, 7 or 8.

Want to add another local node to it?"
safe node join
Try doing that in a different terminal window while still having the terminal window with the Genesis logs open so you can see the flurry of activity in the log.
And to view the logs of the new node:
tail -50f ~/.safe/node/local-node/sn_node.log

If you enjoyed that then you are just at the beginning! You can then have a look through the CLI User Guide starting here for full instructions and explanations of all the things you can do on your network.


Hey @KafkaLee, does any/part of ~/.safe/node/baby-fleming-nodes exist on your filesystem?

1 Like

yes it is.
~/.safe/node/baby-fleming-nodes/sn-node-genesis$ ls
age_group chunks reward_public_key reward_secret_key transfers

1 Like