SAFE Network Alpha Release!

This is the only part I don’t like. Quite rude

I liked your comments because I’ve been wondering the same for a bit, and you’re right it’s quite fair to ask for an update on “Alpha 2” since like you say it was 2 or 3x overdue.

Ask for an update, or ask if they have pivoted from that original goal (“Alpha 2”), but please don’t be rude or accusatory. Nobody here is trying to spread “BS” sir


And I really do believe this, quite firmly


…that was kind of my way of asking about “alpha 2” though, does anyone know?

Was that idea scrapped instead for a more solid network release, like a “beta” instead, when node aging / resource tests etc are all finished?

Anyone know if “alpha 2” will still come, as was the plan a while back?


I very much think so. Disjoint groups turned out to be a > 10 week issue and not a few short weeks issue. (we hoped 2-3 weeks plus plenty of time to test) The plan is to push ahead as soon as we can. In another way though i thought the core guys time to get a lot of work done in data handling. So a silver lining, but disjoint groups took us by surprise at it’s complexity. We are on it very hard though and will crack it.


And this is exactly why demanding ETAs is foolish, and not giving them is the honest thing to do; programming isn’t like chopping trees.


Totally fine I’m sure nobody here can be mad about that! Very glad to know though and be kept in the loop. We’re all on your side and supporting very hard along the way! Every day the global events show the need for SAFE so no matter what we’ll be here, and the little summaries here and there like this help tremendously for putting things into perspective thanks very much!


Please help.
I’ve downloaded Launcher v0.80 and Demo App. and started installation of both (one by one) but when I clicked Finalize button it just disappeared and nothing happened(?) I can not find it anywhere on my desktop PC (Win 7 64). I repeated procedure couple of times and get the same result, nothing.
After that I find Launcher v0.10 and finally succeed to opened account but now I have another problem with Demo App as link from account direct me again to MadSafe site to download Demo App but I can’t make it work and integrate it in Launcher(?) Also, the part of the same problem is that I can’t registrar my ID(?)

Why nobody write step-by-step numb-dumb guide? I find that common problem with all new crypto platform projects.

Hi just a quick note, please try using the newest launcher. People are having problems with that old 0.8.0 version


Ok, I find that I’ve been already installed Luncher and Demo App. in October and also already Registered ID so it was my mistake. Now I uninstall old one and install a Luncher v0.8.0 beside v0.10.0 and Demo App and finally make it both works.
Next thing I have to see if I’m going to register another ID as I’ve been asked for or to figure out how I can use the old one I’ve registered before(?)


Probably just have to make a new one for quickest success. These are only temporary test networks so things like that get deleted after a certain amount of time.


safe://dir.yvette3 - note to self: write down password of new accounts :expressionless:

Out of 2037 PublicIDs guessed, fell 739 websites :thumbsup:

and that’s just from guessing and retaining those declared… so, likely there are more out there with less obvious names… in the same way as there are Services/sub-domains to PublicIDs I couldn’t guess.


wohoow - that is pretty impressive :open_mouth: slightly more than the ones published here xD

1 Like

Alpha 1 issues.

Having issues getting the demo app running with launcher. I have had it working in the past.

I re downloaded the two apps from maidsafe alpha page and the launcher works but cant authenticate demo app

demo app 0.6.0

launcher 0.8.0


Not great if new people are downloading and have issues. Can someone test this please :slight_smile:

1 Like

I did the same thing here 2 days ago (Win64) and it works fine for me, maybe an OSX issue? Have you checked the #support category?

Maybe add your questions there if you still have trouble. Alpha 2 will be different with most action in the SAFE Browser. Should make things way easier for users.

1 Like

Yes, tyvm! That default download, 503 KB (515,688 bytes), is always a horrible idea… Not sure why there wasn’t any obvious way to get an offline installer, from that SAFE Launcher v0.8.0 - Alpha 1 page and this web site’s download link.

Cool! :slight_smile:

^^ Oic., apparently I didn’t scroll down the page, duh! xD


1 Like

Note sure where to post comments. Install could be smoother. safe_launcher not in $PATH – I found it by hand, here: /opt/maidsafe/safe_launcher/safe_launcher so I try to run it:

/opt/maidsafe/safe_launcher/safe_launcher: error while loading shared libraries: cannot open shared object file: No such file or directory
dpkg -S
apt-get install libgtk2.0-0

/opt/maidsafe/safe_launcher/safe_launcher: error while loading shared libraries: cannot open shared object file: No such file or directory
dpkg -S
apt-get install libnotify4

/opt/maidsafe/safe_launcher/safe_launcher: error while loading shared libraries: cannot open shared object file: No such file or directory
dpkg -S
apt-get install libgconf-2-4

/opt/maidsafe/safe_launcher/safe_launcher: error while loading shared libraries: cannot open shared object file: No such file or directory

apt-get install libnss3

I hope this process will end soon … it would be nice if the deb installed the pre-reqs it needed.

Also – its clearly promising to be a graphical app of some kind. Any chance there might be a non-graphics version of this?

OK, so I start it up: nothing happens, it exits silently. I expected an error message, like “can’t connect to X server” or something like that.

strace /opt/maidsafe/safe_launcher/safe_launcher
ends with
open("/usr/share/locale/en/LC_MESSAGES/", O_RDONLY) = -1 ENOENT (No such file or directory)
close(3) = 0
exit_group(1) = ?
+++ exited with 1 +++

find /usr |grep | grep en

OK, I’m stumped, now. Clearly, I need to install one more thing … what might it be?

1 Like

Unclear what you’ve tried there but you simply need to download the .zip for the launcher and the demo app, from the links in the OP and also then get the Beaker browser:

Once you’ve got those, obviously uncompress them and open a terminal in each folder and run the executable as you were trying to do.

Compiling from scratch is liable to you knowing which is the stable repository and which is work in progress.

1 Like

Unclear why you think that your comment is even remotely helpful. If you
don’t understand what I’m talking about, you probably should not be making
obviously incorrect suggestions.

As indicated in the last dev update, the Alpha 1 network is now offline.


A post was split to a new topic: Getting SAFE Browser to work on Debian 9