SAFE Network Alpha Release!

Everything looks better on the SAFE Browser :smile:

MMmmmmm… that’s some sweet safe:// protocol :wink:

6 Likes

Mmmmmm… I’m lovin’ it!

1 Like

Stupid question after installing safe-launcher, what is the command to run it?

wget -O - http://apt.maidsafe.net/repos/maidsafe.apt.gpg.key|sudo apt-key add -
sudo wget -O /etc/apt/sources.list.d/maidsafe.list http://apt.maidsafe.net/repos/maidsafe.list
sudo apt-get update
sudo apt-get install safe-launcher
???

1 Like

The binary is called:

safe_launcher

so type that into a terminal.

On my system, Debian stable (Jessie), that command runs the launcher.

The path was:

/opt/maidsafe/safe_launcher/safe_launcher

…which made me curious because that’s not on my PATH. A search revealed that the installation procedure puts a symlink on my PATH:

/usr/bin/safe_launcher -> /opt/maidsafe/safe_launcher/safe_launcher

2 Likes

Thanks, it worked. But that makes no sense. If the launcher is installed with sudo apt-get install safe-launcher. Logic would tell you the command to run the launcher would be safe-launcher not safe_launcher. :unamused:

2 Likes

Perhaps because one is the name of the application while the other is the name of the executable.

In cases where I am lost finding something in the file haystack (not on this occasion) I’ll open a terminal and search on part or whole of its name, and that might require more than one iteration on different variations.

$ find / -iname safe-launcher 2>/dev/null

(nope)

$ find / -iname "safe*" 2>/dev/null

(bingo, finds the symlink in /usr/bin)

$ which safe*

(bingo again, finds the symlink)

3 Likes

This is a very good point and is probably an oversight in the debian package setup process.

Should be correctible easy tho by having the symlink in /usr/bin called safe-launcher for debian which can then point to the internal binary /opt/maidsafe/safe_launcher/safe_launcher

Will certainly keep a note of this to correct it for future debian packages without which it does make it quite confusing. Sorry for that mess there.

7 Likes

This seems to be an issue with debian packaging guidelines not allowing _ in program name

I would say either rename the program to safe-launcher to make it compatible or at least include both safe-launcher and safe_launcher as symlinks. It would be bad to have different distros start the program by different command.

Good call - executables with underscores or dashes in them are annoying in general too, IMO. It just makes them more difficult to type/remember, especially when you can’t tab complete (or don’t know how to).

safelauncher, safedemo, etc, would be better, IMO.

2 Likes

Or safenetwork and safedemo etc :wink:

3 Likes

It’s an alternative to capitalization, which would be even worse.

1 Like

I am using osx 10.11.5, I have the alpha launcher running, when I execute the demo app I get the message that it is installed successfully but the safe launcher doesn’t show any app asking for permissions. What am I missing?
I have set up the pac so I can see safe sites but the demo app is still not showing up in the launcher.

@optictopic I’m on same os as you and haven’t had that problem but just as a trouble shooting suggestion open up activity monitor and see if there are any other demo app or launcher instances running and force quit them. That’s something I had going on in a previous release on Mac and David told me to look there it solved my issue. Not sure if it’ll help but something to try till someone else gets to you

1 Like

I gave that a try but the Demo app is still not recognized by the launcher.

1 Like

Probably not the case but you are using the latest version of the demo app right?

safe_demo_app-v0.6.0-osx.pkg

You need to start the launcher, login or create account, then start the demo app. It won’t show up in launcher until then.

4 Likes

I had assumed that downloading and installing the demo app was all that was necessary for the launcher to recognize the demo app. I did not see a demo app icon anywhere but when I did a search for the demo app the icon came up, so everything is good now. Thanks for the help!

4 Likes

A post was split to a new topic: Thoughts on Satoshi’s posts

Alpha looks good from here, no issues and still going strong. :thumbsup:

Out of 378 PublicIDs, fell 132 websites
http://dir.yvette.safenet

Again, that’s all guesswork… let me know any I’ve missed.

1 Like