SAFE Browser v0.8.0 - Release


#22

I just tried building the web hosting manger with mock routing and it doesn’t work sadly… Followed the instructions to the letter, including using the exact Node version recommended. It gets stuck in an endless loop of this…


Greatly appreciate the inclusion of a mock build for SAFE Browser! I am not sure if I am doing something horribly wrong on my end, but I have always had a lot of trouble building the applications for myself.


#23

Hey @DaBrown95, few Qs: you’re using the latest mock version of the browser above (already running when you run web hosting manager)?

What version of OSX are you on?

Also, have you run the mock browser/web hosting manager before?


#24

Also, are you trying to run the app, packaged? or using yarn dev and clicking the ‘simulate mock response’ option?


#25

Hi, Do I have to create new account for this browser??


#26

That’ll depend on your mock vault, @SAFE-FS . Currently this is stored in a tmp folder, so if you reboot your comp (I think… depends on your OS probably), the mock vault would be cleared and you’d need to create a new account.


#27

I dont think it is mock I am using @joshuef. Anyway let me try restarting my PC.


#28

Haha is that you, Ronald? Or Nayeem?

You can just use anything for the invitation token, remember? If it’s Mock.

If not, then make sure you’re going to invite.maidsafe.net remember? To update your IP so it will work. It’s in the Trello I gave u


#29

Ah, sorry. Was totally in ‘mock’ mind on this thread. No you should not need to create a new account for alpha 2


#30

@whiteoutmashups

Vijay here. After I have downloaded the latest version browser and trying to use. It looks like I got to create account. Even after restarting am having the same issue.


#31

For the Alpha versions it’s probably fine to have a separate mockup setup to simulate the network, but in Beta that will be too much of extra trouble for many app developers I think.

I would like to have a web browser that can simulate the network locally and where I can register several user accounts for testing.


#32

Oh great OK Mr. Vijay,

Yes, @frabrunelle from MaidSafe told me you have to use totally different info for your account password and secret or else it might get blocked.

Did you change both yet?


#33

Hey @joshuef,
Running the very latest mock build. Checked the sha’s to make doubly sure everything is okay. I am on macOS 10.13.1, the very latest.
I have been using the mock browser for a while now, A mock web hosting manger is something I have never been able to successfully build myself. (Just never seems to function fully/properly). I downloaded the linked mock build that @Krishna_Kumar posted and that does appear to work fine!

As far as I understand, please correct me if I am wrong, for it to work properly I have to run the app packaged in order for it to properly authenticate with the browser?
When I run yarn dev, I get these nasty errors… This is after removing node_modules and running a clean build just now.


Clicking the ‘simulate mock response’ button does nothing.

The whole reason I am interested in getting this working is because I am building my own Electron app, web manager and email client really are the only two good resources for seeing how to use the Node api. So obviously it would be ideal if I could build them to check that everything is working and to play about with them.


#34

Yes I’ve been running into problems with ‘yarn dev’ (or previously, the gcc / VStudio parts) for years and am glad MaidSafe provides builds :slight_smile:


#35

The mock build for SAFE Browser was a life saver!


#36

Aha, so those errors are as you don’t have the correct version of the client libs installed.

When you’re installing your node_modules fresh, be sure that you have NODE_ENV set to dev.

Also, just FYI, you don’t have to have webhosting to test sites against mock. Just in case you missed it, there’s more about that here: SAFE Browser v0.8.0 - Release


#37

I have been setting NODE_ENV to be dev, is it not enough to set it using export NODE_ENV=dev?

Thanks for pointing that out, although I am building an Electron app so sadly it isn’t so simple for me.


#38

Hmm, no that should do it if you have that exported for when you yarn. Strange. Maybe try a yarn --force just in case (it forces to redownload deps). But there’s nothing overtly wrong there then…

I’ll try locally doing a rebuild etc and check that we’re not missing a step in the docs. (I’m also on latest osx).


#39

Hot reload!

We’ve built the Decorum wallet using Vue and Webpack with it. It’s great to immediately see the effects of what you’re editing in the browser. Using Vue it doesn’t even reload the whole app, but just the component you’re working on.


#40

Sadly yarn --force didn’t solve the issue either. It is a weird error.


#41

Okay, i have the same err here, we’re missing the yarn rebuild step! If you run that (you shouldn’t need to re yarn) and then yarn dev, that’ll be it (hopefully).