SAFE Browser - pages not loading

Hi, just installed the SAFE browser (and trying to get to trust level 1 since this afternoon :laughing: wihtout success) but the safe:// pages/sites i find on this website don’t seem to load… Do I need to run the launcher too? This is gone from the downloads. I used to have an account on the first version fooling around on safenet (desmet.safenet).

1 Like

That previous account will not exist now, as the network was wiped between Alpha and tests.

The browser and authenticator (was launcher) are one and the same now.

You need to have the latest version of the browser from https://github.com/maidsafe/safe_browser/releases/tag/alpha-2 … that is safe-browser-v0.6.0
I would be odd if you have that and cannot see something like safe://hello

2 Likes

I’ve similar doubts. However I read there is need for a NEW account, which I already made, and then I’ve to get a “trusted” status while reading more than 60 minutes OR entering at least 30 topics OR other ways. I’m reading like hell and also “answering” some questions like this and hope to be helpful.

1 Like

You don’t need an account to browse sites… I’m not logged in and can see them.

Edit: did not need - see below apparently has changed to need an account for spam prevention.

Thanks for the clarification on the old accounts!
I download the browser from the maidsafe website hours ago but the (safe://) pages aren’t loading still…

Loaders keep on spinning.

1 Like

I’ve just tested on another vanilla computer… and wonder perhaps you do need an account; as I’m getting the same issue there.

That’s a surprise or a change from previous but in line with the need to prevent spamming of the network. The browser/authenticator appears to retain awareness of account exists for the trivial of user-is-not-spammer even if not logged in.

So, I wonder you need to get to basic level on this forum and get an account. You seem atm to be [Trust Level: basic user], so maybe you can try getting an account setup first.

I do have a trusted level now, and created an account, but nothing changes on the browser.

Close the browser and restart to check but otherwise I’m stumped what that is. Suggest which operating system you’re using, in case someone else can help.

OSX 10.11.6

But it seems that the email tutorial and the other thing is also no connecting.

I can only guess - ?permission based firewall not allowing outgoing?..

yeah, I got that same idea, but I am on my home network. Never got blocked/firewalled before. Strange

That should be because your IP is not whitelisted on the SAFE proxies, which you can do when you create your account, actually when claiming a token. After your IP is set/whitelisted, you should be able to browse sites without loging in the Authenticator.

3 Likes

You need an account and be logged in to be able to authorise the apps. You seem to not be able to log in due to the IP whitelisting I mentioned before.

1 Like

A soon as I get one I’ll try the safe browser and let you know.

1 Like

I am getting an unexpect error message too, when i try to activate using my invite token… anyone any suggestions?

Core error: Unexpected: Could not connect to the SAFE Network

I did it and had some errors but it was about the IP. Try and set it before using the token in the safe browser.

that should do, I hope.

3 Likes

That did the job my friend, many thanks!

1 Like

glad to have helped, I wasn’t sure as a newby “tester” of alpha 2. I also already installed the two “safe” apps webhosting manager and mail

We can exchange some mail, my id is aetherhemera and so will be my first safe-web-page (may be tomorrow or so).

keep in touch

2 Likes

I am having somewhat similar problem. After opening the safe browser I tried to claim a token. then it takes me to log in the safe network forum. After logging in I get this page.

Which ever one I choose, Alpha 2 or Test 19, It will just say Please Wait… stays like that.

I had a hiccup also, but now finally I can “set IP” and after that it works. Maybe try again later, once your on the SAFE Network “Wow mindblown” :stuck_out_tongue:

1 Like