SAFE Beaker Browser: Installation Walkthrough

It doesn’t work on Windows, because the npm package for go-ipfs doesn’t work on Windows (See here). Therefore, “npm install” will fail because it can’t get that dependency.

I tried compiling go-ipfs manually following these instructions.

I successfully compiled it, but npm doesn’t seem to know that it exists. And now I’m stuck, because I know next to nothing about how NodeJS and npm actually works. Maybe there’s a method to manually get npm to install go-ipfs from the compiled version? I don’t know.

Any ideas, @betterthantrav?

If you successfully compiled the browser, what’s the problem?

You know about as much as I do. @joshuef can you help us?

No, not the browser.

I probably should have explained in the beginning of my post that my first steps were to just follow the instructions for Linux and see what happens.

So I cloned the Github repo, changed the branch, and ran npm install

Of course, it didn’t work. So I looked through the output, and it looks like the errors were caused by one dependency that npm couldn’t install: go-ipfs-dep

It’s just a package that the browser needs to compile, because beaker uses IPFS too. Since that package couldn’t be installed via npm, I just compiled that individual go-ipfs package by itself, which is where I got stuck because I wasn’t sure how to make npm use my compiled version to fulfill the dependency (or if such a thing is even possible… Like I said, I don’t much about how npm works and what it can do)

Edit: Here’s my output from running npm install in the beaker directory. I snipped out what looked like irrelevant output, and hid my log-in name…

Ah, you got it going! Brilliant.

Thanks @betterthantrav my node and npm were indeed out of date now. Paul’s beaker works now but I get a problem with sqlite3 for the SafePOC

When I run install, I get a lot of these warning:

And then when I start I get:

Any idea?

1 Like

I think @whiteoutmashups had a similar problem to this.

@DavidMtl that looks to me like the npm run rebuild step is missing in beaker.


Worked, I believe my mistake was to use “npm rebuild” instead of “npm run rebuild”.


Thanks mate! Great directions, installed perfect first try on newest Mint Distro.

Wow this thing moves fast…oh boy I feel some more long nights coming on. The creative juices are flowing for sure!

It is running the js/css perfect. I would say even better than firefox or chrome.

I can’t help it. Here is another page I don’t have linked yet in the menu:


I’ve also tried it today and think it’s really smooth… Done some regular websurfing and it’s very responsive etc … Like it !


@joshuef I am trying to crack the windows installation and I keep getting this error…


exactly what I got stuck with on windows…

can’t wait until I’m back home to my ubuntop :slight_smile:

EDIT: Just tried again now and got that exact same error popup again…

1 Like

Looks like the same error @DavidMtl had above.

npm run rebuild works without errors on windows?

@joshuef this is what I have done so far, but it gives me the above bellow error.

Windows Install Instructions:

Step 01: Sign up for
Step 02: Install Git
Step 03: Open Git Bash C:\Program Files\Git\git-bash.exe
Step 04:
Step 05:
Step 06:

Step 07: Open Git Bash !!!You must close Git Bash!!!

Step 08: Install the latest version of node js

!!!Do not instal the LTS verison!!!

Step 09: Install Mercurial X.X MSI installer

Step 10: Install Go

Step 11: Install latest version of Java

Step 12: Open Git Bash C:\Program Files\Git\git-bash.exe

mkdir c:/browser cd c:/browser
git clone cd beaker
git checkout SafePOC npm install
npm run rebuild npm start

1 Like

not quite, definitely has errors at every step of the installation :stuck_out_tongue:

heh, that’ll be the problem if that’s not rebuilding then,

Sorry windowsers! you’ll have to please be patient for a windows build. Proper packaging and apps for all OSs will likely be my jumping off point for dev, so I’d hope to get them to yall ASAP.


Installataion works fine, thanks @betterthantrav for the excellent and very clear instructions. But… I can’t browse any SAFE sites. {“errorCode”:-1004,“description”:“DnsError::ServiceNotFound”} or {“errorCode”:-18,“description”:“CoreError::GetFailure::GetError::NoSuchData”}

Do I need to configure a proxy somewhere?

No, but you do need to run the launcher.

Edit: you also need to remove .safenet from any address. For example ian.safenet becomes just ian. The browser will then automatically convert it to safe://ian.

The only reason to use a proxy is because modern browsers don’t recognize the safe:// protocol. The proxy converts something a modern browser can recognize ie http://ian.safenet into a format the safe:// protocol can recognize and use.


If you are using the Safe POC, remove the .safenet at the end of the address.


I fear if we don’t stop using .safenet this confusion will continue to grow.

.safenet was meant to be a temporary fix to the limitations of modern browsers. This is why we are building a safe:// specific browser.