Problems with Maidsafe Demo App: unable to create pages nor templates

Hello guys, I tried several times to upload a folder for a website, and after completing the upload it doesn’t show anything.

I thought maybe it was the length of the subdomain so I tried several lengths, including www, and none of them seem to be sticking. After clicking okay, it keeps showing “No service registered”

So I tried to close everything, both the launcher and the demo app, and reloading them again… several times until it showed some weird behavior such as uploading status displayed 108%, the status bar gone crazy way over the limit and not reacting again.

Weird.

While “private data” files seems to be uploaded correctly, neither the template nor the custom website are displayed after successfully uploading the files.

Anybody has any idea?

OS: Microsoft Windows [Version 6.3.9600] (Windows 8.1 Pro)
Privileges: User
Hardware: x64 Intel i7-3612QM CPU @2.10 Ghz / 8GB Ram
Network: 4.6 Mbps down / 1.75 Mbps up / Latency to 8.8.8.8 40ms

Have you set-up the automatic proxy? If so can you see other safe sites?

Yep, the pac is configured, no problem there.
I can navigate to other safenet websites.

Every time I try to go to my supposedly created subdomain:
www.piluso.safenet/
lalala.piluso.safenet/
etc…

in all of them it shows:

{"errorCode":-1004,"description":"DnsError::ServiceNotFound"}

Which seems to be the appropriate response for non existent websites.
The Demo App shows that there is no “No service registered” after it shows the dialog that " service has been published successfully"

I’m having the same issue. And yes I have the .pac file set up. I also had a similar issue when trying to use the examples on a local network awhile back.

I have pretty much the exact same issue @piluso is describing, which I also filed a bug report on JIRA for and have yet to hear anything back about. Launcher and account. Check. Pac file. Check. Demo app. Check. Go into the demo app, set up a public ID. Go and try and upload a website. It tells me it’s uploaded to 100% and then just hangs there infinitely. I go to the site to see if it’s actually uploaded? Error code. Tried to get a template test site going. Same result. Error code.

I just tried again http://lalala.ross.safenet/ - and I was ok.
When you click on “Create Public ID” in the demo app do you see Your Public ID is: piluso?

yep, it says piluso.

1 Like

Cool can you now go back into the Manage Websites and Files screen and create a new service >. When you click next > use the template as a test > and lets hope you see the Service Published screen Then OK > and see your service listed.

sorry I know you have done this already.

1 Like

Here goes again:

And after clicking on OK:

and the browser also confirms the non-existence of test.piluso.safenet/ :

{"errorCode":-1004,"description":"DnsError::ServiceNotFound"}

I registered with another PIN (same password and keyword), and at the Demo App I wanted to create a new public ID, but then I found a surprised: it said that my public ID was already piluso.
I might have created a previous account and assigned piluso in two of them, isn’t this impossible?

Could this be the origin of this problem?

:frowning: ok - I just walked through the full process again from creating a new account in launcher > a new public ID, etc and again I was ok - obviously there is a bug somewhere - just trying to recreate it. If you have time could you please close both apps and start again - new account, public ID, etc

Yep, the account with the new pin was able to create a website.
Weirdddddddd

1 Like

FWIW I often get errors like it saying “No services registered”, but if I either continue (create the same service again and upload - even if fails), or I backtrack and try again, at some point it flips from “No services registered” and shows my service/website there for editing.

It did it again (almost always actually) when I went to update the SAFE webring.

So I say, try again, and like Robbie Burns, you may succeed in the end :wink:

1 Like

http://lalalalalalalalalalalalalalalalalalalalalalalalalalalalalalalal.piluso.safenet/ is online!

2 Likes

There, you see, just one more go and weeeeeeeeeeeeeeeeeeeeeee!

Nobody said uploading to SAFE network’s first testnet would be easy, it simply wouldn’t be Scottish enough :wink:

1 Like

Great minds!! :smiley: that is weird I will log this - it look like @Blindsite2k already has - thank you we will get back to you for sure and I will flag it to the Dev guys.

Cheers @happybeing - RABBIE!! :wink:

2 Likes

It seems that yesterday I created an account with that pin, I created the public ID piluso.
Today I forgot exactly the credentials of that account, and I created another account with very similar credentials.
When it asked for a public ID, I selected piluso as well.

So it was in this second account with ID piluso that wasn’t allowing me to create public pages, although it allowed me to upload private files.

I spent all afternoon trying to figure out if this second account was actually my first (I wasn’t sure if capitalized the password or not), and if the lack of public ID was because the network was resetted.

What’s weird is that I forgot the exact Pin/password of the first time, and I “re-registered a new account” with those exact Pin/password combination (a clear case of cryptomnesia lol), ending up in the very first account I created.

It was in this first account where I assigned the public ID piluso that allowed me to publish the sites, I guess.

Oops! Ignorant Sassanach I am :slightly_smiling:

2 Likes

Hmm yeah I also used the same pin. I’ll try recreating with a different one and see how it turns out. Who would have thought a PIN could cause a glitch like this?

Ok, it is now also part of http://the.safewebring.safenet!

1 Like

How long did you wait after launching the demo? I have not had any issues but I have loaded this numerous times and seen this take some time to sync up before a “service” is recognized. This latency could be anywhere between local user and vault. @Ross