Problems with Alpha 2 Network?



I’ve just downloaded the Persue browser and signed up. I managed to go to the Jams website, but when I tried to upload music the next page said I didn’t have a connection to the Safe Network. I’ve tried other websites, but getting a “Requested service is not found” on each one.

Is Alpha 2 still running? Or am I missing something silly?



Hi Sonder,

What is the name of the browser archive that you downloaded?


I tried several sites and they work normally



I downloaded:


Hey @Sonder
I also get the “No connection to SAFE Network!” when I click to upload in Jams, however I’ve tried some other sites from this list:

and they appear to be fine.


Hi @Sonder,

I’m not quite as quick off the mark as @StephenC was there but I’ve just checked some test sites and they seem okay as well… can you try going to safe://home.dgeddes and let me know if you can get access?



Ah @Sonder also found this

It’s also worth noting that JAMS does not work with the newest versions of Peruse so SAFE Browser is recommended for now.


Should explain why upload isn’t working on latest browser version, and could be why @hunterlester was asking for version :slight_smile:


Hi guys,

thanks for the helpful replies.

I’ve managed to get a few websites working now.

@StephenC ahhh ok, that will be why then. Thanks


Yes, I can see that website


This topic was automatically closed after 60 days. New replies are no longer allowed.