Problem importing private key into Omniwallet


I have a chunk of MaidSafeCoins sitting still since the crowdsale and I need to sell some of them. I have tried to import the private key from and it apparently worked… just that the imported address shown by OW is not mine but a completely different one (empty).

I read in a previous discussion that there were some problems with OW and Chrome so I tried it on Safari as well but got the same result.

Can anyone help me? Is there a way to get access to my coins without going through OW?


OW is the wallet that can read your Maidsafecoins and it’s also the wallet that you can send the coins from. You can’t with blockchain, because Maidsafecoins is a omni token.

I don’t give investment advice, but selling your Maidsafecoins is something that you might later regret.
This is the token of the new internet, but it’s up to you…

Good luck


Yes I agree but I need some cash pretty fast and therefore I want to get rid of a part of my balance. The rest I will definitely hold on to for the long term.


Actually its chrome that works, and the others have problems with sending.

Just make sure that the private key you imported is the correct one and not one that created to receive BTC change

You can check your balance by entering the (public) address into omniwallets front page (check address page)


Nope, it’s the right address. But still when I import the key a completely different one shows up. It’s also not the other address which was created by Blockchain.

I checked on the explorer and the coins are there.

I am using the WIF format which in theory should be supported by OW (the other option, Base58, isn’t). I remember before it was possible to see it in more formats but now it seems like that option has been removed.

Maybe this is one time you need to contact support.

So to be clear,

  • you created yourself a omniwallet wallet
  • you imported the private key (typically starts with a 5
  • and the wallet shows a different public address for that private key you imported
1 Like

Yes that’s exactly the case, except that the private key begins with L1 (it’s in WIF format).

I just wrote an email to OW support.

AH I see

The “L1” format is the compressed format

It should still have worked

Omniwallet says it accepts “hex, b64, WIF, compressed WIF”


I can reproduce the issue, it looks like OW doesn’t really recognize the compressed WIF even it says so. You can try what’s described in the site below if you want to obtain the uncompressed version which does work with OW, although it implies using


Ok I just got an answer from OW, it seems like I need to uncompress the private key using Bitadress or a similar service and afterwards it can be imported properly.

Thank you all for your help!