Pre-Dev-Update Thread! Yay! :D

I sense a community test net.

@yogesh :clap:t2:

31 Likes

Well done @yogesh! :beers:

21 Likes

Cheers folks! :slightly_smiling_face:

25 Likes

Agogometer hovering around 7.5.
I have prior engagements so I will likely miss the update itself,
What I can say is that I have had a 15 node baby-fleming running for nearly 24 hrs now with almost 5Gb in the largest nodes (OK a lot of that is trace level logs) and I am about to fire another 6Gb at it before I go out.
Similar attempts over the past few days have stalled at around a max of 1.3Gb in the largest node. Hopefully a testnet would show the same stability.

14 Likes

Just done a git pull and there are a lot of changes over the past 24hrs. So I;m going to call this last baby-fleming a success and build the latest.
I’ll set it to put around 15GB in total and see whats what when I get back in.

I may be some time, the lawyer has told me not to rule out a custodial sentence.

8 Likes

What have you done now :weary:

5 Likes

I have done nothing, the low life that assaulted my boy got 6 months this afternoon.

So we all went to gloat :slight_smile:

10 Likes

Good to see.

11 Likes

New release of sn_dbc v7.1.0

9 Likes

Saw this comment:

SecuredLinkedList as it is currently implemented has some architectural & design problems that prevent convergence, we can merge this as is for now but we’ll need to re-implement the library following MerkleReg as a guide (or perhaps just wrapping MerkleReg).

In this PR:

I hope this is (or has been) a mother of all bugs in the codebase. The way how no fix in AE, or Membership has led to a working solution just makes me feel there is something lurking in higher levels or in a more central place. Could this be it?

11 Likes

It is for sure a big issue and the fix is again removing code that duplicates a function.

13 Likes

Big changes incoming.

I run a wee script every so often that

pulls the latest github/main
attempts to build it
cleans up from previous runs
starts a local baby-fleming
runs cargo-test

I get errors now on starting the nodes

 Creating '/home/willie/.safe/node/baby-fleming-nodes' folder
Storing nodes' generated data at /home/willie/.safe/node/baby-fleming-nodes
Starting a node to join a Safe network...
Starting logging to directory: "/home/willie/.safe/node/baby-fleming-nodes/sn-node-genesis"
Node PID: 378523, prefix: Prefix(), name: b2597c(10110010).., age: 255, connection info:
"127.0.0.1:36490"
error: Found argument '--network-contacts-file' which wasn't expected, or isn't valid in this context

	If you tried to supply `--network-contacts-file` as a value rather than a flag, use `-- --network-contacts-file`

USAGE:
    sn_node --verbose --skip-auto-port-forwarding --local-addr <LOCAL_ADDR>

For more information try --help
Error: 
   0: Error launching node
   1: Failed to start '/home/willie/.safe/node/sn_node' with args '["-vv", "--skip-auto-port-forwarding", "--local-addr", "127.0.0.1:0", "--network-contacts-file", "/home/willie/.safe/node/baby-fleming-nodes/sn-node-genesis/prefix_map", "--root-dir", "/home/willie/.safe/node/baby-fleming-nodes/sn-node-2", "--log-dir", "/home/willie/.safe/node/baby-fleming-nodes/sn-node-2"]'
   2: Node exited early (status: exit status: 2)

Location:
   /home/willie/.cargo/registry/src/github.com-1ecc6299db9ec823/sn_launch_tool-0.11.0/src/cmd.rs:163

Backtrace omitted. Run with RUST_BACKTRACE=1 environment variable to display it.
Run with RUST_BACKTRACE=full to include source snippets.
5 Likes

This may be why the build is failing.

3 Likes

Of course, I wanted to highlight that we have big changes happening, not ask the team to down tools and change stuff for me :slight_smile:

"Found argument '--network-contacts-file' which wasn't expected" suggests the new arrangements for prefix_map are about to be implemented very soon.

2 Likes

Now you need to pass the contacts file path to each node that is joining, we used to have this before, and we are going back to it since it’s more realistic, if you want to join a network you need to provide your node with that contacts file (rather than expecting it to be somewhere). So it’s not the node who tries to find it in a specific place anymore, but other tools in charge of making sure the path is provided to the node.

We’ve updated our sn_launch_tool to do this, so if you are using it (or use the CLI which makes use of it. Edit: except for a bug we are fixing now), it will not only provide each joining node with the path to it (we use the genesis node’s prefix-map file for this: ~/.safe/node/local-test-network/sn-node-genesis/prefix_map), but also copy this file to the location where then the cilents/CLI will find it by default and be able to connect to the network.

10 Likes

Thanks @bochaco that makes sense. Gotta run now but I’ll poke about some more later tonight.

5 Likes

So to be clear, network-contacts-file is the new name for prefix-map ?

Or is it something else ?

very VERY minor point

is the --interval option for safe node run-baby-fleming deprecated now?
I’m running with safe node run-baby-fleming --interval 5 --nodes 15 but I certainly was not seeing a delay of 5 secs between spawning nodes - seemed like the default 1 sec which is often too fast for me atm.

Not that that can be tested right now until I dig deeper into networks-contact-file but earlier testing threw this up and I forgot till now to mention it

Seeing I’m in niggle mode, heres another small weirdness…

On looking at the contents of ~/.safe/prefix_maps, I get this listing

willie@gagarin:~/.safe/prefix_maps$ ll
total 128
-rw------- 2 willie willie  662 Aug  9 17:36  default
-rw------- 1 willie willie 2746 Aug  8 00:57 'PublicKey(014f..7fe0)'
-rw------- 1 willie willie 2707 Aug  8 23:52 'PublicKey(0150..13e2)'
-rw------- 1 willie willie 2515 Aug  7 19:49 'PublicKey(017b..7547)'
-rw------- 1 willie willie  645 Aug  9 15:42 'PublicKey(0303..4995)'
-rw------- 1 willie willie  646 Aug  5 01:57 'PublicKey(035f..31ca)'
-rw------- 1 willie willie 2490 Aug  7 19:41 'PublicKey(03a3..d590)'
-rw------- 1 willie willie 2975 Aug  5 01:59 'PublicKey(03fd..839d)'
-rw------- 1 willie willie 2514 Aug  5 19:23 'PublicKey(0577..6902)'
-rw------- 1 willie willie  654 Aug  7 19:19 'PublicKey(06fa..2072)'
-rw------- 1 willie willie 2755 Aug  8 19:24 'PublicKey(075d..e459)'
-rw------- 1 willie willie  628 Aug  9 14:53 'PublicKey(078e..9617)'
-rw------- 1 willie willie 2791 Aug  7 19:32 'PublicKey(0bc5..3ded)'
-rw------- 1 willie willie  666 Aug  9 15:34 'PublicKey(0ca9..fa31)'
-rw------- 2 willie willie  662 Aug  9 17:36 'PublicKey(0d2f..2902)'
-rw------- 1 willie willie 2707 Aug  7 19:39 'PublicKey(0f12..f14a)'
-rw------- 1 willie willie 2962 Aug  8 19:15 'PublicKey(0f7a..07a1)'
-rw-rw-r-- 1 willie willie  636 Aug  5 01:31 'PublicKey(1105..02f7)'
-rw------- 1 willie willie 2929 Aug  7 19:27 'PublicKey(12be..d8c9)'
-rw------- 1 willie willie  642 Aug  9 15:13 'PublicKey(12e7..5a90)'
-rw------- 1 willie willie 2563 Aug  8 21:49 'PublicKey(137a..6f8b)'
-rw------- 1 willie willie 2737 Aug  8 01:35 'PublicKey(1472..50da)'
-rw------- 1 willie willie  657 Aug  5 22:59 'PublicKey(148c..6fd4)'
-rw------- 1 willie willie  643 Aug  7 19:25 'PublicKey(14c8..8c8a)'
-rw------- 1 willie willie 2542 Aug  7 19:46 'PublicKey(1562..b1c6)'
-rw------- 1 willie willie  630 Aug  9 15:36 'PublicKey(16ad..0e4d)'
-rw------- 1 willie willie 2757 Aug  7 19:43 'PublicKey(16b2..158e)'
-rw------- 1 willie willie 2954 Aug  5 23:00 'PublicKey(1749..1a5c)'
-rw------- 1 willie willie 2532 Aug  8 19:18 'PublicKey(17c6..8dc7)'
-rw------- 1 willie willie  630 Aug  9 15:26 'PublicKey(1813..531e)'
-rw------- 1 willie willie 2748 Aug  8 19:21 'PublicKey(1878..6e0d)'
-rw------- 1 willie willie 2747 Aug  8 19:11 'PublicKey(1890..f6a8)'

Why would one entry be -rw-rw-r-- when the rest are a more secure -rw------- ?

EDIT: perhaps I should be adding rm -rf ~/.safe/prefix_maps/* to rm -rf safe/node/baby-fleming-nodes as part of my clean up routine?

1 Like

I think that is a good idea at least for now to not confuse things, eventually we should evolve all tools/apps to handle whatever situation/inconsistency there may exist.

I just tried it, it’s a bug, I’ve just added the fix to fix(cli): backing up default prefix map file with genesis key in filename if not found by bochaco · Pull Request #1460 · maidsafe/safe_network · GitHub

6 Likes