Pre-Dev-Update Thread! Yay! :D

As part of the recent refactoring of qp2p, the default local address was changed to ``, on the basis that it is more secure to require users to opt-in to public reachability. Sadly, this change was quite disruptive

Is this perhaps why when attempting to run-baby-fleming with latest releases it complains about port forwarding?


You were right. :disappointed_relieved:


I’ll DM you a suitable address for you to deposit the 100 MAID :slight_smile:


Haha, you didn’t take the bet!

1 Like

I did. I just got distracted with RealLife™ and was forced to send my acceptance using the telepathy protocol whilst dealing with some twat from the DWP who thinks I owe them £56 from 2009.

Make with the MAID or there will be consequences !!!

Death to civil servants, especially ALL DWP employees!!!


Ok mate, send the address!

But expect to be binded one-sidedly thelepathetically to a new pathetic pet soon!

1 Like

Should I stock up on dog-biscuits?
Can I show pictures of an adorable puppy to Mrs Southside?

1 Like

Oh yeah… You are married… Did your Mrs. ever say “I do” or was that also something you decided just by yourself?


I seem to remember not having much option about it…


Father in law with a shotgun? We all been there… :joy:

1 Like

Nah - after 12 year-long engagement, I ran out of excuses.

I’m told the best line from my speech was

“And finally ladies and gentlemen, raise your glasses to the fetus - without whom, none of youse chancers would have got a free meal today”


5304782 refactor!: Simplify node address config and improve validation

Node address configuration has been simplified to just two CLI options:

  • --local-addr to set the local address that will be bound. This still
    defaults to (any IP, random port).
  • --public-addr to set the public address that will be written in
    connection info files/logs. If unspecified, this will be resolved by
    qp2p by querying from a contact, if any, or falling back to the
    resolved local address once bound.

In particular, --first is now a flag, and no longer takes an address

Validation of address parameters has also changed:

  • Public addresses must be concrete (e.g. not or port 0 ) and
    non-loopback (e.g. not ).
  • If the local address uses a loopback IP (e.g. ), a public
    address cannot be specified (since the node will not be public).
  • If --first is set, then either a public address, or a local address
    with a concrete IP, must be specified.

Ultimately this should make the address configuration easier to
understand, and make it harder to start an unreachable node.

Considering my experience in trying to set up a test net on ARM Oracle Cloud, I wonder about the impact of this. I had problems with nodes not advertising their public address before; will this solve the problem or make it impossible to spin nodes on these cloud instances? Time (test nets) will tell, I suppose…


Thanks for sharing this @stout77 I have been banging my head against a wall for 2 days, and this makes me look forward to not doing so again tomorrow. :slightly_smiling_face:


I suspect that this may happen in some port forwarding configurations.
It is better to warn user instead of blocking the access to functions.

sneak peek :slight_smile:


The info logs seem more clear and how cool to see that the entropy checks all pass. Wonder how she’ll fare in a public test. Thanks for sharing @Josh


Nice one! Can I try and crash your party?
Am I right there’s no compalible CLI yet?
Wht is the current sn_node command you’re using to join?

Edit:looks like we now need a genesis-key to join

Edit2: which I painfully typed…am I in?


Ouch, yes we do.
Have almost as painfully as you typing the genesis key :slight_smile: been trying to start one up for a few days and then last night while driving home I had the duh “I have been an idiot light bulb moment”.

Sep 14 04:38:15.439 INFO safe_network::routing::core: Section updated: prefix: (), key: PublicKey(18bf…b7ef), elders: 9f9b23… at, a8f2e2… at, a9803c… at, da0802… at

Taking them offline for now, will wait for an official test before running a community network.


Just FYI, sn_api and sn_cli haven’t been updated for new changes in safe_network yet. I’m working on it just now.

I’ll let you guys know when there’s something compatible.


It seems closing the terminal kills the node?
Tried nohup but I am not familiar with the command may have used it incorrectly?