Please Read: Digital Ocean Maintenance Issue


#42

Yes the more the better, however for alpha2 it is a small number of nodes (200) and none could restart (they delete their vault data on reboot) as node age is not in place (forces restartable vaults). Alpha 3 and 4 cannot come quickly enough really.

Not sure, Viv did a lot of legwork over the weekend forcing merges and similar tricks, but we are not confident some of the data is not lost, although we got the invariant back (all nodes seeing the correct network and routing tables).


#43

Yes it is a bit ironic, showing a decentralised network on centralised service :smiley: :smiley: Anyway alpha 2 was about clients, but yip it strengthens the case for sure :wink:


#44

Sorry mate not having a crack, just a bit funny, Im sure you saw the funny side in it too, cheers.


#45

As outlined in this forum post, we’ll be resetting the Alpha-2 network today, wiping user data and restarting the network. We’ll be starting with this quite soon. Note that while this is going on, network connectivity would fail from client apps and the invite server might be unreachable/give other errors too. Digital Ocean also have some power-related maintenance planned today between 17:00-21:00 GMT, therefore we will be aiming to have access restored to the network once this maintenance cycle is complete. We’ll post an update to this thread once everything is sorted and sanity checked.


#47

The Alpha 2 network reset is now complete!

We have tested the network to ensure that the MaidSafe example applications are working as normal, so do not expect any problems, but should you encounter any issues please let us know in this thread and we will investigate.

Following the wipe of all user data due to this reset, the system will no longer recognise your log in details - everyone will become a new user once again.

You will therefore need to go through the process of gaining access to Network credentials. We are aware that many of you may have forgotten how to do this so below is a simple step by step guide to get you back to SAFEty asap:

  1. Ensure you are logged into the forum, the Network will need to check you have Trust Level 1 status.
  2. Open the SAFE Browser, click create an account
  3. Once asked click claim an invitation
  4. This will redirect you to invite.maidsafe.net on the clearnet. This is the step in which the Network will check your forum trust level so make sure you are logged in to the forum in the same browser
  5. Click the SAFE Network logo followed by Alpha-2
  6. At the point you are given your invite token - make sure your registered and current IPs match
  7. Copy and paste your invite token back into the SAFE Browser
  8. Create an account Secret and Password - do not forget these!

You should now have access to the SAFE Network.
Note that you will need to re-authorise apps within the Network and your PUT limit will have been reset.


Is it bad to have multiple accounts
SAFE Network Dev Update - August 30, 2018
Are Safe Vaults servers or not: a discussion
#48

Will the old ‘extra’ invites also work again for those of us who filled up our first account?


#49

I have created this step by step guide with some screen grabs if anyone is having trouble remembering the steps. Let us know if we can help in anyway too :slight_smile:


Asking For A Friend Who Lost His Account Secret
#50

All invites for Alpha 2 were generated yesterday, therefore any invite codes from before the network refresh will no longer be valid


#51

I’ve been encountering ‘-2000: Unexpected (probably a logic error): Could not connect to the SAFE Network’ on and off this morning on the live network. Could anyone confirm this?


E.g., just now using the SAFE web API playground app (when using the connectAuthorised call after initialise and authorise):


#52

I haven’t been able to replicate this yet (though, as you note, it’s on and off, so…).

Just to double check on the invite front: it’s not your IP changing or anything like that?


#53

No. I’m testing it on the 10.0.2 SAFE Browser by the way…


#54

Just re-reading this question @happybeing and wanted to clarify to make sure I was giving the correct info - the actual old ‘extra’ invite codes that you may have been given previously won’t work now, but it’s the exact same process as in you can request new extra invites if required. Hope that makes sense.
All invites for Alpha 2 were generated yesterday, therefore any invite codes from before the network refresh will no longer be valid.


#55

I was wondering the same thing with old invites. Good idea they don’t though cause it could have ended up being s possible problem.


#56

Could do with the “assumes nothing” links to the downloads… I’m doing too much looking for those… the Browser is easy to find but not immediately stumbling over the website upload tool.

Pin perhaps as Alpha2 - Reboot or on the Alpha 2 Community Resources

Browser download for those looking is on https://safenetwork.tech/get-involved/ and at https://github.com/maidsafe/safe_browser/releases/download/0.10.2/safe-browser-v0.10.2-linux-x64.zip

Edit: found web-hosting-manager at https://github.com/maidsafe/safe_examples/releases/tag/0.16.0 works :slight_smile:


#58

All went well and couldn’t find a problem!.. though the downloads should be more obvious for noobs who want to try; so, every opportunity suggest those and assume nothing.
=>
Browser = https://github.com/maidsafe/safe_browser/releases/download/0.10.2/safe-browser-v0.10.2-linux-x64.zip
Web-hosting-manager = https://github.com/maidsafe/safe_examples/releases/tag/0.16.0

Only trivial suggestions then for usability of the web hosting manager

  • There perhaps should be a “ta-da” when the publish succeeds, rather than just returning to the list of public ids
  • Assume “www” as public name for first website… “Service Name - eg www” as a prompt and a helpful bypass of having to state the default.
  • The web-hosting-manager window size, is small relative to the screen available.
  • Progress of the upload not apparent aside from the count on files; so, a large first file might be worrisome unnecessarily.

:+1:


#59

One problem - the IP address reset doesn’t seem to be working https://invite.maidsafe.net
[Choose Testnet] seems to not offer any options and I can’t recall how IP reset worked before but thought that was the route to it.


#60

Hey @davidpbrown, when you get to the https://invite.maidsafe.net/chooser.html page do you see the Alpha-2 option? If so clicking on this should allow you to access the page to update your registered IP


#61

No, that’s what I was expecting to see:
Screenshot

It was there originally just coming to change it that it’s not an option to move through to confirm new IP.


#62

Looks like you have noscripts enabled


#63

Not that… scripts for that domain were enabled and even without the addon enabled, for a time I was getting the same. Yet… it seems to be working again; a couple of switches of IP and the invite appears as normal…so don’t know what that was…