Please Read: Digital Ocean Maintenance Issue


#51

I’ve been encountering ‘-2000: Unexpected (probably a logic error): Could not connect to the SAFE Network’ on and off this morning on the live network. Could anyone confirm this?


E.g., just now using the SAFE web API playground app (when using the connectAuthorised call after initialise and authorise):


#52

I haven’t been able to replicate this yet (though, as you note, it’s on and off, so…).

Just to double check on the invite front: it’s not your IP changing or anything like that?


#53

No. I’m testing it on the 10.0.2 SAFE Browser by the way…


#54

Just re-reading this question @happybeing and wanted to clarify to make sure I was giving the correct info - the actual old ‘extra’ invite codes that you may have been given previously won’t work now, but it’s the exact same process as in you can request new extra invites if required. Hope that makes sense.
All invites for Alpha 2 were generated yesterday, therefore any invite codes from before the network refresh will no longer be valid.


#55

I was wondering the same thing with old invites. Good idea they don’t though cause it could have ended up being s possible problem.


#56

Could do with the “assumes nothing” links to the downloads… I’m doing too much looking for those… the Browser is easy to find but not immediately stumbling over the website upload tool.

Pin perhaps as Alpha2 - Reboot or on the Alpha 2 Community Resources

Browser download for those looking is on https://safenetwork.tech/get-involved/ and at https://github.com/maidsafe/safe_browser/releases/download/0.10.2/safe-browser-v0.10.2-linux-x64.zip

Edit: found web-hosting-manager at https://github.com/maidsafe/safe_examples/releases/tag/0.16.0 works :slight_smile:


#58

All went well and couldn’t find a problem!.. though the downloads should be more obvious for noobs who want to try; so, every opportunity suggest those and assume nothing.
=>
Browser = https://github.com/maidsafe/safe_browser/releases/download/0.10.2/safe-browser-v0.10.2-linux-x64.zip
Web-hosting-manager = https://github.com/maidsafe/safe_examples/releases/tag/0.16.0

Only trivial suggestions then for usability of the web hosting manager

  • There perhaps should be a “ta-da” when the publish succeeds, rather than just returning to the list of public ids
  • Assume “www” as public name for first website… “Service Name - eg www” as a prompt and a helpful bypass of having to state the default.
  • The web-hosting-manager window size, is small relative to the screen available.
  • Progress of the upload not apparent aside from the count on files; so, a large first file might be worrisome unnecessarily.

:+1:


#59

One problem - the IP address reset doesn’t seem to be working https://invite.maidsafe.net
[Choose Testnet] seems to not offer any options and I can’t recall how IP reset worked before but thought that was the route to it.


#60

Hey @davidpbrown, when you get to the https://invite.maidsafe.net/chooser.html page do you see the Alpha-2 option? If so clicking on this should allow you to access the page to update your registered IP


#61

No, that’s what I was expecting to see:
Screenshot

It was there originally just coming to change it that it’s not an option to move through to confirm new IP.


#62

Looks like you have noscripts enabled


#63

Not that… scripts for that domain were enabled and even without the addon enabled, for a time I was getting the same. Yet… it seems to be working again; a couple of switches of IP and the invite appears as normal…so don’t know what that was…


#64

Hello,

I now also get this error with the web-hosting-manager v0.4.4.
I didn’t get it the last time I tried, but that was probably before I made a WebID with the PoC WebID manager app.
So I guess that the WebID causes the error and I need a newer verstion of the Web-hosting-manager?


#65

@draw, you should be fine with this WHM, and the upcoming v0.5.0


#66

This WHM works indeed, thanks!


#67

Just going to reference my dev forum post so it can get attention:

Setting up a digital ocean SAFE network for MaidSafe Asia, any assistance or input is greatly appreciated :+1:


#68

I think there is a bug in safe vault code when several nodes disappear from a section at the same time.

I have created a small test network with min section size = 4 in routing config file. My network has normally 4 nodes which means that all data chunks are duplicated 4 times with one copy in each vault. I have developed a utility to display the number of immutable data chunks and the number of mutable data chunks in each vault. And I observe that these 2 numbers are the always the same in all the vaults.

This kind of setup is useful to observe the number of chunks created by a command: for example this is the way I found this issue.

At one time I deleted 2 vaults by accident in a short interval (I didn’t notice the delay between them). No data was lost because the 2 remaining vaults had still the same values for these numbers. Then I relaunched 2 vaults (one by one, with an enough delay between them) but the 2 new vaults display lower values for these numbers, meaning that some data is not stored in these vaults.

This means that some chunks are duplicated less than 4 times which is not a normal state. This fundamental invariant is not respected, which can be the source of ulterior loss of data.

I think this problem is possibly the root cause of the bad fate of the first alpha 2 network and other past networks. I was considering launching a community network (and this test network was in preparation of it) but the discovery of this problem is blocking for that.

Could someone at @maidsafe analyze this problem?


#69

This could be you losing quorum. So if you had a group set at 4 then you need 3 for quorum. So new nodes my not believe the data, usually that would mean a stalled forever section (well in alpha2). I hope this helps, but let me know if not.


#70

Thanks for your explanations. I understand now what I observe when I try to reproduce the problem with simultaneous deletion of 2 vaults : the 2 numbers I mentioned remain at 0 which is a symptom of the state you just described.

In my initial experiment these numbers weren’t 0. But as I said, I didn’t pay attention to the exact timings and probably the first of the new vaults had time to receive some chunks before the last one died.

Edit: To be clear: what I observed was normal and there is nothing to worry about.


#71

Very troubling info, indeed. I hope this will be remedied when MaidSAFE goes live. I haven’t stored any data in the network, myself. Do I have to go through the invite process, as well?