Permission denied (os error 13)

I need some help here running a node.
I’m getting a “Permission denied (os error 13)”.

$ sn_node -vv --idle-timeout-msec 5500 --keep-alive-interval-msec 4000 --skip-igd --first --local-addr 127.0.0.1:1
Starting logging to stdout
Error:
   0: Cannot start node. If this is the first node on the network pass the local address to be used using --first
   1: Routing error:: Cannot connect to the endpoint: Failed to bind UDP socket
   2: Cannot connect to the endpoint: Failed to bind UDP socket
   3: Failed to bind UDP socket
   4: Permission denied (os error 13)

Location:
   src/bin/sn_node.rs:201

Backtrace omitted.
Run with RUST_BACKTRACE=1 environment variable to display it.
Run with RUST_BACKTRACE=full to include source snippets.
$ sn_node --version
safe_network 0.31.39

Is sn_node supposed to run with root priviliges?

sn_node should run fine as a non-root user.
I have seen this error before but I “solved” it by dropping back to an older version of sn_node.

Looks like this can be solved by going all the way back to Version 0.30.0, so around fifty releases earlier.

It may be a source of problem.

1 Like

Possibly “worked around” rather than “solved” as I have had later releases seemingly working OK.

Well port 1 isn’t exactly the standard port for maidsafe nodes, although it was the port I would see when running baby fleming in the latest version.

If you mean the IP port then it has to be over 1024 as below that you need root access.

2 Likes

I suspect the confusion is over @Vort’s use of :1 to signify point number one in the original list of errors although if sn_node is really attempting to use port 1 then naturally root access is req’d and we have a problem with a daft port no being allocated

I just got this error with sn_cli 0.38.0 and safe_network 0.32.0


willie@leonov:~$ RUST_BACKTRACE=full safe files put -r ~/.fgfs/Aircraft/ThumbnailCache/
Error: 
   0: NetDataError: Failed to get current version: NetDataError: Failed to read current value from Register data: NoResponse

Location:
   /rustc/c8dfcfe046a7680554bf4eb612bad840e7631c4b/library/core/src/result.rs:1897

  ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ BACKTRACE ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
                                ⋮ 2 frames hidden ⋮                               
   3: safe::subcommands::files::files_commander::{{closure}}::he1874d1bb8e98278
      at <unknown source file>:<unknown line>
   4: safe::cli::run_with::{{closure}}::hde1b77550f56abc8
      at <unknown source file>:<unknown line>
   5: <core::future::from_generator::GenFuture<T> as core::future::future::Future>::poll::hb4afedec38d55131
      at <unknown source file>:<unknown line>
   6: tokio::park::thread::CachedParkThread::block_on::h4b7b0e0fbf95d12a
      at <unknown source file>:<unknown line>
   7: tokio::runtime::thread_pool::ThreadPool::block_on::h545f8f897b863791
      at <unknown source file>:<unknown line>
   8: safe::main::h2555b0a43308e615
      at <unknown source file>:<unknown line>
   9: std::sys_common::backtrace::__rust_begin_short_backtrace::ha34c5858aff57cda
      at <unknown source file>:<unknown line>
  10: std::rt::lang_start::{{closure}}::hccc2a1f0cf9113a5
      at <unknown source file>:<unknown line>
  11: core::ops::function::impls::<impl core::ops::function::FnOnce<A> for &F>::call_once::h5edb75ac3af12064
      at /rustc/c8dfcfe046a7680554bf4eb612bad840e7631c4b/library/core/src/ops/function.rs:259
  12: std::panicking::try::do_call::h4398f4e6da05592f
      at /rustc/c8dfcfe046a7680554bf4eb612bad840e7631c4b/library/std/src/panicking.rs:401
  13: std::panicking::try::h3fe03463ab3f9a9d
      at /rustc/c8dfcfe046a7680554bf4eb612bad840e7631c4b/library/std/src/panicking.rs:365
  14: std::panic::catch_unwind::h3f31a496b3e5f0e5
      at /rustc/c8dfcfe046a7680554bf4eb612bad840e7631c4b/library/std/src/panic.rs:434
  15: std::rt::lang_start_internal::{{closure}}::h24e3f631c8bb6bd5
      at /rustc/c8dfcfe046a7680554bf4eb612bad840e7631c4b/library/std/src/rt.rs:45
  16: std::panicking::try::do_call::h9268f45ee0925288
      at /rustc/c8dfcfe046a7680554bf4eb612bad840e7631c4b/library/std/src/panicking.rs:401
  17: std::panicking::try::he93fcdbaacc3daf7
      at /rustc/c8dfcfe046a7680554bf4eb612bad840e7631c4b/library/std/src/panicking.rs:365
  18: std::panic::catch_unwind::hca9f2323bf3773b4
      at /rustc/c8dfcfe046a7680554bf4eb612bad840e7631c4b/library/std/src/panic.rs:434
  19: std::rt::lang_start_internal::hfee0032b3594c35b
      at /rustc/c8dfcfe046a7680554bf4eb612bad840e7631c4b/library/std/src/rt.rs:45
  20: main<unknown>
      at <unknown source file>:<unknown line>

Run with COLORBT_SHOW_HIDDEN=1 environment variable to disable frame filtering.

EDIT: building 0.31.9 now and I’ll try again.