Omni Wallet issue need help

Approx. 24 hrs ago I withdrew BTC from an exchange, sent it to Shape Shift to be exchngd to MSC and sent to my Omni Wallet ( to an address generated by clicking the “new BTC address” key).
It completed the SS transactions, but hasn’t shown up in my Omni Wallet (24hrs later).
If I check the address with omnichest.info I get a “runtime error” screen (???).
What can I do to locate the MSC ?
I am using FireFox on OSX 10.10 which has completed transactions without problems in the past.
Thanks.

you can see if you’ve received them on omnichest.info

As I wrote in the description, If I check the address with omnichest.info I get a “runtime error” screen (???).

ah sorry, didn’t see that. You can also do a balance check on omniwallet…

Well, this is how I’ve known that it hasn’t shown up

Yeah I realise I’m not really helping here :smiley:. Not sure what else you can do, maybe anyone else can help you.

1 Like

Thanks for trying ! I appreciate it.

1 Like

FF doesn’t complete anything, ShapeShift does.

If they didn’t send you anything, you can’t see it. Use blockchain.info.
Contact ShapeShift.

1 Like

Try in Chrome - there are probs with Omniwallet I think. This won’t explain the problem with omnichest.info but maybe that’s a problem with their system. If it doesn’t work in a day or so, take it up with them and see if they’re having a problem. Good luck.

1 Like

Janitor, thanks.
I searched blockchain.info with the address form Omni and it shows 0 transactions, 0 BTC received.
Do I conclude that SS never sent the MSC to that address?
Can you tell me what the hash 160 is?
I contacted SS earlier but they haven’t gotten back to me.
Thanks again, Jopher

Thanks for your reply and sorry for my ignorance here.
Truth be told I am an aging Luddite ( living in a remote area) who is struggling with this stuff
because I think it’s important.
But let me ask you this; so Chrome is a browser and opening omniwallet in
chrome rather than FF should solve some potential problems?

1 Like

If the address has received nothing then omniwallet won’t see anything. Each MAID transaction results in a small amount of BTC appearing on blockchain.info

The issue with browsers is that omniwallet only works properly in chrome. FF does not do all the actions like sending MAID and others

Thanks neo, this helps.
So should I conclude that the SS transaction was incomplete?

Yep, next destination ShapeShift tech support

Stick with it @jopher - sorry I didn’t realise you needed more detail, but yes, you have it right.

Sometimes transactions can take many hours to complete, so do one last check and then take it to ShapeShift as @janitor suggests (if you haven’t already). Come back here if you need more help.

Thanks again!
Can you tell me what the “hash 160” refers to in the blockchain.info screen?

You’re welcome.
See this: https://en.bitcoin.it/wiki/Technical_background_of_version_1_Bitcoin_addresses

I don’t think you need to understand that - if you don’t see any very small BTC confirmed transactions involving your address then they didn’t send you the coins. And it may be unintentional (maybe they did send but the send failed to get confirmed).

1 Like

Unrelated problem to OP. Hoping that anyone can help.

I have an OMNI wallet set up with an offline Armory address. Created a transaction, signed it offline (all signatures valid) and tried broadcasting it. As soon as I try to broadcast the signed transaction I get the following error code;

Transaction failed to broadcast: Transaction rejected by the network.
Reason: 64: non-mandatory-script-verify-flag (No error)

Digging deeper into this error, shows the following from the source code;

// Check whether the failure was caused by a
// non-mandatory script verification check, such as
// non-standard DER encodings or non-null dummy
// arguments; if so, don’t trigger DoS protection to
// avoid splitting the network between upgraded and
// non-upgraded nodes.

Tried sending a different OMNI token, resulted in the same problem.
Examining the transaction details shows that there’s 2 recipients, one being the receiving address I have provided, the other is a ‘Non-standard’ address (starting with a 3=multisig). Is this an address OMNI wallet uses to collect their fees/tx costs? And would this be the reason the tx fails to broadcast?

Anyone else have problems sending OMNI tokens? I could import the private key and try to send it that way. But I’d rather not if it’s not necessary.

Thanks in advance for helping out.

I don’t think we’ve seen this here before so probably worth asking omni if you haven’t already.

1 Like

Thanks for the reply, have sent a support request to omni. Just wanted to check if someone here might have a workaround or a good suggestion. :slight_smile:

1 Like