Non SAFE support

This topic is for community support of issues that are preventing users from enjoying SAFE apps. While not specific to SAFE directly, these problems stand in the way of allowing new users to participate

3 Likes

It is about UEFI Secure Boot, which I don’t know exactly what it is, but if I remember right, it was a way to make my HD as secure as possible a couple of years ago when I bought this machine.*)

The error message I’m getting from VirtualBox is:

Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver is either not loaded or not set up correctly. Please try setting it up again by executing

‘/sbin/vboxconfig’

as root.

If your system has EFI Secure Boot enabled you may also need to sign the kernel modules (vboxdrv, vboxnetflt, vboxnetadp, vboxpci) before you can load them. Please see your Linux system’s documentation for more information.

where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.

I have tried to do the stuff the message says, and followed directions from this link:

https://superuser.com/questions/1438279/how-to-sign-a-kernel-module-ubuntu-18-04

… but the same error message persists.

But hey, I think this is not relevant to SAFE anymore, just problems of my specific system. If you think so too, maybe it is better I try to solve this with VirtualBox or Ubuntu resources. I don’t want to clutter this thread with irrelevant stuff.

2 Likes

Sorry I missed this reply.
I have created a new non SAFE support topic and I’ll get the mods to move your problem there.

1 Like

What is your keyboard locale?
I see from the link you posted that unmatched locales were an issue in one case.
Did you notice any specific error in that long process or did it just Not Work It’s not a problem I have had to deal with so far so we’re in this together :grinning: by we will get there.

1 Like

Secure boot is a setting in the BIOS/UEFI that probably is more secure but also makes so you can’t boot into Linux. Turn off, save and reboot.

Go into BIOS when the computer starts and turn of Secure boot. There might be other changes to do also but start with that.

2 Likes

Googled and not knowing anything more…

If you know what .VMX file is, suggestion the solution might be adding a line:
firmware = "efi"

1 Like

@Southside, thank you so much, and you @tobbetj, @davidpbrown and others too!

It’s likely that I don’t have a chance to look into this for a couple of days, but we will solve this sooner or later. It’s terribly nice to get your support here. :heart:

I use command line stuff regularly, like for a few days every 6-18 months or so, and get to forget everything before the next time I need it arises. It’s always a lot of Googling, copy-pasting, guesswork and feeling of risk. Like doing some brain surgery with winter gloves on, without education, following hazy tips from internets.

So, your help is really appreciated. But, what really got me into this was this post from @gouda123 from about three weeks ago:

That list worked for me as a reminder how cool this whole project is, and what they (you, we…) are trying to achieve here, and how no one else is working toward a solution of the scope Maidsafe is doing. So I just got this strong motivation to help a bit. May not be a large bit, may not come quickly, but I really, really want to be part of the solution, and try to lift this thing up when someone else tries to shoot it down.

Another insight I got is this: One does not need to help with his / her best skills, one just needs to do what one is motivated to do. I might have been of greater benefit with some other skills I have, but I’m bored with that stuff. It is more important to do at least something, than to try to demand your best of yourself and end up doing nothing at all.

I’m looking forward to get things going and make it as beneficial for the SAFEnet as I (or we) can.

6 Likes

Thank you for these kind words, whenever you feel ready to move, lets do it

Yes and it still is for most of us to a far greater extent than we might sometimes want to admit. Once you get to a place where you know you cant break anything that really matters then it is often a case of trying anything, everything cos it might just work… And then if it does work, going back and seeing just why it worked so that hopefully you are in a better place when a similar problem comes along. And sooner or later you find that much to your amazement you actually have a working command of some of these areas that once were totally impenetrable to you.
Just keep at it. Often the best insights come not when you have made it work but when you have made it fail in a different way. Never get upset at yet another bloody error message. If its a different error message, then there is something, no matter how small, to be learned from that.

2 Likes

Life gave me things to worry soon after my last reply, so I have not had time to do anything SAFE related. Seems to be getting easier now, but let’s see.

Lurking here anyway and preparing to do things too, when there is a chance.

5 Likes

Story of my life :sweat_smile:

3 Likes

This topic was automatically closed after 60 days. New replies are no longer allowed.