New Release: Vault Phase 1 (real vault)

I’ve built and run this, it opens and I entered the credentials from my shared vault account but it fails with this familiar error: Core error: Unexpected: Could not connect to the SAFE Network

Am I missing something?! I’m currently able to safe cat safe://test etc but in a different terminal that I have already done safe auth. Is there any thing else to do in the POC browser terminal?

1 Like

It sounds like (since the PoC browser doesn’t have an authenticator :slight_smile: ) you forgot to switch to the NewDay branch?
Make sure you clone the repo and then checkout NewDay:

  • $ git clone
  • $ cd safe_browser
  • $ git checkout NewDay
  • $ yarn && yarn start

Each one more magnificent than the last


Doh! Thanks Gabriel, I forgot the checkout.


Stream straight into vlc if using linux:

safe cat safe://hbyyyydumbcdx4yd55q4bg3yxfjkrw15rbepchpy5izded53useofe5fge | vlc -


@happybeing thanks for that info on libsodium! I’ll definitely have a look at that soon.


Cat a dog!

safe cat safe://hbyyyydgtpdfuspaui6s4yozkyfbogrmf9jrt4zo6ea9nuspbdzhdtbfea | display

Or with NRS:

safe cat safe://lazydog | display

vlc didn’t work for me, complained about fd:/0 or something but the dog displayed! Nice :smile:


I have to say, this is great fun to play with! It’s all so intuitive and easy. No faffing about with registering a server, setting up FTP, DNS, etc. Just a few commands and you’re away! Very cool!


I’m getting the same problem on Ubuntu.

1 Like

The first problem, the double click, is a very old ubuntu problem. Must use the terminal to run the browser.

About the second one, I also get the same error if I try to run the browser (and I checked that I have the correct Vault connection config file).


Yes, that’s the one I meant to quote. It looks like the binary is looking for a local file on @bochaco 's machine! :slight_smile:

1 Like

So, can we create and send test safecoin to each other yet? I tried playing around with keys/wallets, but I couldn’t get it to give me a balance I could transfer to another wallet. I thought it would be fun to play with this if it works! :slight_smile:

1 Like

You can, I am not near the computer right now, but you can create coins, transfer them to friends, create account etc.


Thanks! I’ve just found the right spell! :slight_smile:

safe wallet create --preload 10 --test-coins
Wallet created at: “safe://hnyybyc1yk541etxw5f5r4dafxp18qigy4enjsneeksy1w45a7of7cefhny9e”
New SafeKey created at: “safe://hbyyyybdnmsqmxjn5cpaasxb3gyx4bht9xird1oqn3wj5x4ze9s6wszi33”
Preloaded with 10 coins

safe wallet transfer 1.5 safe://hnyybyx956ise984w6p7ai7tijr6qoh6ha11b35wsiwx4qurch4c5s64dsy9e safe://hnyybyc1yk541etxw5f5r4dafxp18qigy4enjsneeksy1w45a7of7cefhny9e
Success. TX_ID: 12481148043643847385

safe wallet balance safe://hnyybyx956ise984w6p7ai7tijr6qoh6ha11b35wsiwx4qurch4c5s64dsy9e
Wallet at “safe://hnyybyx956ise984w6p7ai7tijr6qoh6ha11b35wsiwx4qurch4c5s64dsy9e” has a total balance of 1.500000000 safecoins

safe wallet balance safe://hnyybyc1yk541etxw5f5r4dafxp18qigy4enjsneeksy1w45a7of7cefhny9e
Wallet at “safe://hnyybyc1yk541etxw5f5r4dafxp18qigy4enjsneeksy1w45a7of7cefhny9e” has a total balance of 8.500000000 safecoins



I’ve been following the safenetwork for a long time. Also lost track of the what-is-what long time ago. Can someone please explain in human language in a few lines what this release means, what it can do and what it can’t do ?

Ha ha ha that’s a good one. In human language.


I am able to transfer coins from one of my wallets to another, but when I tried to transfer some coins to you, I did not get a Success: TX_ID message, and my balance did not reduce.

safe wallet transfer 10 safe://hnyybyc1yk541etxw5f5r4dafxp18qigy4enjsneeksy1w45a7of7cefhny9e safe://hnyybypkizohxe9oaqen1m6rehjzx4md1ezayxnuirw61b6xfw39rwp416y9e

Is that a wallet address or a SafeKey address? I tried sending coins to the from address and this was the response:

safe wallet transfer 1.5 safe://hnyybypkizohxe9oaqen1m6rehjzx4md1ezayxnuirw61b6xfw39rwp416y9e safe://hnyybyc1yk541etxw5f5r4dafxp18qigy4enjsneeksy1w45a7of7cefhny9e
[2019-08-30T23:42:59Z ERROR safe] safe_cli error: [Error] AccessDenied - Couldn’t read source Wallet for the transfer at “safe://hnyybypkizohxe9oaqen1m6rehjzx4md1ezayxnuirw61b6xfw39rwp416y9e”

I can transfer to my other address, but it doesn’t seem to like your wallet URL?

EDIT: Note that the ‘source’ wallet seems to be the ‘to’ wallet address, which makes me think the message may be ambiguous.

1 Like

Here, I transfer from one of my wallets to the other…

safe wallet transfer 5 safe://hnyybycbhu4ybt9r4m9xa6o9snyq49gqo7gaskksypfnbtm1fxej9himmgy9e safe://hnyybypkizohxe9oaqen1m6rehjzx4md1ezayxnuirw61b6xfw39rwp416y9e
Success. TX_ID: 7210224360587966587

safe wallet balance safe://hnyybycbhu4ybt9r4m9xa6o9snyq49gqo7gaskksypfnbtm1fxej9himmgy9e
Wallet at “safe://hnyybycbhu4ybt9r4m9xa6o9snyq49gqo7gaskksypfnbtm1fxej9himmgy9e” has a total balance of 35.000000000 safecoins

safe wallet balance safe://hnyybypkizohxe9oaqen1m6rehjzx4md1ezayxnuirw61b6xfw39rwp416y9e
Wallet at “safe://hnyybypkizohxe9oaqen1m6rehjzx4md1ezayxnuirw61b6xfw39rwp416y9e” has a total balance of 64.999999999 safecoins

So, here, I try to transfer to @Traction
safe wallet transfer 5 safe://hnyybyc1yk541etxw5f5r4dafxp18qigy4enjsneeksy1w45a7of7cefhny9e safe://hnyybypkizohxe9oaqen1m6rehjzx4md1ezayxnuirw61b6xfw39rwp416y9e
But no Transaction ID Success message