New Release: Vault Phase 1 (real vault)

It comes from experience. The host OS endpoint is the weakest link in the SAFE network. A late night Windows update leading to 80% of desktop vaults going offline is not acceptable. It’s why we will need SafeOS.

6 Likes

Sure, Microsoft will release an secret update that will kill all vaults in the same time. I wish that happened. Imagine how big and dangerous safe network would have to be to force US government to create such secret plan and force Microsoft to do that. In such scenario there will be so many other players, like data centers , special safenet hardware, billions of android devices, etc. Network has to recover from 20-30% of vaults loss. Elders will be on linux machines, etc… Don’t cut your legs just because they may fail in distant future.

1 Like
safe cat safe://hbyyyyn48uc44z7o3wjus5jsieu3wfecdzn859e34nmb6sib5ifx393ehh > image.jpg
6 Likes

That wasn’t what I was suggesting. Not sure about you, but any windows machine I ever used suffered and glitched when updates are happening in the background until one or four forced reboots later. Anyway, you all win… I regret using CAPS.

2 Likes

Windows is okay when it works, it’s the enforced restart and updates that will interupt peoples vaults.

2 Likes

Can anyone confirm for me that the following content exists on the shared vault. I can safe cat this but don’t seem to be able to safe cat other people’s stuff…

safe cat safe://dweb/index.html

For example these fail:

safe cat safe://hbyyyynndgnwyik7t6mba3ojxti5ar6r35mbzs9ek6erby8iaqc975b9j4 > a-song.mp3
[2019-08-30T14:56:21Z ERROR safe] safe_cli error: [Error] NetDataError - Failed to GET Published ImmutableData: CoreError(No such data - CoreError::DataError -> NoSuchData)
safe cat safe://test
[2019-08-30T14:56:58Z ERROR safe] safe_cli error: [Error] ContentNotFound - Content not found at safe://test

PWeb POC Issue

Trying the POC browser (safe-browser-pweb-poc-linux-x64) on Ubuntu 18.10 I’m getting an error:

$ ~/safe-releases/2019-08-29\ Fleming\ -\ Phase\ I/safe-browser-pweb-poc-linux-x64/safe-browser 
[main 15:50:21.724] › >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
[main 15:50:21.726] › whoops! there was an uncaught error:
[main 15:50:21.726] › {"message":"Cannot open /home/bochaco/safe/bochaco-safe_browser/node_modules/safe_nodejs/native/index.node: Error: /home/bochaco/safe/bochaco-safe_browser/node_modules/safe_nodejs/native/index.node: cannot open shared object file: No such file or directory","name":"Error"}
[main 15:50:21.726] › >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
3 Likes

I don’t see your public name on shared vault, you must have been storing it in your own local vault I guess, and that’s why you cannot fetch the song file or safe://test.

You need to make sure you place the vault_connection_info.config in the right place as detailed in the OP, and then have your safe_auth restarted so it connects to shared vault to login and/or create an account, then you should authorise your safe_cli so it then connects to the shared vault also.

There was an issue with packaging the browser unfortunately, we are investigating and trying to solve it ASAP, in the meanwhile you can build it from source code from this branch https://github.com/maidsafe/safe_browser/tree/NewDay, yarn and then launch it with yarn start

7 Likes

I guessed this might be the problem so I have copied it again and repeated the steps a couple of times. It looks like I’m still using a local vault but I’m not sure why.

I’ll go again starting with downloading it afresh! Thanks Gabriel.

3 Likes

Ok @happybeing , you can run safe --version to make sure you have v0.2.2, same for safe_auth --version and it should show v0.2.0. Perhaps the issue you have is that you are still running your local vault? I can see safe_auth will find it first before trying with shared vault, so probably make sure you stop your local vault?

2 Likes

I have:

$ safe --version
safe_cli 0.2.2

$ safe_auth --version
safe_auth 0.1.0 <- not 0.2.0

Both downloaded today from the links in last night’s post and it is definitely the version extracted from the archive safe_authenticator_cli-0.2.0-x86_64-unknown-linux-gnu.tar. I just checked.

I only have the one vault running, so not an earlier local vault.

Now doing safe_auth --update

That’s odd, even after update things are still not working and safe_auth --version still reports v0.1.0!

NOTE: One possibility is that other people already had the binaries and that --update worked, but I hadn’t downloaded any of these previously so have the version in the archive, and it seems not to update even though it says it will!

5 Likes

I have the same problem.

3 Likes

Right @happybeing @Sascha, we just spotted a bug then in the version reported by the safe_auth binary. I’ll raise it so we can fix it for next release.

@happybeing I think we can ignore the issue with the wrong version reported by the binary, you should be fine to use it. Not sure if I follow you, what I meant was that to connect to the shared vault you make sure you don’t run any local vault. I tried it and if you have a local vault running, even with the config file in place, the safe_auth seems to first connect to you local one. So can you try stopping/killing any/all your local vaults and then try to use the CLI to connect to shared vault?

7 Likes

Thanks Gabriel, I misunderstood. I was getting a timeout when I tried without first running safe_vault so I thought the idea was to run the vault but with the alternative config.

This timeout still happened after you suggested I make sure I wasn’t running a local vault so I’m still having problems. I’m not sure if I’d updated before that but think I had. Will have to check later.

What is using the ~/.config/safe_vault/blah.config when using the shared vault if it isn’t safe_vault?

3 Likes

I guess the config file name can be misleading/confusing you, but the safe_auth (actually the SCL library) will use it to connect to the shared vault. Likewise, the browser would use it to connect to shared vault.

Also, the shared vault is a vault like the one we are all running locally, it’s just one that is running on a server so people can connect to it instead of running a local one. In fact I believe anyone can run a local vault, and share the config file with its public IP to others to connect to it with CLIs and browser.

7 Likes

I had the same problem. When you run the local vault, it creates the config file … and blows away the other config file that you downloaded from github that allows connecting to shared vault.

Overwrite the config file that the local vault created, with the one from github … and then never run the local vault again to avoid overwriting it again.

8 Likes

I am up and running to the shared vault on the same Windows 10 computer I struggled with yesterday on local vault. Local vault still not working, but shared vaults working great.

Here’s my contribution to the shared vault.

safe cat safe://hbyyyydumbcdx4yd55q4bg3yxfjkrw15rbepchpy5izded53useofe5fge > maidsafe.mp4

6 Likes

I suspect this is the answer! Thanks Tom. Confirmed - my running safe_vault was overwriting the vault config and forcing connection to local vote or a timeout when the safe_vault wasn’t running.

@Maidsafe I suggest the OP is clarified to say that to use the shared vault, do NOT run safe_vault and always copy the shared config, because every time you run safe_vault it resets the config to look for a locally running safe_vault.

7 Likes

I can’t get
$ safe_auth --apps
to work. Am I doing something completely idiotic?

Also:

sascha@Knut-Mint:/mnt/Data/SAFE$ ./safe cat safe://hbyyyydumbcdx4yd55q4bg3yxfjkrw15rbepchpy5izded53useofe5fge > maidsafe.mp4
[2019-08-30T18:44:46Z ERROR safe] safe_cli error: [Error] NetDataError - Failed to GET Published ImmutableData: CoreError(No such data - CoreError::DataError -> NoSuchData)
1 Like

Fragment of new Cyberpunk 2077 – Deep Dive Video:

safe cat safe://cyberpunk/banhammer.mp4 > banhammer.mp4

1 Like

I wonder if safe_vault overwriting the config automatically is wise. It could ask first, or perhaps better an option could be provided to allow or prevent overwriting the config. Thoughts @bochaco?

5 Likes