New Release: Vault Phase 1 (real vault)

Impressive… most impressive!

A bit too late for me to play with tonight, but I’m looking forward to having some fun over the weekend!

Amazing job guys!

11 Likes

I’m on it. Can’t wait to try this out. So exciting! Thank you Devs!

7 Likes

Started a vault … but it seems like it’s “stuck”. I expected to see something more happening. I also do not see any log files being created, or any activity, really.

It tells me it’s writing connection info and that’s where it hangs…

image

5 Likes

Tried to create an account. Got a "thread ‘main’ panicked at 'called Result::unwrap()

I was able to get a backtrace.

6 Likes

That’s timing out when trying to connect to the vault, and because the vault is not running then fails, can you please try restarting the vault and see if you get it to run this time? if not let’s see if some of the other folks can help with the vault issue.

5 Likes

Here’s a pic of both windows, showing that the vault is kinda-sorta running, but seems “hung”. In the other window is the timeout error. … I’ll try vaults from home later. Must be some issue with my work computer.

image

4 Likes

Yeah, I don’t think the vault is ready for accepting connections, the output looks incomplete to me…

4 Likes

Self update is really cool, but a minor discrepency. safe_auth is a flag, safe is a subcommand.

./safe_auth --update
./safe update

Will be very cool when “New exe download url” starts with safe:// instead of https:// :exploding_head:

With permissions, I think it makes sense that any files in /tmp/safe_vault (or the root directory configured by the user) should be 600, and same with files in ~/.config/safe_vault.

Calling ./safe_vault --help connects to the internet to check current vs latest version. Seems very iffy to me when simply calling --help. But the help is very helpful so that’s great!

I did a hello world test uploading some immutable data to a locally running vault, very simple and satisfying. safe cat is strangely awesome.

14 Likes

As @Tom_Carlson, cannot make work with my local Vault (Windows)

but work with the shared Vault…

7 Likes

HI @mav,

Thanks for that feedback on self update!

Regarding the issue with --help: I agree with you - having it connect to the internet before displaying the help menu isn’t a very nice user experience. I can get that changed.

As for the slightly inconsistent self update UI between safe and safe_auth, this is because the 2 apps are intended to be used a bit differently, and the code bases reflect that. safe needs to have a more complex UI, so the code is setup for using subcommands with positional arguments, but we only really need to pass basic options to safe_auth, so the code is only setup for using named arguments and flags. I hope that makes sense.

Cheers,

Chris

13 Likes

This is the expected output, the vault started and is waiting for connections from clients. If you want it to output a little more info of what it’s doing try setting the environment variable RUST_LOG=safe_vault=info in the terminal running the vault (before starting the vault)

14 Likes

Seems a specific windows problem. I’ve tried a local vault on Ubuntu and works. But neither in a computer with windows 10 nor in a VM in another one work.

4 Likes

Milestone day !! Congratulations @maidsafe team :sunny:

I’m in !


Checking target-arch… x86_64-unknown-linux-musl
Checking current version… v0.19.0
Checking latest released version… v0.19.0
Update status: 0.19.0!
Our connection info:
{“peer_addr”:“127.0.0.1:49356”,"peer_(etc etc etc …


12 Likes

Great news! Can we have an ARM version as well? So we can test it on something like a Raspberry? @bart created one for the community network that worked well.

7 Likes

@nevel we built the vault Linux binary with musl libc so I’m hopeful this will work on something like a Rasberry pi - do let us know if this is the case if you get to try (I don’t have one to test with).

With the cli clients we hit some problems trying to build them with musl libc and we’ll need to spend more time on that, but definitely something on our to do list.

See the musl libc mentions in the dev update from August 15th SAFE Network Dev Update - August 15, 2019

EDIT - @nice tried the vault on a pi and it didn’t work, though @happybeing suggests compiling for ARM and even has instructions New Release: Vault Phase 1 (real vault)

15 Likes

I just built the safe_authenticator_cli on a raspberry pi4, it works like a charm with the shared vault :+1:


Secret:
Password:
Account was created successfully!
SafeKey created and preloaded with test-coins. Owner key pair generated:
Public Key = didyouexpectIwouldpastethis
Secret Key = andthistoo?
Exposing service on 127.0.0.1:41805


16 Likes

Not sure if this is related to the move to musl but on Debian 9 I got a GLIBC_2.25 not found error when running safe_auth. Fixed it by following the final post in this thread. Leaving this here in case anyone has similar issues.

.

6 Likes

I just tried, the released vault linux binary doesn’t work on the pi. I’ll try building it

5 Likes

The authenticator isn’t built with musl yet - only vault is for now. We have plans to remove a C dependency that is currently preventing us from building safe_auth and safe with musl, but we’re not quite there yet.

10 Likes

I think you will also need to compile for the ARM (v7?) processor architecture for Raspberry Pi etc. I’m trying to find topics on this atm. With Rust cross compilation this is fairly straightforward (famous last words).

Here’s one - I believe you can ignore all the stuff up front about libsodium now so it might be trivial!

11 Likes