New Release: SAFE Authenticator v0.2.0 & SAFE Mobile browser v0.3.0

@happybeing you need to check the box for the config you wish to use, as per
image

This is open for discussion/improvement though, maybe not completely intuitive?

@Savage No, definitely no need to update IPs any more. What/where are you being asked for that?
If that’s popping up in app then maybe best to delete the app completely then reinstall fresh. Let me know how you get on as potentially others will hit that if it’s an issue so I can update the OP

3 Likes

I did fresh installs on both.


@StephenC lets assume user error. Deleted again and reinstalled again. All good now!

4 Likes

I’ve never seen a circle used as a checkbox before! Is that common? Also, on the right?

I think we’ll need a hint on the page with those graphics.

w00t!

And here’s a plus, the browser back button works with mobile browser on safe://dweb. Desktop browser gives 404’s, see here. Also, I can navigate by inserting a navigation path (e.g. dweb/blog) in the address bar which also fails on the desktop browser.

BUG: One thing though, the browser address bar doesn’t change as I navigate the site, it remains at safe://dweb.

5 Likes

OP Pre-requisites section` updated with vault config information

3 Likes

Lol thanks @Savage, glad it’s sorted. I can only assume it was downloading the old app on your device for whatever reason. Maybe just the new release propagating across different AppCenter servers

1 Like

Maybe consider putting the Github download option first? Far more straightforward than the MS AppCenter rigmarole

4 Likes

The Andriod Authenticator seeking the config seems to default to Downloads with an s… I don’t know if its just me but mine if Download without s … so took a moment to find with show internal files etc.

Also, the confirm passphrase and confirm password boxes unfortunately underlap the keyboard… perhaps just my size of screen but would be better higher up and.or with option to scroll screen and typing those blind.

All working well so far but for a lack of working urls to visit!

:+1:

4 Likes

Opposite experience having done the browser first… github required thinking to expand the assets list for that link… and knowing to look for a .apk link. Github for geeks only…:thinking:

2 Likes

On my first attempt - before I realised the vault cofig that I KNOW works is on the PC not the phone - duh- I got presented with a list of my recent photos to use as config files. Can we maybe add a filter so it only shows .config files?

Threw me for a while as the left side click, suggests only cancel delete and not choose.

Thanks for the feedback @davidpbrown. I remember fixing this last week, maybe I’ll just recheck again to be sure. Could you please confirm that you are not able to scroll when you select any entry field? It’s kind of a passive scroll control which is only scrollable when any of the entry boxes is focused.

1 Like

try
safe://animals
safe://primer
safe://dweb
safe://safe-blues <-- nice picking @JPL
or if really desperate safe://rabc

12 Likes

Seems, we can improve this as there are multiple feedbacks on this. The idea was to allow users to easily switch by selecting the radio button on the right side. Maybe I’ll remove the dialog and provide two button for each item in the list. One for selection and another to delete the file from the app.

7 Likes

Works like that… but unexpected it’s not alao with focus.

2 Likes

I’ll leave the design feedback on the vault selection page for the experts to take into consideration :sweat_smile: I’ll log in the meantime so this feedback isn’t missed.

Updated the OP so that for Android it is the GH links that show first. Look out for the expand option at the bottom of the release to find the apk :smiley:

I am/will be logging bugs, suggestions etc on the GH project board for either the authenticator or browser, so won’t reply to everything in here separately. Will be checking up on comments periodically.

Appreciate all the feedback & comments, keep them coming!

8 Likes

State?.. each time I goto the Authenticator it’s asking I login and hasn’t remembered the browser was allowed… and the browser isn’t making obvious progress loading //primer or complaining that it has no connection.
While typing primer page has completed… though I’d just created another account and not yet authorized the browser… so, last authentication still live in browser. Browser isnt obvious about its having authorized state… some icon missing for that perhaps.

So, it’s the initial setup account page that is not offering scroll on focus … or without focus… passphrase and password pages.

1 Like

On the Authenticator appearing to ask for login again - that sounds like a known issue logged here.

I tried loading safe://primer and it worked for me, took maybe 2-3 seconds or so. I also saw a progress bar the whole time (something that I’d flagged as a bug during development as initially no progress bar was showing anywhere - was fixed). Hopefully any delay in loading & lack of progress bar you saw was temporary. Will look out for this and see if I can replicate again.

The issue you point out about after having logged in as a different user, the last authenticated session is still in progress is an interesting one. I never really considered it as a bug/problem but I can see now that this could cause confusion, lead to somebody posting something as the wrong user, etc. I’ll log that and see if we can find a way to make it clear who is logged in during a session, or kill the session if the authenticator is logged out at any point.
EDIT - as Ravinder points out here the browser uses an unregistered session, so not a problem.

1 Like

So, browser restarted and nice and smooth to authenticate with an Authenticator that looks not logged in… and it worked to become authorized and visit to primer proves that. So, concern if I have two accounts with different intent for control of apps.

Also, surprised the browser fell over… not many other apps open etc and none other do fall down. Is there option to grab bug feedback that’s useful?

5 Likes

@davidpbrown, the authenticator uses an unregistered session. That means it’s just reading the connection info from the authenticator app. You don’t need to login in to the authenticator to allow the browser to connect to the network. or you don’t even need an account.

Also, in the browser we have re-authenticate option in the right bottom menu popup control which can be used to refresh the session (especially when you want to connect to the different vault)

1 Like

Ah yes… of course. I disengage thinking when testing :grinning:

1 Like