New Release: SAFE Authenticator v0.2.0 & SAFE Mobile browser v0.3.0

So, browser restarted and nice and smooth to authenticate with an Authenticator that looks not logged in… and it worked to become authorized and visit to primer proves that. So, concern if I have two accounts with different intent for control of apps.

Also, surprised the browser fell over… not many other apps open etc and none other do fall down. Is there option to grab bug feedback that’s useful?

5 Likes

@davidpbrown, the authenticator uses an unregistered session. That means it’s just reading the connection info from the authenticator app. You don’t need to login in to the authenticator to allow the browser to connect to the network. or you don’t even need an account.

Also, in the browser we have re-authenticate option in the right bottom menu popup control which can be used to refresh the session (especially when you want to connect to the different vault)

1 Like

Ah yes… of course. I disengage thinking when testing :grinning:

1 Like

In response to the crash post - if you open the browser again and go to Settings --> App logs then you can hopefully send us the logs where the crash happened

2 Likes

I think the crash maybe related to the browser trying to fetch multiple or lots of data at once in parallel. If I remember correctly, I think the primer has lots of images that maybe causing some kind of high memory consumption and then OS stops/prevents the app so it doesn’t consume any more memory then allowed/allocated to the browser app.

I think, based on logs and feedbacks + device specs like memory and processor, in coming releases I can improve the logic to handle the multiple data request and that will solve this.

3 Likes


@Shane phantom

11 Likes

Thanks @savage, I’m feeling much better now.

It’s loading :tada:, but you wouldn’t be able to create a web app from the mobile browser, not yet cause it’s using an unregistered session and currently we don’t have an interface/bridge for node/JS APIs enabled in the mobile browser. But, I’m sure we will have that some day :smile:

5 Likes

I’m sure you mean, soon :wink:

1 Like

Cheers for that, I only started working on that UI last night and haven’t had a chance to fiddle around with the SAFE browser on mobile yet - I didn’t want to waste time making assumptions about the @css-media values I would need so I just left it unstyled. Expect that to be much more friendly by, say, Friday.

8 Likes

I think, I can pull that off but I’ll definitely need a long break after that :rofl:

3 Likes

I was thinking about asking, then thought we got plenty already and would leave that question for another day.
Thank you!

2 Likes

I once tried to create a POC to check if it’s achievable with our current setup (https://github.com/ravinderjangra/safe-mobile-browser/tree/JSinterface/SafeMobileBrowser) and I was able to make this work (like for one or two APIs) but then we deprecated all the older APIs and put a stop on this so we don’t repeat the efforts with the new APIs. I hope this will still work and I’ll not have to start from scratch.

2 Likes

See then https://github.com/maidsafe/safe-mobile-browser/issues/226

3 Likes

10¹⁰⁰ times thank you Maidsafe devs,

You can’t imagine how super charged, I feel to be on the SAFE Network again.

@Southside safe://safe-blues <-- nice picking @JPL :wave: :sweat_smile:

15 Likes

Maybe when tapped on anywhere have it select deselect and show the check in the circle and have a trash can to the far right for deletion, triggering the delete prompt.

I’m having some issues with the Authenticator I’ll have to test on another device and share later.

1 Like

Huge compliments on the ease of downloading and picking the configuration file, I too was confused by having to specifically tap that little circle to select the file and being shown the delete prompt instead. I’m persistant so I figured it out but should be a little more intuitive.

The apps look amazing with the material update!

7 Likes

Really nice! Feels good browsing from my mobile again! :sunglasses:

5 Likes

Well done @ravinderjangra and all!
Agree on the feedback above re:

12 Likes

Welcome.default page perhaps could suggest which network it’s connected to?.. that it is connected and also perhaps network name.version might useful in the case there any many testnets.

1 Like

Ok I’m having problems navigating to other pages after successfully having visited one.
I.e. typing a new address but the new page is not loading.
Is it just me? How can I troubleshoot?
Edit: on shared vault…I believe? I have the autenticator running, connected to the share vault, but as @davidpbrown pointed out, no way to know which vault the browser is connected to, and the Autenticator doesn’t show any authorisation

1 Like