New Peruse & Web Hosting Manager


#1

The Front End team have been busy and today we are releasing the newest version of Peruse (v0.7.0) and Web Hosting Manager (v0.5.0). You can download both of these from our GitHub now and of course we would love to hear your feedback so post it here!

As you will know our current SAFE Browser is a fork of the Beaker Browser however changes to the Beaker Browser means it no longer meets our requirements. We will be therefore deprecating the Beaker Browser fork on Monday and replacing it with our the Peruse version. To be clear from Monday any download or reference to the SAFE Browser will be the Peruse version.


SAFE Network Dev Update - September 20, 2018
SAFE Network Dev Update - September 13, 2018
Can't seem to get on the net
SAFE Browser Error: Requested public name is not found
#2

Thank you very much! Great work. Could I just, please, again propose a Debian repository for everything related to SAFE. It would be great to have apt-get help one to stay up-to-date.


#3

Awesome! Great work team MaidSafe! :sunny:


#4

It should be noted here that the changes in the DOM APIs may means that some older web apps do not work correctly


#5

:+1:

In Peruse v.0.7.0, like in the Peruse Poc WebId version, I’ve no menu in the top left and no -+x in the top right on Linux Mint 18.3 Cinnamon.
On Windows 10 I see the menu and the -+x, like expected.


#6

Ditto, no menu in Ubuntu so no way to get to the Authenticator other than entering the URI.

Coming together nicely.


#7

Same as above no -+x in top (left I was expecting) on OSX, (new Peruse.)

Got WHM 0.5.0 a couple of weeks ago and it’s been really smooth. :grinning: Only complaint the upload buttons are way off the bottom of the page so it took a minute to find them.

No luck at all with the trips tutorial app from the devhub. Was able to get the default page and at least as far as connect and authorise on the old SAFE browser, but just getting a blank page on the new dev Peruse.


#8

Just a note: If you’re having issues, can you please report them in the safe_browser repo going forwards as this is where we’re managing issues from now on.

@draw I’ll move yours across and tag you in the new issue :+1:


#9

@happybeing what v of ubuntu? I’m on 18 now, and I can still see the menu. But I think as I upgraded, I’m still on unity (as opposed to gnome, which I believe is now the default desktop renderer).

no -+x in top (left I was expecting) on OSX, (new Peruse.)

Yep, I have this. Amazing what you don’t notice when you’re in there every day. Will make an issue for this (and checking out linux too).

edit: https://github.com/maidsafe/safe_browser/issues/362


#10

My Ubuntu came as 16 but I upgraded to 18 and to Gnome soon after. I had the same issue with all versions of Peruse I think - certainly recent ones (on Debian LMDE too before I got my new laptop).

I don’t recall if I used Peruse for the brief time I ran Unity.

I actually thought it was a ‘feature’ of the early software, although I probably did mention it somewhere! Sorry :blush:

I recommend you try Gnome, much better IMO, and of course it is easy to switch back and forth between desktops.