NatNet [May 26 Testnet 2023] [Offline]

Great work!

Functions as expected for me:

[2023-05-27T08:52:35.950460Z INFO safenode::network] Node (PID: 22728) with PeerId: 12D3KooWNterj1zXnTxJwfHKyLQpYFqkxdmyEHtCiFx3YPFwdcMk

Error: We have been determined to be behind a NAT. This means we are not reachable externally by other nodes. In the future, the network will implement relays that allow us to still join the network.

I was asking because I was having a mare cross-compiling. After much pulling of hair cargo clean fixed all my woes.

I have a Pine Rock64 chugging away! :partying_face:


Everything is still working beautifully! :clap: :clap:

safe --peer=/ip4/ files download -- ANT.png ad0c55da8362bbcae4e57b9158f1641033eb9590467d6d0773e46c260f443283

C:\abc>safe --peer=/ip4/ files download -- ANT.png ad0c55da8362bbcae4e57b9158f1641033eb9590467d6d0773e46c260f443283
Starting logging to directory: "C:\\Users\\Sergio\\AppData\\Local\\Temp\\safe-client"
Instantiating a SAFE client...
Current build's git commit hash: ---- No git commit hash found ----
Client successfully connected to the Network.
Downloading file "ANT.png" with address ad0c55da8362bbcae4e57b9158f1641033eb9590467d6d0773e46c260f443283
Successfully got file ANT.png!
Writing 1666945 bytes to "C:\\Users\\Sergio\\.safe\\client\\ANT.png"

In windows why displays double backslash instead of a single backslash?


I’ve had a seemingly working node for about two hours. If it stores some data, where should it be? The tmp/safenodedata/record_store is empty.

But from the log I can find:

[2023-05-27T17:22:05.059122Z TRACE safenode::domain::storage::disk_backed_record_store] Wrote record to disk! filename: 1658257bfab7c8d87d4146f79d2901085728062b1c6f74eb513c47c1006798ac

And that file is found in: C:Users/me/AppData/Roaming/safe/node/record_store

There are 81 files from 1 kB to 21 kB and 14 files from 246kB to 501kB. What are these?

I’m off to sleep now, and can’t leave the node on. But… was I in, was I in, was I in? :thinking: :thinking: :thinking:


Same here, I see files under record_store locally (122 files - 10.3MB total).

Overkill, but ended up giving safenode roughly ~20TB of free space to work with, :smiley: .

Debug version of safenode seems to be holding steady on memory & cpu levels for the past 24+ hrs:

Glad to see the AutoNAT feature detect private vs public swiftly and accurately here!

Nice work Maidsafe team :clap: . Looking forward to the next testnet, as always!


I am not sure why the still shows as ‘not found’ on Alpine 3.17:

safe-alpine:/usr/local/bin# ./safenode --help
-ash: ./safenode: not found

safe-alpine:~# ldd --version
musl libc (x86_64)
Version 1.2.3
Dynamic Program Loader
Usage: /lib/ [options] [--] pathname

I upgraded the Alpine image to 3.18 which includes musl libc 1.2.4, which gave the same error.

I then tried the following:

apk add build-base
apk add gcompat

This didn’t give the errors, but also didn’t work as intended with the --help actually starting up the program automatically:

safe-alpine:/usr/local/bin# ./safenode --help
Starting logging to stdout
[2023-05-27T22:02:16.454168Z DEBUG safenode] Current build's git commit hash: ---- No git commit hash found ----
[2023-05-27T22:02:16.454275Z WARN safenode::peers_acquisition] No SAFE_PEERS env var found. As `local-discovery` feature is disabled, we will not be able to connect to the network. 
[2023-05-27T22:02:16.454744Z INFO safenode] 
Running safenode v0.1.0
[2023-05-27T22:02:16.456273Z INFO safenode] Starting node ...

I went back to downloading the binaries from JoshNet, then DiskNet, then NatNet on the same container (Alpine 3.18). It seems JoshNet’s safenode worked right out of the gate, where as DiskNet and NatNet binaries did not.

I think Alpine uses musl libc instead of glibc compared to other container distribution images? Only way for me to get safenode going on Alpine was to compile from source for this NatNet testnet.

I didn’t participate in DiskNet, so maybe certain changes went in the build process and dependencies against certain libraries that make these release binaries not work on Alpine images anymore?

Are others able to reproduce this issue?


I fired up an alpine container and grabbed

unzipped and moved them to /usr/local/bin

I get the same strange results
safe files upload gets me the help for safenode

/ # safe files upload 
Usage: safenode [OPTIONS] <COMMAND>

  wallet    Manage wallets on the SAFE Network
  files     Manage files on the SAFE Network
  register  Manage files on the SAFE Network
  help      Print this message or the help of the given subcommand(s)

      --peer <PEERS>  Nodes we dial at start to help us get connected to the network. Can be specified multiple times
  -h, --help          Print help
  -V, --version       Print version

safenode --help attempts to start a node…

/ # safenode --help
Starting logging to stdout
[2023-05-27T22:38:34.112166Z DEBUG safenode] Current build's git commit hash: ---- No git commit hash found ----
[2023-05-27T22:38:34.112427Z INFO safenode::peers_acquisition] Using contact peers from $SAFE_PEERS env var to intitiate contact with the network: ["/ip4/"]
[2023-05-27T22:38:34.112461Z INFO safenode] 
Running safenode v0.1.0
[2023-05-27T22:38:34.113252Z INFO safenode] Starting node ...
[2023-05-27T22:38:34.113367Z INFO safenode::network] Node (PID: 77) with PeerId: 12D3KooWLcHrGWiSS5466ENHDNsyqyJZGjirbzHro2vKhNcvgTJi
[2023-05-27T22:38:34.114573Z INFO safenode::network::event] Local node is listening on "/ip4/"
[2023-05-27T22:38:34.114629Z INFO safenode::network::event] Local node is listening on "/ip4/"
[2023-05-27T22:38:34.114859Z ERROR safenode::node::api] Failed to dial 12D3KooWN7AJe7wxVckZ6SF3ybYXVgetQ9hkYWHCHLokpSRC31W2: AlreadyDialingPeer(PeerId("12D3KooWN7AJe7wxVckZ6SF3ybYXVgetQ9hkYWHCHLokpSRC31W2"))
[2023-05-27T22:38:34.448995Z INFO safenode::network::event] Connected with PeerId("12D3KooWN7AJe7wxVckZ6SF3ybYXVgetQ9hkYWHCHLokpSRC31W2")
[2023-05-27T22:38:34.449514Z INFO safenode::network::event] identify: Sent { peer_id: PeerId("12D3KooWN7AJe7wxVckZ6SF3ybYXVgetQ9hkYWHCHLokpSRC31W2") }

So, yes, reproduced the issue.


A bit late, just in case it’s of use
fedora 38 with vpn

[2023-05-26T23:17:01.533131Z INFO safenode] Starting node …
[2023-05-26T23:17:01.533296Z INFO safenode::network] Node (PID: 737) with PeerId: 12D3KooWRnYVUCDji66z6WbpejLpPvvCiokpuWHYRYwv2S4QbVAS (33.0 KB)


Here is my attempt to connect.

Windows 11 Pro

[2023-05-28T13:15:18.096710Z INFO safenode::network::event] AutoNAT status changed: Unknown -> Private [2023-05-28T13:15:18.096728Z WARN safenode::node::api] NAT status is determined to be private! [2023-05-28T13:15:18.096760Z INFO safenode] Node is stopping in 1s... (6.4 KB)

Privacy. Security. Freedom


There should be a lot more screaming going on about the success of this network so:

Team Maidsafe I am beyond happy and excited for you all!


I wondered whether it might matter if I was using a VPN for my test.

So I went back and redid my laptop over mobile b/b hotspot test with Ubuntu 22 but this time twice. Once using my self hosted VPN and once without.

Both times the same result (NAT detected and node shut down).


Is the VPN actually also behind a NAT or does it expose your machine (laptop) to the internet with a public IP address?


Meaning large data or large network? Good either way!


The VPN is hosted in the cloud with Its own fixed IP.


It means both, one, big, and free data network

     .🌟 Ƿ@$$ỉØƝ ⱮΛID  🌟

Here is the PeerId of another Node started behind a NAT in case more evidence is needed:-



Za-dang!!! :boom:


Yes! I can only assume a lot of people are sailing, barbecuing or off doing other good weather things.

They’ll be in for a pleasant surprise when they next log in!

I don’t want to jinx it but is this the most durable network yet (in recent times)?