Messing about with stuff i dont understand :)

@Southside taking off from where we left off.
47.199.80.90:55575
I can only start a genesis node with my internal ip not public but I am learning

Started node 1 (genesis) on 192.168.0.173:55575
[sn_node] INFO 2021-06-09T10:59:58.435205867-04:00 [src/bin/sn_node.rs:106] 

Running sn_node v0.47.5
=======================
[sn_node] TRACE 2021-06-09T10:59:58.460565528-04:00 [src/node/messaging.rs:23] Prefix(), Sending msg: OutgoingMsg { msg: Node(NodeCmd { cmd: System(RegisterWallet(PublicKey::Ed25519(c9191fc4e96a8fd7a5124592b33cf2c3afbbf98250bdef4c33a2516880cf0be3))), id: 879619a4.. }), dst: Section(000000(00000000)..), section_source: false, aggregation: None }
Node PID: 15349, prefix: Prefix(), name: 8db579.., connection info:
"192.168.0.173:55575"
4 Likes

Ok gimme 2 mins to deal with immediate annoying realities here and I will try to join

3 Likes

Hey I have that weird "Two networks set as default thing going on again that I spotted a month or two back

Dont fret @Josh , I will delete the local and try to join your test network right now… just wanted to note this “double default” thingy before I forget

1 Like

Ahh…

willie@gagarin:~$ tail -f /home/willie/.safe/node/local-node/sn_node.log
[sn_node] INFO 2021-06-09T15:14:33.682939428+00:00 [src/bin/sn_node.rs:106] 

Running sn_node v0.47.5
=======================
[sn_node] ERROR 2021-06-09T15:15:33.773617205+00:00 [src/bin/sn_node.rs:125] Cannot start node due to error: Routing(CannotConnectEndpoint { err: BootstrapFailure }). If this is the first node on the network pass the local address to be used using --first. Exiting

and also …

willie@gagarin:/etc/apache2/sites-available$ safe node killall
Success, all processes instances of sn_node were stopped!
willie@gagarin:/etc/apache2/sites-available$ safe node join
Joining network with contacts {47.199.80.90:55575} ...
Storing nodes' generated data at /home/willie/.safe/node/local-node
Starting a node to join a Safe network...
Launching with node executable from: /home/willie/.safe/node/sn_node
Version: sn_node 0.47.5
Using RUST_LOG 'sn_node=debug'
Node to be started with contact(s): ["47.199.80.90:55575"]
Launching node...
Node logs are being stored at: /home/willie/.safe/node/local-node/sn_node.log
willie@gagarin:/etc/apache2/sites-available$ safe keys create --test-coins --for-cli
Error: Failed to connect with read-only access

Caused by:
    ConnectionError: Failed to connect to the SAFE Network: QuicP2p(UnresolvedPublicIp)
willie@gagarin:/etc/apache2/sites-available$
1 Like

ok last try before i go, (i have been trying to use digital ocean to figure this all out but I cant connect to my droplets today)

added a node
Node to be started with contact(s): ["47.199.80.90:55575"]

1 Like

We are having DO problems today, could be the fallout of the fastly thing, not sure, but today it has been impossible for us to start up networks there.

6 Likes

Just started working for me.

3 Likes

How about running a few nodes in house to kick off a public testnet then? :wink:

2 Likes

What’s “DO”?

1 Like

Digital Ocean

2 Likes

Digital Ocean - used to run test nodes in the cloud.

2 Likes

A good few areas of hanging cracked today. It has been in a few areas of the code. I cannot wait to get Dbc in and hopefully make payments and rewards much simpler too. Wallet to wallet xfers are a PITA and loving getting wallets gone.

13 Likes

Is that kind of language allowed here? :stuck_out_tongue_winking_eye:

3 Likes

The spelling is shocking, everyone knows there are 2 Ts in PITA

3 Likes

My trials and tribulations continue with small progress.

I have 7 elders and 2 adults running on DO.
But… despite having been able to run a node from home for each of the latest Maidsafe tests I am not able to join as a node from home.
I get :point_down:
Please ensure that IGD is enabled on your router - if it is and you are still unable to add your node to the testnet, then skip adding a node for this testnet iteration

  • creating tests coins does work, but…
  • when I try to upload data I get an error that the network does not have enough storage available. (I am 2 shy of the 11 which is standard for baby-fleming)

If anyone would like to try and connect so that it can reach 11 nodes please do and let me know if you succeed or not.

rm -rf $HOME/.safe

curl -so- https://sn-api.s3.amazonaws.com/install.sh | bash

safe node install

safe networks set test 206.189.181.79:55579 143.244.159.77:55582 157.230.188.15:55583 157.230.49.200:55584

safe networks switch test

safe node join

2 Likes

i failed

Network 'test' was added to the list. Contacts: '{157.230.188.15:55583, 206.189.181.79:55579, 143.244.159.77:55582, 157.230.49.200:55584}'
sm00thie@DESKTOP-BDSR5AD:/mnt/c/Users/tseko$ safe networks switch test
Switching to 'test' network...
Successfully switched to 'test' network in your system!
If you need write access to the 'test' network, you'll need to restart authd (safe auth restart), unlock a Safe and re-authorise the CLI again
sm00thie@DESKTOP-BDSR5AD:/mnt/c/Users/tseko$ safe node join
Joining network with contacts {206.189.181.79:55579, 143.244.159.77:55582, 157.230.188.15:55583, 157.230.49.200:55584} ...
Creating '/home/sm00thie/.safe/node/local-node' folder
Storing nodes' generated data at /home/sm00thie/.safe/node/local-node
Starting a node to join a Safe network...
Launching with node executable from: /home/sm00thie/.safe/node/sn_node
Version: sn_node 0.48.0
Using RUST_LOG 'sn_node=debug'
Node to be started with contact(s): ["206.189.181.79:55579","143.244.159.77:55582","157.230.188.15:55583","157.230.49.200:55584"]
Launching node...
Node logs are being stored at: /home/sm00thie/.safe/node/local-node/sn_node.log

but

tail -f /home/sm00thie/.safe/node/local-node/sn_node.log
[sn_node] INFO 2021-06-13T07:23:07.387583800+03:00 [src/bin/sn_node.rs:106]

Running sn_node v0.48.0
=======================
[sn_node] ERROR 2021-06-13T07:23:38.411389300+03:00 [src/bin/sn_node.rs:128] Unfortunately we are unable to establish a connection to your machine either through a public IP address, or via IGD on your router. Please ensure that IGD is enabled on your router - if it is and you are still unable to add your node to the testnet, then skip adding a node for this testnet iteration. You can still use the testnet as a client, uploading and downloading content, etc. https://safenetforum.org/
3 Likes

Thanks for trying, I am taking them down now. I may try again in a bit.