MaidSafe Dev Update - September 21, 2017 - Alpha 2


#163

Downloaded and all installed great, signed up smooth as anything, both apps worked great but there are a couple of little things.

On the Web hosting manager when I use template to create website, I click on publish after editing the text but the Publish button does not do anything and cannot publish. It doesn’t freeze it just doesn’t go anywhere.

Also I am being asked to save the .pac file again! Thought this got sorted on a previous testnet… cant remember the details tho

But really easy to install and understand the basics of whats being asked for newbies like myself tho!

Running win7 64 bit


#164

I think you need to remove the proxy that was required back then, but no longer used.


#165

I’ll take a closer look later but for now will suggest this passed the beer test with flying colours :beer:
So, with disclaimer for the user perception …

First impressions having skipped a couple of iterations recently:

  • Web Hosting Manager has taken a great leap forward - the design is really good!.. I especially like the font sizes, which makes for easy reading. I would only push for one notch less gray…
  • It all looks good and is simple to use.
  • I note that I’m thinking about what I’m doing more than worrying about whether the network is working, which I think is a credit to the design and the responsiveness.
  • Network is fast and upload of large files progresses well.

A few problems though mostly minor - the remapping being the biggest… and on Linux if that is a difference…

[Create new folder].[Upload files] on first use - doesn’t… it uploads file=[first alphabetical from the selection]… where there are more files, it requires user navigates back and uploads all but the index.html.

[upload from scratch]+[files] has no memory and each time defaults back to ~/

[Create new folder].[Upload folder] is annoying to make sense of. A website is top level content and subfolders; so, you want to upload [a site] not just a subfolder or a selection of files. Uploading the folder into the “new folder” makes less sense because the index.html is so important on first use. Better and easier to understand would be to adopt the content of the folder uploaded, not the folder itself - and that avoids the need for user to select all files in folder. However, the option to simply upload one subfolder is likely cause… but it’s a minor use relative to uploading whole sites… so perhaps needs to be made a third option along with [upload site]|[upload file]|[upload subfolder]. The problem with the current behaviour compounded because the remapping doesn’t work to compensate for that.

[Remapping] doesn’t seem to offer options to remap to a subfolder, which has been mistakenly uploaded and which then contains the index.html and top level documents… so, no option to reset map to lower level folder.

[Remapping] dropdown isn’t working beyond suggesting one folder - looks to be always the first one I uploaded. So, not useful for remapping atm.

[Create new folder].[Cancel] does not delete the uploaded content in the way perhaps expected. At least a warning or query “do you also want to delete uploaded files” might be appropriate.

Web Host manager’s sub window is not tall enough or fluid enough that the + and bottom detail is visible on first use; so, user has to take initiative to scroll down to find that. Given the + is root to upload files or folder that’s a bit more discovery that should be needed.

Probably something like OCD but I would prefer that the [Home] and [SAFE Hosting Manager] were self referential links not just static… I think that’s because it’s not obvious what it clickable and what is not; so, I want everything to be clickable, even if it’s just to confirm that this is the top level of Home… and I want to refresh the Home to close the expanded >PublicID detail.

I wonder the account status should be displaying in the Web Hosting Manager… rather hidden away from those uploading content.

Location with ‘root-’ seems odd where the service name exists… surely simpler to have as _public/PublicID/ServiceName not _public/PublicID/root-ServiceName

File upload=overwrite seems not available… delete and then upload seems unnecessary extra work

8/10 would use again :smiley:

and as a consequence of playing, the usual suspects:
safe://hello
safe://yvette
safe://heaven
safe://the.teapot
safe://the.odyssey
safe://eye.eye
safe://wall.knot
safe://fear.knot
safe://dir.yvette


#166

@joshuef yes Windows


#167

Bug found:
I click on a clearnet link in the SAFE browser, and it pops up in Chrome. However, this then happens to my address bar. (And yes, I chose to upload the image to safenet just because it is so easy, lol)

[EDIT] This error happened on a mac with chrome. Was clicking on the blog-link in the footer of safe://maidsafe


#169

Wonderful work by all concerned! I don’t understand half of what I’m reading but can make Safe Browser and the Email Tutorial work just fine. You’ve successfully simplified it for those of us that know nothing about development.


#170

A welcome vision to the earth which will encompass the new to activate the pleasant freedom to interact and navigate from any.


#171

greetings everyone
congratulation to the maidsafe team and david:)
I am running the maid web browser I have uploaded a folder which contain the css and html and any file from my website however once I have done that nothing is happening as launch any guidance on the following will be lovely
thank you all


#172

The new site looks amazing! Definitely hats off to @Shona


#173

Now I get it too. Browser was open overnight, and now it gives this error on every site - except safe-auth://home/#/


#174

I had the same problem. Close and open the browser and the problem disappear.

Perhaps it is an error related to the current limits.


#175

Simple question: How do I get an invite code? Where is the invite code topic?


#176

Go to https://invite.maidsafe.net/ and click:
image
and select the network you’d like to get an invitation code to.

EDIT:This response was aimed at @Blindsite2k only because he had already obtained Trust Level 1 a long time ago.


#177

Hey guys, I am trying to play around with the new update. I don’t know why, but I cant “publish” the template of the website. I tried a couple of times, and tried writing different things, but at the end when I press publish, nothing happens. Can someone guide me :sweat_smile:


#178

This appears to be a known problem / bug (see above). The other options are working though AFAIK.


#179

should this https://apps.safenetwork.org/ not reference Alpha 2 instead of Test 19?


#180

@happybeing Thanks a lot…Everything worked great until “publish” step :grinning: I guess I will have to wait until I get to explore more of the update


#181

For those stating they can’t Publish the Template - https://github.com/maidsafe/safe_examples/issues/287


#182

“Core error: Unexpected: Could not connect to the SAFE Network” Seems I can’t register an account.


#183

^You have to click the “Set IP” button. I’m pretty sure I never clicked that button for the past 2-3 tests.